Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

rx2600 Console Output

 
Paul McCleary
Honored Contributor

rx2600 Console Output

Hi,

I'm trying to build an rx2600 and running into a few issues. Basically I can boot off the Dec 05 11i v2 DVD but never get past the stage below:

\EFI\BOOT\AUTO ==> boot :IINSTALL
Seconds left till autoboot - 0
AUTOBOOTING...> System Memory = 2036 MB
loading section 0
............................................................ (complete)
loading section 1
.............. (complete)
loading symbol table
loading ram disk file (:IINSTALLFS).
................................................................................
......
(complete)
Launching :IINSTALL
SIZE: Text:30384K + Data:6821K + BSS:5417K = Total:42623K

I thought it was an issue related to the console output (had no problems building an rx2620) other threads seem to confirm this.

My settings are:

Select the Console Output Device(s)


Acpi(PNP0501,0)/Uart(9600 N81)/VenMsg(PcAnsi)
Acpi(PNP0501,0)/Uart(9600 N81)/VenMsg(Vt100)
* Acpi(PNP0501,0)/Uart(9600 N81)/VenMsg(Vt100+)
Acpi(PNP0501,0)/Uart(9600 N81)/VenMsg(VtUtf8)
Acpi(HWP0002,700)/Pci(1|1)/Uart(9600 N81)/VenMsg(PcAnsi)
Acpi(HWP0002,700)/Pci(1|1)/Uart(9600 N81)/VenMsg(Vt100)
Acpi(HWP0002,700)/Pci(1|1)/Uart(9600 N81)/VenMsg(Vt100+)
Acpi(HWP0002,700)/Pci(1|1)/Uart(9600 N81)/VenMsg(VtUtf8)
Acpi(HWP0002,700)/Pci(2|0)
Save Settings to NVRAM
Exit

I've tried to change standard out, error, input to:

Acpi(HWP0002,700)/Pci(1|1)/Uart(9600 N81)/VenMsg(Vt100+)

Which is what I think it should be, based on Uart and PCI meaning this should be the serial console port. I then save this to NVRAM, another thread suggested a Cold Reset is required, after which the settings always default back to the above. I've also tried to Restore the Default Configuration, but this errors out.

I've tried various console access methods:

- Serial connection with HT (my preferred for initial build)
- Telnet to MP port
- iLO Web access

All cannot get past the stage above.

Firmware versions etc.:

MP FW : E.03.15
BMC FW : 01.53
EFI FW : 01.22
System FW : 02.31

Any ideas/experiences would be much appreciated.

Thanks, Paul
4 REPLIES 4
Paul McCleary
Honored Contributor

Re: rx2600 Console Output

I've now attached my serial cable to the 'console serial' port on the rx2600. I can now see the IUX build process and will be able to build the system.

However, I still don't understand why I cannot change and save to NVRAM the console settings that I want to use, i.e. connecting using the serial MP port (i.e. through the 'w cable', console/serial/ups).

Has anyone else seen this?

Cheers, Paul
Torsten.
Acclaimed Contributor

Re: rx2600 Console Output

You need to have only one star "*" in the list, otherwise the OS will select the first as console and the result will be the same.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Sameer_Nirmal
Honored Contributor

Re: rx2600 Console Output

Hi Paul,

The first behaviour look obvious. The active system console was set to Serial port 1/A (Acpi(PNP0501,0)/Uart(9600 N81)/VenMsg(Vt100+). Thus when kernel is getting loaded, it could have used serial port 1/A as system console output device since it was set in EFI. And that's why you could able to complete the build using the serial port 1/A by direct attach.

The path Acpi(HWP0002,700)/Pci(1|1)/Uart(9600 N81)/VenMsg(Vt100+) belongs to MP serial console. Be aware Serial 1/A and MP serial ports are two different ports.

The only reason I could think of NVRAM issue you stated, is not having common changes in active Output,Input and
Error devices menus. rx2600 does not support different configuration for outut and error console.Similarly, in case of serial console devices, appropriate changes should be done in all 3 menus.
Refer the following document for details at page 3-18 onwards.
http://docs.hp.com/en/5969-3163/5969-3163.pdf

The two serial are mirrored , thus if you have correct entries in all 3 menus, then you should be able to use those ports at a time.
Paul McCleary
Honored Contributor

Re: rx2600 Console Output

Appreciate your responses guys.

Torsten - I was originally trying to change from one to the other so that I would only have one configured. I did also try with multiple console output/input/error set.

Sameer - I know the ports are different and was always trying to set the console output/input/error i.e. all 3 in one go. The doc you reference is one I've already checked and confirmed the procedure I'm using is correct.

The issue is that I'm trying to make the changes and it's not retaining them in NVRAM, just always defaulting back to as I've listed above. So unfortunately I'm still stuck and unable to change and save the settings I want.