Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

rx2600 EFI elilo question

 
David Horowitz
Occasional Contributor

rx2600 EFI elilo question

Hi.

I have recently inherited two rx2600's running RedHat Advanced Server. The root passwords that I was given by the person who set these up do not work. I am currently trying to boot these into single user mode in order to modify the passwords.

I am accessing the EFI/MP through a terminal server hooked into the MP port. I am able to reset the server, and access the elilo prompt through the console. However, when I issue the "linux," "linux single," or "linux console=ttyS0 single" commands, I only see up to the line "Loading initrd initrd-2.4.18-e.31smp.img...done." I believe that if I give it just "linux," I will see an "ATI9" after the loading line. I have also tried using ttyC0 in hopes that it would output to console, but had no luck.

If booting the default kernel, I will eventually be able to access this server via telnet, but I still don't see any console output.

I also connected a terminal server connection to serial port A and watched the output there. This just mirrored what I saw from the MP console output.

What am I doing wrong? How can I view/interact with the console?

thanks,

David

4 REPLIES 4
Matthew_50
Valued Contributor

Re: rx2600 EFI elilo question

try, following

linux emergency
or linux rescue

note: In emergency mode, you are booted into the most minimal environment possible. The root filesystem will be mounted read-only and almost nothing will be set up. The main advantage of emergency mode over linux single is that your init files are not loaded. If init is corrupted or not working, you can still mount filesystems, then simply type 'passwd' to reset root password
Gerben Roest
Occasional Advisor

Re: rx2600 EFI elilo question

Maybe you have to put the serial speed on the command line? Like this:
console=ttyS0,9600,8n1
instead of only console=ttyS0 ?
Matthew_50
Valued Contributor

Re: rx2600 EFI elilo question

please reference http://docs.hp.com/en/5991-0624/5991-0624.pdf for page 7,8,9
David Horowitz
Occasional Contributor

Re: rx2600 EFI elilo question

I was finally able to get back to this issue, and I talked to someone at HP.

It seems that the serial port was selected in the output of the console maintenance menu. The HP rep told me that this could override the other output modes, and the serial port was actually set to ttyS3 and not 0.

Unselecting the serial port, and issuing console=ttyS0 at the elilo prompt allowed me to boot normally from the maintenance port.

-David