Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

rx2600 LAN Console problems

 

rx2600 LAN Console problems

We're running an rx2600 on HPUX 11iV2. Whenever we restart the system, the LAN Console displays everything fine up until /stand/vmunix is launched - then it just hangs and nothing additional is displayed. Here are the last lines that are displayed:

- - - - - - - - - - Prior Console Output - - - - - - - - - -
.............. (complete)
loading symbol table
loading System Directory (boot.sys) to MFS
....
loading MFSFILES directory (bootfs) to MFS
....................
Launching /stand/vmunix
SIZE: Text:30529K + Data:7134K + BSS:5281K = Total:42944K
- - - - - - - - - - - - Live Console - - - - - - - - - - - -

We rebooted 19 days ago and if I connect to it now, the above listing is all that I see.

Any ideas?

Thanks!

Brian
12 REPLIES 12
Bill Hassell
Honored Contributor

Re: rx2600 LAN Console problems

The obvious questions are:

How are you connected to the console (serial terminal, LAN console, KVM)?

What happens when you press the Enter/Return key?

What happens when you type CTRL-B?

If CTRL-B works OK, then it would appear that the console for HP-UX is hung. Can you connect to HP-UX with ssh, remsh or telnet? If so, what does: fuser /dev/console show?


Bill Hassell, sysadmin
Bill Costigan
Honored Contributor

Re: rx2600 LAN Console problems

Can we assume that the system is up? If so then I think the settings for the console is wrong in EFI. Check the EFI console command.

The console can be set to different devices (e.g. serial, VGA, etc.)

I don't recall exactly where you set this, I think under the console config of the boot config menu.

Re: rx2600 LAN Console problems

@Bill Hassell:
I connect via LAN console (i.e. ssh to LAN Console IP) and choose CO at MP Main Menu. Enter/Return does nothing.
CTRL-B returns to MP Main Menu.

fuser /dev/console shows process for:
/usr/sbin/rpc.lockd
/usr/sbin/syslogd -D
/usr/sbin/netfmt -C -F -f /var/adm/nettl.LOG000 -c /var/adm/conslog.opts
/usr/sbin/rpc.statd
/usr/sbin/getty console console

@Bill Constigan:
Yes the system is up. I know that I messed with the EFI settings when I first noticed the problem and I'm pretty sure I set it to VGA. Is there anyway to check the settings WITHOUT rebooting?
Bob_Vance
Esteemed Contributor

Re: rx2600 LAN Console problems

A long time ago, when I was fooling with this situation, I made some notes, which I have attached.

I say therein:

"The bottom line is that I shouldn't have had the
UARTs (serial ports) enabled for it to act like
it does on the PARisc servers and HPUX.
"

But, unfortunately, I'm having trouble understanding exactly what I wrote !?!
But maybe something therein will give you a clue, like the discussion UARTs, PCI, etc.
I do know that I had to reboot each time to make a change.


Also, in the

HP-UX Installation and Update Guide

there is a section,

"Selecting Your HP-UX Console for Integrity Systems"

but doesn't appear to help much.



bv
"The lyf so short, the craft so long to lerne." - Chaucer

Re: rx2600 LAN Console problems

Just some follow-up info... About a year ago, I followed instructions to use the EFI to set VGA to Primary and Serial to Not Configured. This didn't seem to make any difference.

Re: rx2600 LAN Console problems

One other slight correction. If I only have one connection via SSH (or http), then when I press Enter/Return nothing happens.

However, if I make a separate (second) connection with SSH, then when I press Enter/Return, I get

[Read only - use Ctrl-Ecf for console write access.]

And when I use Ctrl-Ecf, I get

[bumped user - Admin]

but then nothing else works or is displayed on either connection (except Enter/Return and Ctrl-Ecf to bump back and forth between connections).

If I disconnect from one of the connections, then Ctrl-Ecf no longer works on the remaining connection.
Torsten.
Acclaimed Contributor

Re: rx2600 LAN Console problems

If the console is set to VGA, you need to reboot and use the boot menu to select serial (over MP) as console.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Bill Costigan
Honored Contributor

Re: rx2600 LAN Console problems

I don't think that is telling up anything.

Cntl-E,c,f will bump another connection. so if you are the second conection you can use it to bump the first. If there is only one connection - there is nothing to bump.

I believe the isssue is that you are connecting to the console but the the HPUX messages are not going to the console because of the console conf in the EFI.

According to some notes I have there are three confs. Consle Output, Console Input and Standard Error Devices

I also read that all three should have a single device selected - It should be the one with the names PCI, Uart and the prefered emulation (e.g. vt100) in the description.
ck3
Occasional Visitor

Re: rx2600 LAN Console problems

HPUX is using a console device other than the serial port on the MP.  Boot to the EFI Shell and use the conconfig command to change your primary console.  There should only be 2-3 choices, so if it's not obvious which one is the MP serial port just try each until you get it.

 

-Charles

Torsten.
Acclaimed Contributor

Re: rx2600 LAN Console problems

There is no "conconfig" on this system, use the menu to adjust the in/out devices.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
S_Logan
HPE Pro

Re: rx2600 LAN Console problems

Hi,

Please check teh EFI Console configuration menu or check the following link:

HP Integrity rx2600 Series - How to Set Up a Console for OpenVMS:

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=ro&taskId=120&prodSeriesId=447334&prodTypeId=15351&objectID=c01672119

 

HTH

Surendar

How to assign KUDOS! Click the STAR!

HP Guided Troubleshooting - www.hp.com/support/hpgt

I work for HPE

Accept or Kudo

S_Logan
HPE Pro

Re: rx2600 LAN Console problems

Hi,

 

You can also check the  similiar solved post:

http://h30499.www3.hp.com/t5/Integrity-Servers/rx2600-iLO-remote-console-amp-OS-Boot/m-p/5266925#M10806

 

HTH

Surendar

How to assign KUDOS! Click the STAR!

HP Guided Troubleshooting - www.hp.com/support/hpgt

I work for HPE

Accept or Kudo