Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

rx2600 no boot, console, or efi; only mp

 
kenichi
Occasional Advisor

rx2600 no boot, console, or efi; only mp

i have connected a serial line to the "console" connector of the "w" dongle, a vga monitor to the vga port of the mp, and a hp usb keyboard. connecting via minicom, i can ctrl-b, get the mp cmd line. i can power on/off, reset, view log, all via mp... but dropping back to the console, or looking at the monitor, i never receive a boot menu or efi. i have also tried connecting to the serial a port (not on the mp or dongle).

the logs state that the system is powered on/off, an acpi message about same, but that's it. the power light is solid green, and the system light is blinking green. the hard drive spins up, the cd eject button does not work (there is no cd in it). here is the output from 'vfp' mp command:

LEDs: SYSTEM POWER
FLASH GREEN ON
LED State: Running non-OS code. (i.e. Boot or Diagnostics)


Loca-| | | |
tion |Alert| Encoded Field | Data Field | Keyword / Timestamp
-------------------------------------------------------------------------------
BMC 2 0x2043FB2793021370 FFFF006FFA220300 Type-02 226f00 2256640
21 Feb 2006 14:45:39

i need to get this system booted, please help! :) thanks...
21 REPLIES 21
Geoff Wild
Honored Contributor

Re: rx2600 no boot, console, or efi; only mp

Did you follow setup:

http://docs.hp.com/en/A9664-90001/A9664-90001.pdf

And check this doc:

http://docs.hp.com/en/5969-3163/5969-3163.pdf

If you are at MP - enter co to get to EFI.

Is this a new system? Did something happen to the hard drive?

Rgds...Geoff

Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
kenichi
Occasional Advisor

Re: rx2600 no boot, console, or efi; only mp

Yes, I have followed the documentation very carefully. My problem is every time it says, "select ___ from the boot menu", there never is a boot menu. if i drop from the MP to the console using 'CO', i never get any response.

this system originally came with 11.23i on it. at some point, a new drive was swapped in, and linux put on it. currently, i'm trying to get it to boot off the original hp-ux drive. i have reseated the drive a few times.
Torsten.
Acclaimed Contributor

Re: rx2600 no boot, console, or efi; only mp

Please check this document:

Default Console: hp integrity rx2600 Server

http://docs.hp.com/en/5971-4238/5971-4238.pdf

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
kenichi
Occasional Advisor

Re: rx2600 no boot, console, or efi; only mp

Serial via the SERIAL A connector
Graphics via the VGA port of the ECI (Extended Core I/O)
Serial via the CONSOLE cable of the ECI (Extended Core I/O)

all of these i have tried with known working serial cables, as the mp interface works through the dongle. no response is received on any of these, using minicom 9600n81 for serial or a known working vga monitor.

LAN via the LAN connector of the ECI (Extended Core I/O)

there hasn't been a network cable plugged into the mp unit for as long as we've owned the box, so i haven't tried to get a console on this device. looking at the config for that via mp command 'lc', it's not even setup (loopback address only).

is there any other configuration that would affect this?
Torsten.
Acclaimed Contributor

Re: rx2600 no boot, console, or efi; only mp

You need to select the correct console and only one at a time. see this link

http://docs.hp.com/en/5187-2725/ch04s03.html

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Marco Hogeveen_1
Trusted Contributor

Re: rx2600 no boot, console, or efi; only mp

You can try to connect your serial cable to the console port on the server itself (so not the M cable on the MP but the top serial connector on the server).

you might need to press Esc-Shift-Q to go to console output. Esc-Shift9 (Esc-( ) gets you back to the BMC console.

If this doesn't work please post the system event log from MP to this thread, maybe there's something interesting in it.

Marco
Alan_152
Honored Contributor

Re: rx2600 no boot, console, or efi; only mp

If you are in the MP, go to SL, select "T"ext", select "A"lert level, "5", then "L"ast. That will give you a list of system messages that are critical failures...
kenichi
Occasional Advisor

Re: rx2600 no boot, console, or efi; only mp

Thank you all for your responses. Here is what I've done so far, without any luck:

- tried powering on the system with only one of each of the following connections:
minicom 9600,n,8,1 to serial a-console (not part of mp)
minicom 9600,n,8,1 to console branch of mp dongle
monitor to vga port on mp

on the serial a-console connection, i can get to BMC:

cli>con
Console Token Settings
Output
PCI UART :(bus e0/700)/PCI(1|1)Uart(9600 N81)/VenMsg(Vt100+)
VGA :(bus e0/700)/PCI(2|0)

Input
PCI UART :(bus e0/700)/PCI(1|1)Uart(9600 N81)/VenMsg(Vt100+)

Error
PCI UART :(bus e0/700)/PCI(1|1)Uart(9600 N81)/VenMsg(Vt100+)

Debug
Serial 2 :Uart(9600 N81)/VenMsg(Vt100+)

Note: *Listed devices aren't necessarily present*

cli>se
# Sev Generator/Sensor Description Event ID Data, Timestamp
---- - ---------------- ------------ ----------- --------------------------
...
1D70 - Power Button Pressed 0D-14:08:01 2006-02-23 11:54:05
1D80 - BMC Chass cntrl 00-12:70:A3 0E:04 2006-02-23 11:54:05
1D90 - Pwr Spply 1 Ctrl Disabled 44-08:09:00 2006-02-23 11:54:07
1DA0 - ACPI State S5 (off) FA-22:6F:05 2006-02-23 11:54:07
1DB0 - BMC Chass cntrl 00-12:70:A3 81:07 2006-02-23 11:55:09
1DC0 - ACPI State S0 (on) FA-22:6F:00 2006-02-23 11:55:12
1DD0 - Pwr Spply 1 Ctrl Enabled 44-08:09:01 2006-02-23 11:55:13
1DE0 - BMC Chass cntrl 00-12:70:A3 83:07 2006-02-23 12:11:23
1DF0 - BMC Chass cntrl 00-12:70:A3 83:07 2006-02-23 12:34:53
cli>q
Password: ******

Admin Session Initiated.
cli>

i tried esc-shift-q, to no avail. esc-shift-9 is what brought up the BMC password prompt.

on the console branch of the mp dongle, i can get to MP (using ctrl-b), but there do not appear to be any critical messages in the log. using the SL command yields more verbose display of the same things in the BMC SE command.

the vga monitor never turns on. am i just missing something horrendously obvious/stupid?
Marco Hogeveen_1
Trusted Contributor

Re: rx2600 no boot, console, or efi; only mp

Your input and output devices are set to the MP's serial port and VGA port, so if you don't get any messages there then you maybe just have a hardware problem?.

Try to post the previous boot log, if I can see where it stops then it may be possible to trac where it's going wrong. Or just log a case at HP.
Alan_152
Honored Contributor

Re: rx2600 no boot, console, or efi; only mp

Change the alert level to 3, and post whatever messages you get out of the SL...
kenichi
Occasional Advisor

Re: rx2600 no boot, console, or efi; only mp

here is the SL output using level 3, entire dump:

Log Entry 7: 00:00:02
Alert Level 3: Warning
Keyword: Type-02 050301 328449
The server's built-in sensors have detected an open chassis door.
Logged by: BMC; Sensor: Physical Security - Chassis Open
Data1: State Asserted
0x2000000002020080 FFFF010302050300


Log Entry 51: 03 Feb 2006 14:39:46
Alert Level 3: Warning
Keyword: Type-02 226f0a 2256650
ACPI state S5 (soft-off, entered by override)
Logged by: BMC; Sensor: System ACPI Power State - ACPI State
Data1: S5 entered by override
0x2043E36B32020370 FFFF0A6FFA220300


Log Entry 113: 03 Feb 2006 15:35:12
Alert Level 3: Warning
Keyword: Type-02 086f03 552707
Power supply AC lost
Logged by: BMC; Sensor: Power Supply - Power Supply 1
Data1: Power Supply A/C lost
0x2043E37830020760 FFFF036F40080300
kenichi
Occasional Advisor

Re: rx2600 no boot, console, or efi; only mp

attached is the "Current Boot" output. "Previous Boot" has 0 entries.
Alan_152
Honored Contributor

Re: rx2600 no boot, console, or efi; only mp

There you go... plug in your #1 power supply (I assume that #0 is up and running), and make sure that the chassis, lid, and door switches are closing properly.
Alan_152
Honored Contributor

Re: rx2600 no boot, console, or efi; only mp

Pay special attention to the top lid switch -- I've had a number of these break or otherwise quit working. Fortunately, they are easy to bypass with a simple jumper block.
kenichi
Occasional Advisor

Re: rx2600 no boot, console, or efi; only mp

ok i believe i've opened and close the lid correctly, at least the log tells me so. i've attached a power cable to the 2nd supply (which until now has had a yellow stopper plug in it). i've tried each of the three console devices again, each time disconnecting the others, but still don't get a boot menu or anything actually. i can still get to the bmc via serial a, and the mp via the console end of the dongle. see the attached mp SL-E-N-D output. i note that it says it loses power redundancy and later gains it...
Alan_152
Honored Contributor

Re: rx2600 no boot, console, or efi; only mp

So, what happens on the console when you go to CM>pc -on ? Do the fans spin up?
kenichi
Occasional Advisor

Re: rx2600 no boot, console, or efi; only mp

the fans start, there are messages about them being ok; as well as the ss command says the processors are on and initialized. the power light is solid green, the system light is flashing green ("non-os code" according to vfp), the hard drive spins up and then waits, there are two solid green lights in the mp unit, whereas there was only one lit when only one power cable was plugged in. the serial console device on the mp dongle only responds to ctrl-b, prompting for login to the mp. the serial a device only responds to esc-(, prompting for the bmc password. the vga never turns on, monitor works fine on the comp used for serial connection. we have another one of these rx2600s rhat "just works" i.e. the boot menu comes up on the vga device about 30 seconds after power on. the visible difference between the two is that the bmc does not list the serial (PCI UART :(bus e0/700)/PCI(1|1)Uart(9600 N81)/VenMsg(Vt100+)) as Output or Input, only vga. according to an "important note" in one of the manuals linked above, it's very crucial to have only one device selected for console interaction: multiple can cause the appearance of system hang, which sounds exactly like what i'm seeing. everything i've read says use the boot menu to select/change this, which is the problem: the boot menu continues to elude me.
Alan_152
Honored Contributor

Re: rx2600 no boot, console, or efi; only mp

OK, rip the MP out (I mean, undo the 4 screws, disconnect the ribbon cable, and remove the board), hook up to the bulkhead serial console, and see what you get out of that....
kenichi
Occasional Advisor

Re: rx2600 no boot, console, or efi; only mp

ok, i've ripped out the mp, the two screws on it, the two holding that huge d-sub guy in, and disconnected the ribbon to the main board.

connecting serial to the "console" serial a port, i can still get to BMC, using esc-(, but no boot menu still. the 'con' command in bmc produces this (still):

Console Token Settings
Output
PCI UART :(bus e0/700)/PCI(1|1)Uart(9600 N81)/VenMsg(Vt100+)
VGA :(bus e0/700)/PCI(2|0)

Input
PCI UART :(bus e0/700)/PCI(1|1)Uart(9600 N81)/VenMsg(Vt100+)

Error
PCI UART :(bus e0/700)/PCI(1|1)Uart(9600 N81)/VenMsg(Vt100+)

Debug
Serial 2 :Uart(9600 N81)/VenMsg(Vt100+)

Note: *Listed devices aren't necessarily present*
Alan_152
Honored Contributor

Re: rx2600 no boot, console, or efi; only mp

Now you need to reset your input and output consoles to serial A (the top DB9M connector). You could try using Seriab B (the bottom DB9M) if that is easier to identify for you.
kenichi
Occasional Advisor

Re: rx2600 no boot, console, or efi; only mp

sorry if i'm being horrendously dense, but how would i do that without the EFI or boot options menu?