Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

rx2620 fails to boot Windows 2003 Server

 
Sao Cin
Occasional Visitor

rx2620 fails to boot Windows 2003 Server

We are using a rx2620 server with Windows 2003 Server Enterprise. It came with two 73GB SCSI drive. One of them had the server. In an attempt to upgrade the firmware, I followed all the procedure, and the firmware was updated properly. But the windows does not boot anymore. Reinstallation is not an option for us due to some valuable data in the boot drive.

I have tried many ways from the EFI menu to boot the server. Also searched the internet on how to boot windows 2003, but every time it says "Load of Windows Server 2003, Enterprise failed: Not Found". I reinstalled the server on the second drive, which installed without any problem. I noticed that on the first drive all the windows OS files in addition to all our files.

How can we get the original drive to boot instead of using the new install. We really need the original drive to boot.

I have even tried exporting from the new install into the importing into the old drive. That just adds a menu item. That menu item does not solve the problem.

Why is the original drive not booting if the OS is actually present. What do I have to do to point the firmware to boot the OS from old drive, not the new drive?

Can I get some help on this? Thanks.
4 REPLIES 4
kris rombauts
Honored Contributor

Re: rx2620 fails to boot Windows 2003 Server

Hi Sao,

not sure why your boot entry doesn't work anymore after a f/w upgrade.
The EFI boot menu entry contains a disk GUID and the hard disk which contains a partition with that GUID will be the disk it loads the Windows Operating System from.

So what needs to be done is likely to verify and possibly reconstruct the EFI boot menu entry such that it contains the GUID from the disk you want to boot from. Maybe this got corrupted somehow.

Reconstructing boot menu entries requires the usage of the EFI hexeditor.
It is best you open a support call with HP so they can help you to fix this boot issue.


HTH

Kris
mits
Respected Contributor

Re: rx2620 fails to boot Windows 2003 Server

Firstly, which firmware you updated, system FW, SAS controller FW or disk drive FW?

Can you access EFI and check to see if you can see any FS devices? For instance, if you have the only one FS volume, it would be fs0. Then try access its volume and check to see if you see a folder "Microsoft" something like below.

fs0:\> ls efi
Directory of: fs3:\efi

12/16/04 04:18a 1,024 .
12/16/04 04:18a 0 ..
12/16/04 04:18a 1,024 Microsoft
0 File(s) 0 bytes
3 Dir(s)

If no FS drive is available, your FS is created on the SAS RAID volume and its RAID volume may be inactivated.
Sao Cin
Occasional Visitor

Re: rx2620 fails to boot Windows 2003 Server

I updated the System Firmware, which HP indicated as a critical update. The firmware version now is 4.29. I have not tried to update any other firmware.

I can go to the EFI shell and see:

fs0, fs1 and fs2.

I can go to fs0: and type ls. Just like windows, I can go to EFI/Microsoft/Winnt50 and saw two hidden files:

BoJt0001
ia64ldr.efi

I believe that BoJt0001 is the file that stores the boot information. I imported it to the efi boot menu using msutil/nvrboot.efi.

But that does not help. When I try to boot using that menu, it says "Load of Windows Server 2003, Enterprise failed: Not found".

I think the problem is in this file. If I can modify this file to point to the partition where the it can load the OS, may solve the issue. But, I do not know how to do that.

Sao
mits
Respected Contributor

Re: rx2620 fails to boot Windows 2003 Server

I do not think updating the system firmware will cause your problem or file corruption. You can open a HP software support call and request a help for more troubleshooting.