Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

rx2620 hangs at boot time

 
Christoph Ernst_2
Occasional Advisor

rx2620 hangs at boot time

Hello,
i have a rx26260 server with two Tachyon XL Fibre Channel adapters. Both adapters are connected to an IBM SAN. On the SAN there are three LUNs configured for my rx2620 server. The server boots from internal SCSI disks.
When i reboot the server, it hangs when the Fibre Channel adapters are found. It hangs, until i disconnect the fibre channel cables from the server. Then it continues with booting. I reconnect the cables then, and the LUN's are visible in the OS and work fine.
Does anybody has an idea what the problem is caused by?
HP service already replaced the backplane and the fibre channel adapters, without success

Thanks,
Christoph
7 REPLIES 7

Re: rx2620 hangs at boot time

Have you tried temporarily zoning your SAN so that the HPUX box can't see anything on the SAN... that would at least tell you if its a problem with scanning for the LUNs, or just a general fabric login issue.

If its a problem with the LUNs, I'd talk to IBM and make sure you have them presented correctly for a HPUX host (HPUX uses volume-set addressing, which usually requires a slightly different LUN presentation than Windows, SOlaris and AIX).

HTH

DUncan

HTH

Duncan

Re: rx2620 hangs at boot time

I assume you ahve already installed the latest FC and SCSI IO subsystem patches as well?

PHKL_31501
PHKL_31507

HTH

Duncan

HTH

Duncan
Christoph Ernst_2
Occasional Advisor

Re: rx2620 hangs at boot time

Duncan,

the patches are installed.

Christoph
Sameer_Nirmal
Honored Contributor

Re: rx2620 hangs at boot time

Hi,

It seems that the across fabric communication/login is not taking place while bootup. During sysem startup , the FC card detection and driver setup routine, "ioscan" runs to scan LUNs attached to the FC cards. I guess the problem could be either with switch or the Storage end.

It may be a case SAN switch doesn't allow HP-UX ( ioscan ) to communicate with the LUN ( nport) at first place. After re-connecting the FC cable , the switch allows the communication with the LUNs. To avoid such peculier problems , it is always better to use zoning.

At the other side , one need to cross-check all OK from IBM array side. If the presenation is done for HP-UX host etc.

I would check for
/etc/rc.log , syslog , dmesg
# ioscan -fn
# fcmsutil
# fcmsutil vpd
# fcmsutil stat
# fcmsutil nsstat
# fcmsutil devstat all
# fcmsutil -k ns_query_ports
# /opt/fcms/bin/tdlist
# /opt/fcms/bin/tddiag

Checking patches , besides mentioned by Duncan
PHNE_32201/PHNE_32277
PHSS_32101

By the way which SAN switch and IBM disk array you are using?
Alan_152
Honored Contributor

Re: rx2620 hangs at boot time

Are you doing a "reconnect -r" from the efi prior to booting the unit, to make sure all your storage devices can be seen?
mits
Respected Contributor

Re: rx2620 hangs at boot time

If your cards are A6795A PCI 4X 2Gbps single port host bus adapter, I would suggest you will check the emulation policy. See web doc below.
http://www.docs.hp.com/en/J6374-90018/ch04s10.html

If your emumeration policy is set as "Enumerate all Fibre Channel devices" the firmware will search entire network and it should takes a very long time. You may think the system gets hung. Suggestion is to change the enumeration plicy to "Enumerate all Fibre Channel boot devices in the boot option list". If you can access HP knowldges database, doc ID KBQA00000574 "How to add FC boot option to the EFI boot menu" has a copy of the web document.
Christoph Ernst_2
Occasional Advisor

Re: rx2620 hangs at boot time

Hello everybody,
the problem is solved. Our customer, who administrates the SAN, changed the setting of the SAN switch ports from GL-mode to F-mode (whatever that means). Now the problem is gone.

Thanks to everybody
Christoph