Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

rx4640 firmware: "Could not set TIMEOUT NVRAM" error

 
Kevin Hardy
Occasional Advisor

rx4640 firmware: "Could not set TIMEOUT NVRAM" error

Hello,

Has anyone else had problems installing firmware updates on an Integrity rx4640? Our rx4640 is running the following firmware right now:

System Firmware: 3.17 [4511]
BMC Version: 3.49
MP Version: E.03.15

I'm trying to upgrade to:

rx4640 Recipe 9.8
System Firmware: 4.29
BMC Version: 4.06
MP Version: E.03.32

But once I get past all of the selection options and just before the installation begins I receive the following error:

/---------------------------------------------------------------\
| (x) ERROR: Could not set TIMEOUT NVRAM variable. |
| |
| OK |
\---------------------------------------------------------------/

I tried going back to a previous firmware release between where I wanted to be and where I am but the only one I could find on the HP download site was for:

rx4640 Recipe 9.6
System Firmware: 4.28
BMC Version: 4.06
MP Version: E.03.32

I tried that and got the same error. I've checked the release notes and I don't see anything that jumps out as a problem with this upgrade path. I did find a mention of this error message in another thread on this forum, but there didn't appear to be an explanation or a resolution:

http://forums12.itrc.hp.com/service/forums/questionanswer.do?admit=109447627+1210514239752+28353475&threadId=1174109


There is a vague reference to the following statement:

"If the System firmware revision is less
than 04.21, if the BMC firmware revision
is less than 04.05 or if the iLO MP
firmware revision is less than E.03.30
then firmware should be updated"

That statement doesn't explain this error, it just states that I should update the firmware and upon that I completely agree. Is there something I'm missing in the prerequisites? Is this a common issue?

Thanks!
2 REPLIES 2
John Travell
Valued Contributor

Re: rx4640 firmware: "Could not set TIMEOUT NVRAM" error

Presuming that the machine is covered by either warranty or a service contact, report the problem to your service provider.
If it is a hardware problem you want it fixed before you get to a situation where a future version fails to boot because the firmware is too low. This is not saying that such a situation is guaranteed, just reasonably likely over the life of this architecture.
JT:
JP Watson
Advisor

Re: rx4640 firmware: "Could not set TIMEOUT NVRAM" error

The issue is not a hardware problem. It is a problem where the script doing the firmware update is unable to set a NVRAM variable at efi. In this case, it is the "TIMEOUT" variable. We have seen this on a few other occasions. It is suspected that the system has too many NVM variables declared which had used up all the available NVRAM storage space. You can use the "set" command at the efi shell to display and delete, but this might be too tedious. Also, this is only seen when using the ISO version.

You can do one of two things as a workaround.

1) Bypass the script and execute the update directly from the CD being used. Find out which fs#: your cdrom is mapped to at the efi shell, and run the firmware update application directly:

fs0:\efi\hpofm\firmware\update_SFW.efi

2) download the efi firmware image and run it directly from a cd, flashstick or copy to the efi partition on your hard drive. BTW, the efi images are much smaller.

For 04.29 efi image
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=88837&prodNameId=346361&swEnvOID=54&swLang=13&mode=2&taskId=135&swItem=ux-58874-1

In either case, I would recommend reseting the MP/iLO and system before and after the updates. Refer to the "README" link from the page above for MP reset details.