Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

rx4640 mystery error - WARNING[58]

 
SOLVED
Go to solution
Steven Bucek
Frequent Advisor

rx4640 mystery error - WARNING[58]

rx4640, ROM 2.13, BMC 2.33, 4 processor, 4gb ram.

I am logging the following error in the 'warning and stop boot information'. From the EFI the 'info warning' command gives the following output.

WARNING[58] Checksum failure accessing FRU information.

I can not find any infomation regarding this error. I ran overnight test on the memory, processors, and core io with no errors.

I built this machine a month ago, tested it, loaded the OS, printed my tests results and sent it along. The server has been sitting around for a month, now they want to put it in production and this error shows up, and I can't expalin it.

Anyone seen this before?
--To go forward, you must backup
6 REPLIES 6
Torsten.
Acclaimed Contributor
Solution

Re: rx4640 mystery error - WARNING[58]

Sounds like you should reseat the cards first.

BTW, your firmware is pretty old, should be BMC 03.47.

You can download an ISO image from www.hp.com and update.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Steven E. Protter
Exalted Contributor

Re: rx4640 mystery error - WARNING[58]

Shalom,

I recommend the following steps, which really should have been done prior to "sending" the machine for production.

1) Get the latest firmware installed. This is done by patch.
2) Install the latest, greatest HWE patch set. See below for where to get it.
3) Install the March 2006 QPK patch set, which assumes your OS is 11i v2, but no matter the OS you need a recent patch set.

http://www2.itrc.hp.com/service/patch/mainPage.do
Thats's where you find and build patch sets. the firmware is in there too.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Cheryl Griffin
Honored Contributor

Re: rx4640 mystery error - WARNING[58]

This is a known message fixed by firmware update. You need PHSS_34022 s700_800 11.23 rx4640 System; BMC and MP Firmware Patch or place a call to HW Support to update the firmware for you.
"Downtime is a Crime."
Steven Bucek
Frequent Advisor

Re: rx4640 mystery error - WARNING[58]

Thank you everyone for the response. This machine has been a nightmare.

I updated the firmware and the error went away. The story does not end there.

After the firmware update, one of the processor stopped working. Last night after the firmware updates were done and error was gone, I removed the processors to get some assett information I tagged them with. This morning I put the processors back on the board, tired to power and got the blood red led. So, after hours of troubleshooting I find ONE processor that seems to be the problem, with this one proc in the sys board the machine will not power on, just get the red led. I tried using other processor boards and even another system, the error follows. Ok so I accept the processor is bad and move on. I cleared the logs and rebooted with the 3 processors just to make sure everything was ok, and there is the WARNING[58] again in the same place. 'info warning' from efi gave the same error. I fell out of my chair.


I tried to re-flash the fw, it gave me a bunch of warnings that the firmware rev's were the same, i choose to continue, and it seemed to skip the updates and rebooted. Im sure I didn't update anything as the firmware update took a good 20 minutes or so to complete. It did not remove the error.

So now I'm pretty much back where I started from, only I have updated frimware with the WARNING[58] and a processor that does not work.

All these processors were working fine after the firmware updates. I needed 2 updates since the fw was so old, so i have NO idea why it this 'bad' processor worked last night and not this now. UGH!
--To go forward, you must backup
mits
Respected Contributor

Re: rx4640 mystery error - WARNING[58]

Can you run MP command "df -all -nc" and attach its output to this forum board?
Steven Bucek
Frequent Advisor

Re: rx4640 mystery error - WARNING[58]

UPDATE: I removed the processor in slot 2, leaving 0 and 1 in, booted,and the error is gone.

I will re-install the processor and post the output of the command above.
--To go forward, you must backup