Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

terminal problem on rx2620

 
Eliza Jones
Occasional Visitor

terminal problem on rx2620

I have an rx2620 with garbled Redhat on it, and I'm trying to do a new install of Redhat. This server has an HP terminal & keyboard attached. We tried connecting with a laptop & serial cable and using VT100 term to connect to this box, but it doesn't seem to be able to talk to it. Using the HP terminal, when I try to boot off the Redhat DVD, I'm getting garbage on the screen when it goes into the install menu, and the keyboard doesn't function. Does anyone know what I need to set this terminal in order to do this install? Or have a recommendation for a terminal emulator for a laptop connection? The emulator I tried using earlier was Tera Term Pro, and it only gives me VTxxx options. The HP terminal that is attached to this server gives me options EM100, EM220, and HP, and none of them seem to work with the Redhat install DVD.
2 REPLIES 2
Steven E. Protter
Exalted Contributor

Re: terminal problem on rx2620

Shalom,

As I recall, rx2620 systems have a build in lan console. Its an RJ45 plug on the back and its labelled. An HP-UX install might work from the serial terminal, but probably not Red Hat.

The best bet for installation is to connect to that device by ssh and manage the install from there.

I do not believe this install will work on the hp terminal.


SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Karsten Breivik_1
Frequent Advisor

Re: terminal problem on rx2620

Found a few old notes on the subject:

-----------

Garbled man pages

In /etc/sysconfig/i18n change

LANG="en_US.UTF-8"

to

LANG="en_US"

-------------------


Also here is a quote from Bernhard Gabler on HP ITRC somewhere:

My screen is all full of weird characters instead of letters.

You probably sent some binary data to your screen by mistake. Type echo '\033c' to fix it. Many Linux distributions have a command, 'reset' that does this.

If that doesn't help, try a direct screen escape command.

echo

This resets the default font of a Linux console. Remember to hold down the Control key and type the letter, instead of, for example, `Ctrl-V'. The sequence

echo c

causes a full screen reset. If there's data left on the shell command line after typing a binary file, press Ctrl-C a few times to restore the shell command line

------------

Have not connected to this kind of server, but usually Tera Term VT100 emulation works fine with linux. I believe VT100 emulation also worked for me once I had to install UX on a 9000 system... Alternatively you could also try using putty.
poi