LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

1920S 24G 2SFP (JL384A) inter-vlan routing

 
Highlighted
Occasional Visitor

1920S 24G 2SFP (JL384A) inter-vlan routing

We have an issue with inter-vlan routing let me explain what we have.

We have 5 vlans:

  • vlan 1
  • vlan 101
  • vlan 111
  • vlan 121
  • vlan 131

The main core switch is the 1920S and connected to this is x4 1820. 

When on on vlan 121 I am not able to ping anything on vlan 101 which is essential. 

Strangely though, when on vlan 111 I can ping devices on vlan 101, the config is no different. 

A tracert from a device on vlan 121 to vlan 101 stops at the 1920S core switch. 

Here is the running config on the 1920S:

!Current Configuration:
!
!System Description "HPE OfficeConnect Switch 1920S 24G 2SFP PPoE+ (185W) JL384A, PD.02.11, Linux 3.6.5-375bd0e8, U-Boot 2012.10-00118-g3773021 (Oct 11 2016 - 15:39:54)"
!System Software Version "PD.02.11"
!System Up Time "9 days 2 hrs 15 mins 9 secs"
!Additional Packages HPE QOS,HPE IPv6 Management,HPE Routing
!Current SNTP Synchronized Time: SNTP Last Attempt Status Is Not Successful
!
network protocol none
network parms 192.168.255.1 255.255.255.0 192.168.255.2
vlan database
vlan 101,111,121,131
vlan name 101 "MGMT"
vlan name 111 "SHOPFLOOR"
vlan name 121 "CORPORATE"
vlan name 131 "FINAL"
vlan routing 1 1
vlan routing 101 2
vlan routing 121 3
vlan routing 111 4
vlan routing 131 5
exit
network mgmt_vlan 101
network mgmt_port 3
ip http session soft-timeout 15
configure
sntp client mode unicast
sntp server "10.0.0.31"
clock summer-time recurring EU offset 60
time-range Schedule-1
exit
time-range Schedule-2
exit
ip routing
ip helper enable
ip helper-address 10.0.0.32 dhcp
username "admin" password 
no username guest
line console
exit
line telnet
exit
line ssh
exit
snmp-server sysname "SW-CORE-01"
snmp-server location "IT Server Room"
snmp-server contact "IT"
!
ip access-list ALLOW
permit ip any any
exit
ip access-list VLANDENY
deny ip any 172.16.2.0 0.0.0.255
deny ip any 172.16.1.0 0.0.0.255
deny ip any 172.16.3.0 0.0.0.255
exit
ip access-list VLANALLOW
exit
ip access-group ALLOW vlan 111 in 999
ip access-group ALLOW vlan 121 in 999
ip access-group ALLOW vlan 131 in 999
interface 1
bandwidth 100000
spanning-tree port mode
ip mtu 1500
exit
interface 2
vlan pvid 101
vlan participation exclude 1
vlan participation include 101
exit
interface 3
vlan participation include 101,111,121,131
vlan tagging 101,111,121,131
exit
interface 4
vlan pvid 101
vlan participation exclude 1,131
vlan participation include 101,111,121
vlan tagging 111,121
exit
interface 5
vlan pvid 101
vlan participation exclude 1
vlan participation include 101,111,121
vlan tagging 111,121
exit
interface 6
vlan pvid 101
vlan participation exclude 1
vlan participation include 101,111,121
vlan tagging 111,121
exit
interface 7
vlan pvid 101
vlan participation exclude 1,131
vlan participation include 101,111,121
vlan tagging 111,121
exit
interface 8
vlan pvid 101
vlan participation exclude 1,131
vlan participation include 101,111,121
vlan tagging 111,121
exit
interface 9
vlan pvid 101
vlan participation exclude 1
vlan participation include 101,111,121
vlan tagging 111,121
exit
interface 10
vlan pvid 101
vlan participation exclude 1
vlan participation include 101,111,121
vlan tagging 111,121
exit
interface 11
vlan pvid 101
vlan participation exclude 1,111,121
vlan participation include 101
exit
interface 12
vlan pvid 101
vlan participation exclude 1
vlan participation include 101,111,121
vlan tagging 111,121
exit
interface 13
vlan pvid 101
vlan participation exclude 1,111,121
vlan participation include 101
exit
interface 14
vlan pvid 101
vlan participation exclude 1
vlan participation include 101
exit
interface 15
vlan pvid 101
vlan participation exclude 1
vlan participation include 101,111,121
vlan tagging 111,121
exit
interface 16
vlan participation include 101,111,121,131
vlan tagging 101,111,121,131
exit
interface 17
vlan participation include 101,111,121,131
vlan tagging 101,111,121,131
exit
interface 18
vlan participation include 101,111,121,131
vlan tagging 101,111,121,131
exit
interface 19
vlan pvid 101
vlan participation exclude 1
vlan participation include 101,111,121
vlan tagging 111,121
exit
interface 20
description 'MAN_MSA2050'
vlan participation exclude 101,111,121,131
exit
interface 21
description 'UPLINK'
vlan participation include 101,111,121,131
vlan tagging 101,111,121,131
exit
interface 22
description 'UPLINK'
vlan participation include 101,111,121,131
vlan tagging 101,111,121,131
exit
interface 23
description 'UPLINK'
vlan participation include 101,111,121,131
vlan tagging 101,111,121,131
exit
interface 24
description 'UPLINK'
vlan participation include 101,111,121,131
vlan tagging 101,111,121,131
exit
interface vlan 1
bandwidth 10000
routing
ip address 10.0.0.5 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 101
bandwidth 10000
routing
ip address 172.16.0.1 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 121
bandwidth 10000
routing
ip address 172.16.2.1 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 111
bandwidth 10000
routing
ip address 172.16.1.1 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 131
bandwidth 10000
routing
ip address 172.16.3.1 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
ip default-gateway 10.0.0.1
exit