LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

2530 Aruba switch port fail over

 
sunilkumar19
Occasional Advisor

2530 Aruba switch port fail over

Hi,

I have 2530 switches connected between our two offices where the distance is about 200 metres, currently we are using fiber cable as uplink between this two offices, this is the only single point of failure.

Hence we have decided to use wireless point to point connection as backup for fiber, the challenge i am facing here i can't connect both fiber and wireless uplink cable in same 2530 switch, it is creating loop sometimes in the network and causing network disconnection.

Is there a way to configure port/Link failover in both switches...for ex : when fiber port uplink goes down the wirless P2P port should be able to send packets to gateway or destination.

Thanks in advance.

 

Regards,

Sunil Kumar

7 REPLIES 7
shijuganga
Occasional Advisor

Re: 2530 Aruba switch port fail over

Hi Sunil,

Add below command in both the switches and confirmed.

"spanning-tree mode mstp"

Also refer https://www.arubanetworks.com/techdocs/ArubaOS_74_Web_Help/Content/mas_guides/mstp/MSTP.htm

Please confirm the solution once implemented.

Thanks,

Shiju Chacko

sunilkumar19
Occasional Advisor

Re: 2530 Aruba switch port fail over

Hi Shiju,

Thanks for your reply,

Forgot to mention that we have configured 3 vlans and tagged on the intreface will the vlan traffic also get included in MSTP ? or do we need to create separate tagging for packets to flow.

tagged vlan IDs

Vlan -2,3&4 on interface 10-24

Untagged vlan Id is Vlan-1 on interface 10-24 

Uplink interface in Port-24.

Please help!

shijuganga
Occasional Advisor

Re: 2530 Aruba switch port fail over

Hi Sunil,

Just add the command on both switches and check. Please confirm once done.

Thanks & Regards

Shiju

 

sunilkumar19
Occasional Advisor

Re: 2530 Aruba switch port fail over

Hi Shiju,

I have applied the command and connected the P2P cable, getting request time out to gateway and network is disconnected.

shijuganga
Occasional Advisor

Re: 2530 Aruba switch port fail over

Hi Sunil,

Please share the configuration of both switches in text file.

Shiju Chacko

sunilkumar19
Occasional Advisor

Re: 2530 Aruba switch port fail over

Please find the below details, SW1&2 config details.

 

Switch1# sh config

Startup configuration: 13

; J9774A Configuration Editor; Created on release #YA.16.04.0008
; Ver #10:19.02.13.98.82.34.61.18.28.f3.84.9c.63.ff.37.27:00
hostname "Switch1"
ip default-gateway 192.168.105.1
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-10
ip address 192.168.105.20 255.255.255.0
exit
vlan 105
name "OmR"
tagged 1-10
no ip address
exit
vlan 107
name "Content"
tagged 1-10
no ip address
exit
vlan 108
name "CS"
tagged 1-10
no ip address
exit
spanning-tree
password manager


Switch 2
Startup configuration: 18

; J9774A Configuration Editor; Created on release #YA.16.04.0008
; Ver #10:19.02.13.98.82.34.61.18.28.f3.84.9c.63.ff.37.27:00
hostname "Switch2"
ip default-gateway 192.168.105.1
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-10
ip address 192.168.105.21 255.255.255.0
exit
vlan 105
name "savis"
tagged 1-10
no ip address
exit
vlan 107
name "Content"
tagged 1-10
no ip address
exit
vlan 108
name "CS"
tagged 1-10
no ip address
exit
spanning-tree
no tftp server
no dhcp config-file-update
no dhcp image-file-update
no dhcp tr69-acs-url
password manager

sunilkumar19
Occasional Advisor

Re: 2530 Aruba switch port fail over

Can anyone help on this ?