LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Adding an additional L3 switch

 
Highlighted
Occasional Advisor

Adding an additional L3 switch

Hi

As above we are trying to get a fourth switch to work with our current switches.  

We have the following configured:

Port1 in HP1910 Switch connected to 

Port1 in HP2910al.  Port2 connected to

Port1 in HP2952.  Port12 connected to

New HP 2910 Switch Port1.  Then Port2 to Port2 on HP1910.

HP2952, currently in a looped config..  We want to add the fourth switch here but in a chain mode - as i've read this is the preferred config.

Running Configs:

172.19.4.4

<HP V1910 Switch 2>display current-configuration
#
version 5.20 Release 1111
#
sysname HP V1910 Switch 2
#
clock timezone #Web#0#02 add 00:00:00
#
super password level 3 simple
#
domain default enable system
#
telnet server enable
#
ip ttl-expires enable
#
web idle-timeout 30
#
vlan 1
#
radius scheme system
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple
authorization-attribute level 3
service-type ssh telnet terminal
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 172.19.4.4 255.255.0.0
#
interface GigabitEthernet1/0/1
stp edged-port enable
#
interface GigabitEthernet1/0/2
stp edged-port enable
#
interface GigabitEthernet1/0/3
stp edged-port enable
#
interface GigabitEthernet1/0/4
stp edged-port enable
#
interface GigabitEthernet1/0/5
stp edged-port enable
#
interface GigabitEthernet1/0/6
stp edged-port enable
#
interface GigabitEthernet1/0/7
stp edged-port enable
#
interface GigabitEthernet1/0/8
stp edged-port enable
#
interface GigabitEthernet1/0/9
stp edged-port enable
#
interface GigabitEthernet1/0/10
stp edged-port enable
#
interface GigabitEthernet1/0/11
stp edged-port enable
#
interface GigabitEthernet1/0/12
stp edged-port enable
#
interface GigabitEthernet1/0/13
stp edged-port enable
#
interface GigabitEthernet1/0/14
stp edged-port enable
#
interface GigabitEthernet1/0/15
stp edged-port enable
#
interface GigabitEthernet1/0/16
stp edged-port enable
#
interface GigabitEthernet1/0/17
stp edged-port enable
#
interface GigabitEthernet1/0/18
stp edged-port enable
#
interface GigabitEthernet1/0/19
stp edged-port enable
#
interface GigabitEthernet1/0/20
stp edged-port enable
#
interface GigabitEthernet1/0/21
stp edged-port enable
#
interface GigabitEthernet1/0/22
stp edged-port enable
#
interface GigabitEthernet1/0/23
stp edged-port enable
#
interface GigabitEthernet1/0/24
stp edged-port enable
#
interface GigabitEthernet1/0/25
stp edged-port enable
#
interface GigabitEthernet1/0/26
stp edged-port enable
#
interface GigabitEthernet1/0/27
stp edged-port enable
#
interface GigabitEthernet1/0/28
stp edged-port enable
#
interface GigabitEthernet1/0/29
stp edged-port enable
#
interface GigabitEthernet1/0/30
stp edged-port enable
#
interface GigabitEthernet1/0/31
stp edged-port enable
#
interface GigabitEthernet1/0/32
stp edged-port enable
#
interface GigabitEthernet1/0/33
stp edged-port enable
#
interface GigabitEthernet1/0/34
stp edged-port enable
#
interface GigabitEthernet1/0/35
stp edged-port enable
#
interface GigabitEthernet1/0/36
stp edged-port enable
#
interface GigabitEthernet1/0/37
stp edged-port enable
#
interface GigabitEthernet1/0/38
stp edged-port enable
#
interface GigabitEthernet1/0/39
stp edged-port enable
#
interface GigabitEthernet1/0/40
stp edged-port enable
#
interface GigabitEthernet1/0/41
stp edged-port enable
#
interface GigabitEthernet1/0/42
stp edged-port enable
#
interface GigabitEthernet1/0/43
stp edged-port enable
#
interface GigabitEthernet1/0/44
stp edged-port enable
#
interface GigabitEthernet1/0/45
stp edged-port enable
#
interface GigabitEthernet1/0/46
stp edged-port enable
#
interface GigabitEthernet1/0/47
stp edged-port enable
#
interface GigabitEthernet1/0/48
stp edged-port enable
#
interface GigabitEthernet1/0/49
stp edged-port enable
#
interface GigabitEthernet1/0/50
stp edged-port enable
#
interface GigabitEthernet1/0/51
stp edged-port enable
#
interface GigabitEthernet1/0/52
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 172.19.4.5
#
snmp-agent
snmp-agent local-engineid 800063A203B8AF67426857
snmp-agent community read public
snmp-agent community write private
snmp-agent sys-info contact IT
snmp-agent sys-info location
snmp-agent sys-info version all
#
ntp-service source-interface Vlan-interface1
ntp-service unicast-server 81.168.77.149
ntp-service unicast-server 194.35.252.7
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return
<HP V1910 Switch 2>

----------------------

Running configuration:

; J9148A Configuration Editor; Created on release #W.15.08.0012
; Ver #02:11.05:16
hostname "HP-E2910al-48G-PoE-"
module 1 type j9148a
power-over-ethernet pre-std-detect
qos type-of-service diff-services
sflow 1 destination 172.19.10.23
sflow 1 sampling 1-48 500
timesync sntp
sntp unicast
sntp server priority 1 87.124.126.49
sntp server priority 2 178.79.165.21
time timezone 60
ip authorized-managers 172.19.0.0 255.255.0.0 access manager
ip authorized-managers 172.16.0.0 255.255.0.0 access manager
ip authorized-managers 10.255.255.0 255.255.255.128 access manager
ip authorized-managers 192.168.2.0 255.255.255.0 access manager
ip authorized-managers 192.168.3.0 255.255.255.0 access manager
ip authorized-managers 10.255.254.0 255.255.255.128 access manager
ip authorized-managers 192.168.100.0 255.255.255.0 access manager
ip authorized-managers 192.168.200.0 255.255.255.0 access manager
ip authorized-managers 10.255.253.0 255.255.255.0 access manager
ip default-gateway 172.19.10.15
no ip icmp redirects
ip route 0.0.0.0 0.0.0.0 172.19.10.15
ip routing
interface 1
name "to HP1910 (top)"
no power-over-ethernet
exit
interface 2
name "to 3com (bottom)"
no power-over-ethernet
exit
interface 3
name "to ASA 5505 fe01"
no power-over-ethernet
exit
interface 4
name "Cisco_AP_172.19.3.20"
exit
interface 5
name "to HP2910 Ground Floor"
exit
interface 6
no power-over-ethernet
exit
interface 7
name "Shoretel E1k"
speed-duplex 100-full
exit
interface 8
name "Shoretel SG90"
speed-duplex 100-full
exit
interface 9
name "Shoretel SG90Bri"
speed-duplex 100-full
exit
interface 10
name "-Oaisys"
exit
interface 11
name "Shoretel HQ"
exit
interface 12
name "Ingate"
exit
interface 16
name "Server Room"
exit
interface 19
name "Test Phone"
exit
interface 21
name ""
exit
interface 22
name "Meeting Room"
exit
interface 25
name ""
exit
interface 31
name ""
exit
interface 35
name "Test_Port_for_"
exit
interface 37
name "to onenet e0/1"
exit
interface 38
name "to cisco asa e0/0"
exit
interface 39
name "to juniper e0/1"
exit
snmp-server community "public" unrestricted
snmp-server contact "IT" location "HQ"
spanning-tree
vlan 1
name "DEFAULT_VLAN"
no untagged 7-48
untagged 1-6
ip address 172.19.4.5 255.255.0.0
exit
vlan 20
name "Voice"
untagged 7-12,35
tagged 13-34,36-48
ip address 172.16.4.5 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
vlan 50
name "vlan50"
untagged 37-39
no ip address
exit
no autorun
password manager

-----------------------------

172.19.4.4

<HP V1910 Switch 2>display current-configuration
#
version 5.20 Release 1111
#
sysname HP V1910 Switch 2
#
clock timezone #Web#0#02 add 00:00:00
#
super password level 3 simple
#
domain default enable system
#
telnet server enable
#
ip ttl-expires enable
#
web idle-timeout 30
#
vlan 1
#
radius scheme system
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple
authorization-attribute level 3
service-type ssh telnet terminal
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 172.19.4.4 255.255.0.0
#
interface GigabitEthernet1/0/1
stp edged-port enable
#
interface GigabitEthernet1/0/2
stp edged-port enable
#
interface GigabitEthernet1/0/3
stp edged-port enable
#
interface GigabitEthernet1/0/4
stp edged-port enable
#
interface GigabitEthernet1/0/5
stp edged-port enable
#
interface GigabitEthernet1/0/6
stp edged-port enable
#
interface GigabitEthernet1/0/7
stp edged-port enable
#
interface GigabitEthernet1/0/8
stp edged-port enable
#
interface GigabitEthernet1/0/9
stp edged-port enable
#
interface GigabitEthernet1/0/10
stp edged-port enable
#
interface GigabitEthernet1/0/11
stp edged-port enable
#
interface GigabitEthernet1/0/12
stp edged-port enable
#
interface GigabitEthernet1/0/13
stp edged-port enable
#
interface GigabitEthernet1/0/14
stp edged-port enable
#
interface GigabitEthernet1/0/15
stp edged-port enable
#
interface GigabitEthernet1/0/16
stp edged-port enable
#
interface GigabitEthernet1/0/17
stp edged-port enable
#
interface GigabitEthernet1/0/18
stp edged-port enable
#
interface GigabitEthernet1/0/19
stp edged-port enable
#
interface GigabitEthernet1/0/20
stp edged-port enable
#
interface GigabitEthernet1/0/21
stp edged-port enable
#
interface GigabitEthernet1/0/22
stp edged-port enable
#
interface GigabitEthernet1/0/23
stp edged-port enable
#
interface GigabitEthernet1/0/24
stp edged-port enable
#
interface GigabitEthernet1/0/25
stp edged-port enable
#
interface GigabitEthernet1/0/26
stp edged-port enable
#
interface GigabitEthernet1/0/27
stp edged-port enable
#
interface GigabitEthernet1/0/28
stp edged-port enable
#
interface GigabitEthernet1/0/29
stp edged-port enable
#
interface GigabitEthernet1/0/30
stp edged-port enable
#
interface GigabitEthernet1/0/31
stp edged-port enable
#
interface GigabitEthernet1/0/32
stp edged-port enable
#
interface GigabitEthernet1/0/33
stp edged-port enable
#
interface GigabitEthernet1/0/34
stp edged-port enable
#
interface GigabitEthernet1/0/35
stp edged-port enable
#
interface GigabitEthernet1/0/36
stp edged-port enable
#
interface GigabitEthernet1/0/37
stp edged-port enable
#
interface GigabitEthernet1/0/38
stp edged-port enable
#
interface GigabitEthernet1/0/39
stp edged-port enable
#
interface GigabitEthernet1/0/40
stp edged-port enable
#
interface GigabitEthernet1/0/41
stp edged-port enable
#
interface GigabitEthernet1/0/42
stp edged-port enable
#
interface GigabitEthernet1/0/43
stp edged-port enable
#
interface GigabitEthernet1/0/44
stp edged-port enable
#
interface GigabitEthernet1/0/45
stp edged-port enable
#
interface GigabitEthernet1/0/46
stp edged-port enable
#
interface GigabitEthernet1/0/47
stp edged-port enable
#
interface GigabitEthernet1/0/48
stp edged-port enable
#
interface GigabitEthernet1/0/49
stp edged-port enable
#
interface GigabitEthernet1/0/50
stp edged-port enable
#
interface GigabitEthernet1/0/51
stp edged-port enable
#
interface GigabitEthernet1/0/52
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 172.19.4.5
#
snmp-agent
snmp-agent local-engineid 800063A203B8AF67426857
snmp-agent community read public
snmp-agent community write private
snmp-agent sys-info contact IT
snmp-agent sys-info location
snmp-agent sys-info version all
#
ntp-service source-interface Vlan-interface1
ntp-service unicast-server 81.168.77.149
ntp-service unicast-server 194.35.252.7
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return
<HP V1910 Switch 2>

----------------------------------

New switch current config:

Running configuration:

; J9148A Configuration Editor; Created on release #W.15.14.0016
; Ver #06:04.18.63.ff.35.05:b6
hostname "HP2910al-48G-PoE-GroundFloor"
module 1 type j9148a
trunk 1 trk1 trunk
power-over-ethernet pre-std-detect ports 1-48
qos type-of-service diff-services
sflow 1 destination 172.19.10.23
sflow 1 sampling 2-48 500
timesync sntp
sntp unicast
sntp server priority 1 87.124.126.49
sntp server priority 2 178.79.165.21
time timezone 60
interface 1
name "to port 5 on HP2910"
exit
snmp-server community "public" unrestricted
snmp-server contact "IT" location "
vlan 1
name "DEFAULT_VLAN"
untagged 2-48,Trk1
ip address 172.19.4.6 255.255.0.0
exit
vlan 20
name "VLAN20"
tagged 33-48
ip address 172.16.4.6 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
spanning-tree
spanning-tree Trk1 priority 4
no tftp server
no autorun
no dhcp config-file-update
password manager

Currnelty the phone that is connected in the vlan20 port on the new switch cannot get an IP from the DHCP server voice scope.  It seems though that it can get an ip from the DHCP server but the wrong range.

We also have problems pinging to/from the new vlan20 to old and from hosts on the vlan1 to new vlan20.

I've read we may need to use trunks to resolve?  My concern is making these changes to production switches particluarly the core switch.

Suggestions?

Thanks

Attached is current (black) and propsed (red).

 

2 REPLIES 2
Highlighted
Frequent Advisor

Re: Adding an additional L3 switch

Hi,

Appears to be multiple devices involved and needs to verify all the configuration, my suggestions to log support case to investigate.

 

 

Bala
I work for HPE

Accept or Kudo

Highlighted
HPE Pro

Re: Adding an additional L3 switch

Hello,

 

You may need to configure uplinks ports as trunk and allow required vlans and as you want it in chain model, you can prefer

 

Port1 in HP1910 Switch connected to 

Port1 in HP2910al.  Port2 connected to

Port1 in HP2952.  Port12 connected to

Port1 in new switch

I am an HPE Employee

Accept or Kudo