LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

CLOSED: OSPF and MD5 error on version K-15-06

SOLVED
Go to solution
steve dowling
Occasional Advisor

CLOSED: OSPF and MD5 error on version K-15-06

I have an OSPF network running (mostly) Procurve 8200/5400/3500 routers.  Firmware is (mostly) K-15-04.  Everything runs well.

 

I upgraded one of my 3500 to K-15-06 and now get the OSPF error:

"03133 OSPF: RECV: Packet received on interface vl450 has its MD5 key expired: Extending life of last accepted key"

Downgrading back to firmware K-15-04 clears the error.

 

This appears to be a time limitation of the MD5sum, but when I look at the key-chain I see that the expiration date is "infinite."

 

Is this a known incompatibility, a bad config problem, or do i need to issue a new key to run ver K-15-06?

 

 

9 REPLIES
whoami
Occasional Visitor

Re: OSPF and MD5 error on version K-15-06

sounds like a bug. report this to HP support.

steve dowling
Occasional Advisor

Re: OSPF and MD5 error on version K-15-06

This is indeed with HP support. 

I had hoped there was someone else out there who had seen this problem.  

(I should close this thread now.)

 

SFHR
Frequent Advisor

Re: OSPF and MD5 error on version K-15-06

Please share outcome!

Rgrds//

Regards//
SF Hussain

Help others for better Tomorrow
__________________________________________________________
Please click the White Star Button should you like the Post for Points.,,
steve dowling
Occasional Advisor
Solution

Re: OSPF and MD5 error on version K-15-06 - FOUND

This has gone to HP suoorts and they have reproduced the issue. 

Looks like I'm going back to an earlier version of code.

Davis McNeill
Occasional Contributor

Re: OSPF and MD5 error on version K-15-06 - FOUND

I have the same issue.

 

"e 11/01/11 15:54:46 03133 OSPF: AM2: RECV: Packet received on interface xxxxx
            has its MD5 key expired: Extending life of last accepted key"

André Beck
Honored Contributor

Re: OSPF and MD5 error on version K-15-06 - FOUND


steve dowling wrote:

This has gone to HP suoorts and they have reproduced the issue. 

Looks like I'm going back to an earlier version of code.


Hi Steve,

 

thanks for documenting this on the 'net. I've hit this same issue yesterday, and there seems to be no solution yet, at least I see no maintenance rebuild of K.15.06.0008. Do you have more information about the problem, specifically if the key life will be extended perpetually (so it's just a bad glitch flooding the logs) or if the extension might end some day, killing off my adjacencies? What version did you downgrade to exactly? I'm looking on K.15.04.0009m as the latest maintenance rebuild on top of K.15.04, but I haven't used that before, either...

 

TIA,

Andre.

Moshe_azu
Occasional Visitor

Re: OSPF and MD5 error on version K-15-06

Hi,

I have the same problem at one of our customers site.

Did you recieved any solution from HP regarding this issue or the solution was to downgrade the switch OS ?

 

Thanks in advance for your help

Moshe

steve dowling
Occasional Advisor

Re: OSPF and MD5 error on version K-15-06

This fix is merged into K-15-06-0009. 

It does clear the ospf and md5 problem, but HP have not yet released this. 

 

I'm staying with K-15-04-0007 which is a nice, stable release.

André Beck
Honored Contributor

Re: OSPF and MD5 error on version K-15-06

Hi Steve,

 


steve dowling wrote:

This fix is merged into K-15-06-0009. 

It does clear the ospf and md5 problem, but HP have not yet released this. 

 

I'm staying with K-15-04-0007 which is a nice, stable release.


Ah, great to know the fix is merged and upcoming. The switch where I hit this is running K.15.04.0009m since, without any issues. It's not really in heavy production use yet, though. On the other hand, a maintenance rebuild should be the most stable thing you can get compared to its branch base version. Great HP have started to issue dedicated stable rebuilds, it's a welcome step.

Thanks for the feedback,

Andre.