LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Comware Sparse/dense mode

SOLVED
Go to solution
Sander97
Occasional Contributor

Comware Sparse/dense mode

Hi Guys,We have a HPE 5900 as a core-switch.
On this core we have a "vlan 113" for multicasting (IPTV)
On this vlan we have enabled igmp-snooping and igmp-snooping querier.
#
igmp-snooping
#
vlan 113
description IPTV
igmp-snooping enable
igmp-snooping querier

watching iptv IN the vlan works perfect.
At the same site we have vlan2. now we also want to wacht IPTV from vlan 2.
So we have to use multicast routing, sparse or dense mode.
The multicast routing fails in DM or SM.

if we configure Dense mode the streaming also stops in iptv vlan 113

CONFIGURATION DM
#
igmp-snooping
#
multicast routing
#
pim
#
vlan 113
description IPTV
igmp-snooping enable
igmp-snooping querier
#
interface Vlan-interface2
ip address 192.168.254.1 255.255.252.0
pim dm
igmp enable
#
interface Vlan-interface113
description IPTV
ip address 172.16.0.1 255.255.252.0
pim dm
igmp enable

CONFIGURATION SM

igmp-snooping
#
multicast routing
#
pim
static-rp 172.16.0.1
c-rp 172.16.0.1
#
vlan 113
description IPTV
igmp-snooping enable
igmp-snooping querier
#
interface Vlan-interface2
description Data
ip address 192.168.254.1 255.255.252.0
pim sm
igmp enable
#
interface Vlan-interface113
description IPTV
ip address 172.16.0.1 255.255.252.0
pim sm
igmp enable

somebody knows whats wrong?

We have a Triax headend in iptv vlan 113 that generate the streams.

The strange thing is that if we start our own stream with vlc player and dm is configured, it works only with the vlc stream.

wireshark:

vlc packets: UDP stream --> TTL=5

triax head end: MPEG-TS stream (udp) --> TTL=16

THANKS!!!!!

2 REPLIES
Vince-Whirlwind
Honored Contributor

Re: Comware Sparse/dense mode

I think you need to issue the pim-snooping enable command, per vlan.

display pim-snooping statistics and display pim-snooping routing-table could be useful for you here.

Sander97
Occasional Contributor
Solution

Re: Comware Sparse/dense mode

Hi,

Thanks for the reply but we solved it already.

Ther were 2 problems. our headend (source of multicast streams) didn't had an ip address.

after giving it an IP we created a multicast route to it. now everything works!