LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Config for Multicast routing

Rich R_1
Advisor

Config for Multicast routing

I have a E5412zl that I would like to enable multicast routing on...I haven't tested the config yet, but would I need to enable router pim?  I have enable ip igmp on the edge switches as well...they are  2510-48G

 

Running configuration:

; J8698A Configuration Editor; Created on release #K.15.04.0007
; Ver #01:00:01

hostname "HP E5412 Core Switch" 
time timezone -300 
time daylight-time-rule Continental-US-and-Canada 
module 1 type J8706A 
module 2 type J9534A 
module 3 type J8707A 
interface A2 
   name "" 
exit
interface A4 
   name "" 
exit
interface A6 
   name "" 
exit
interface A8 
   name "" 
exit
trunk A1 Trk1 LACP 
trunk A5 Trk2 LACP 
trunk A3 Trk3 LACP 
trunk A4 Trk4 LACP 
trunk A6 Trk5 LACP 
trunk A8 Trk6 LACP 
trunk A2 Trk7 LACP 
ip routing 
vlan 1 
   name "" 
   untagged A7,A9-A24,B1-B2,B6-B11,B13-B24,C1-C4 
   ip address 10.10.7.2 255.255.240.0 
   tagged Trk1-Trk7 
   no untagged B3-B5,B12 
   ip igmp 
   exit 
vlan 15 
   name "" 
   ip address 10.10.41.2 255.255.255.128 
   tagged Trk1-Trk2 
   ip igmp 
   exit 
vlan 16 
   name "" 
   ip helper-address 10.10.7.13 
   ip address 10.10.42.2 255.255.255.128 
   tagged Trk1,Trk3 
   ip igmp 
   exit 
vlan 10 
   name "" 
   untagged B3-B5 
   tagged Trk1 
   no ip address 
   ip igmp 
   exit 
vlan 17 
   name "" 
   ip helper-address 10.10.7.13 
   ip address 10.10.44.2 255.255.254.0 
   tagged Trk1,Trk4-Trk7 
   ip igmp 
   exit 
vlan 18 
   name "IT" 
   untagged B12 
   ip helper-address 10.10.34.37 
   ip address 10.10.46.2 255.255.255.128 
   tagged Trk1,Trk4-Trk6 
   ip igmp 
   exit 
mirror 1 port A1
sflow 1 destination 10.10.34.39 2055
sflow 1 polling Trk1 60
sflow 1 sampling Trk1 50
web-management ssl
ip route 0.0.0.0 0.0.0.0 10.10.7.1
ip multicast-routing
router pim
   exit
snmp-server community "" operator
snmp-server community "" operator unrestricted
snmp-server host 10.10.34.39 community "" trap-level all
snmp-server contact "" location ""
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
spanning-tree Trk4 priority 4
spanning-tree Trk5 priority 4
spanning-tree Trk6 priority 4
spanning-tree Trk7 priority 4
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager
password operator
3 REPLIES
ISoliman
Super Advisor

Re: Config for Multicast routing

You have to enable IP PIM  under the VLANs also (source VLAN and desination(s) VLANs), I would recommend using PIM-DM since it is easy to configure and the multicast is in the LAN side which has bandwidth to handle this.

Rich R_1
Advisor

Re: Config for Multicast routing

Ok, thus say on vlan 18, I would do ip pim-dense from the 5412zl and the 2510 doesn't have that mode, just ip igmp.  

ISoliman
Super Advisor

Re: Config for Multicast routing

PIM should be enabled on the routing switch only, for the other layer 2 switches just enable IP IGMP under the multicast users vlan.