LAN Routing

Connecting two LAN

Go to solution

Connecting two LAN

Hi everyone,


I have to connect two LANs via an HP 1910-24g switch.


The LAN1 is 10.0.0.x/24, the LAN2 is 192.168.17.x/24. The ports 1-23 of the switch belong to LAN1, while port 24 belongs to LAN2.

Following the user guiede, I have created two VLANs and two VLAN interfaces (one for each LAN).


Each LAN has its own default gateway to access internet.


The switch auto discovered the routing table is the following:


Destination        Mask                         Protocol       Preference      Next hop                   Interface

.....          Direct            0                               Vlan-interface1

.....     Direct            0                    Vlan-interface2



( and are the Vlan-interface1 and Vlan-interface2 IP address respctively)


From any 10.0.0.x device I can ping only on the other LAN.

From any 192.168.17.x device I can ping only on the other LAN.


I tried to ping another address from a LAN to the other with no success. Is there some other configuation options to set to let the networks work?


Many thanks


Esteemed Contributor

Re: Connecting two LAN

The symptoms you describe indicate that routing is not properly configured.


There are three options:

  1. The devices on your network should use the 1910 as their default gateway and the 1910 would have a default gateway for one of your internet routers. And then follow step two as well.
  2. If you keep your network devices pointed to your internet routers as their default gateway, you need to add static routes to your internet routers that point back to the 1910 for the remote subnet: on the router set to and on the router set to
  3. Add static routes on each device that point to the other subnet through the 1910. For example, on windows use the "route -p add mask" or "route -p add mask"


Honored Contributor

Re: Connecting two LAN


4. Windows firewall will block ICMP from a different subnet.


Re: Connecting two LAN

Hi Vince,


# 4 is the solution!


Many thanks