LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Equivalent Command in HP for native VLAN in Cisco

 
SOLVED
Go to solution
Highlighted
Occasional Advisor

Equivalent Command in HP for native VLAN in Cisco

What's the equivalent HP 2530 switch command for the below Cisco interface configuration?

interface GigabitEthernet1/0/22
switchport trunk native vlan 70
switchport trunk allowed vlan 60,70
switchport mode trunk
spanning-tree portfast

1 REPLY 1
Highlighted
Honored Contributor
Solution

Re: Equivalent Command in HP for native VLAN in Cisco

Hi,

If Cisco IOS has:

interface GigabitEthernet1/0/22
switchport trunk native vlan 70
switchport trunk allowed vlan 60,70
switchport mode trunk
spanning-tree portfast

then the above (minus the spanning-tree portfast) can be replicated on Aruba ArubaOS-Switch (HP ProVision):

# Enter the VLAN 70 (vlan 70 must exists) context
vlan 70
# Assign interface x (where x is the interface Id) to above VLAN as Untagged member (untagged traffic)
untagged x
# Enter the VLAN 60 (vlan 60 must exists) context
vlan 60
# Assign interface x (where x is the interface Id) to above VLAN as Tagged member (tagged traffic)
tagged x

That way you are configuring interface x as untagged member of VLAN 70 and tagged member of VLAN 60.

Then, for the spanning-tree portfast, the equivalence is:

spanning-tree x admin-edge-port

where x is, as usual, the interface Id.

Please note that the admin-edge-port option overrides the auto-edge (feature) which is enabled by default on all ports. Consider that an updated HP/Aruba switch has the auto-edge detection feature which will automatically detect if a port is edge or non edge (example: switch-to-switch, means a port not used for access/edge) based on if a BPDU is received on that interface.