LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Expected behaviour or configuration problem?

 
frankm2
Occasional Visitor

Expected behaviour or configuration problem?

I have connected an 5412zl(K.15.30 stp enabled) port d21 with an 2510G-48(Y.11.08 no stp enabled) port 25 using an RJ45 cable, on both we have two VLANs configured, to simplify the setup and eliminating other possible errors I reduced the configuration to that scenario.

2510G-48

vlan 222
tagged 25,48
exit
vlan 111
ip address 1.1.1.1 255.255.255.0
tagged 25,48
exit

Status and Counters - VLAN Information - for ports 25

VLAN ID Name Status Voice Jumbo
------- -------------------- ------------ ----- -----

1        DEFAULT_VLAN
111    Port-based No No
222  Port-based No No

5412zl

vlan 222
tagged d21
exit
vlan 111
ip address 1.1.1.2 255.255.255.0
tagged d21
exit

Status and Counters - VLAN Information - for ports d21

VLAN ID Name Status Voice Jumbo
------- -------------------- ------------ ----- -----
111    Port-based No No
222  Port-based No No

As long as as port 25 and 48 remains untagged in VLAN1 I can't ping from switch to switch, when I remove them by setting them "no untagged 25,48" in vlan 1 everything is fine and I get a reply. I would expect it to work even when the ports remain untagged in default vlan. Am I wrong? Is this expected behaviour on HP procurves? Any thought on this?

1 REPLY
Vince-Whirlwind
Honored Contributor

Re: Expected behaviour or configuration problem?

I suspect the snippet of config you have provided does not contain the bit that is relevant to understanding the behaviour.

Do you have IP routing enabled?
Do you have any other IP addresses on either switch?
What are you pinging, exactly?
What is the management VLAN set to on each switch?