LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

For VMWare VLAN trunking solution on HP switch on a similar Cisco way

SOLVED
Go to solution
TBITGuys
Occasional Advisor

For VMWare VLAN trunking solution on HP switch on a similar Cisco way

Hi,

 

best greetings from Germany,

We got a VMWare ESXI solution with ISCSI which should be on a different VLAN. But our IT stuff from our parent company hasn't work with HP switches so thats why we have small issues to configure our ISCSI directly throug a virtual machine. They only have CISCO and build up this solution on this scenario.  I can imagine that the way on HP switch level should be also reachable.

 

We have 4x HP 2920-48G switches stacking (works fine).

 

Build up scenario:

On both Switch 1 & 2:

Port 1 -> Router CISCO (on second an backup CISCO router) untagged as default vlan (1)

Port 3-18 -> ISCSI (NAS and ISCSI ESXI Server on a VLAN  untagged 5

Port 19-21 -> ESXI Management (& vMotion)/ manage interface network for ISCSI configuration.  untagged as default vlan (1) (is also manged on monitored over vcenter management server in our parent company).

Port above 22-25 for Virtuell Machine client network

 

On Cisco way the solution should be that port 19-21 are all vlan trunking ports (CISCO thinking) on our HP switch, so that every vlan is reachable. You only to have one virtuell machine based on windows for exemple who gots a second network adapter with access on the management interface network for the iscsi connection with the setting vlan5.

Calling him vmAdminPC for example.

 

I tried a lot but always we lose the connection to vcenter in our parent company. Every physical networkcard in the esxi server has no vlan tagging. But it works in our parent company based on cisco switches. No routing should be necessary. The guys in our parent company have it on the same way like our ESXI system is set up.

 

Here is the configuration file, in the moment we can only setup our ISCSI env. over a plugged cable to vlan5 ports.

IP configuration of ISCSI 172.16.0.X rest is based on 10.2.1.X

 

Attached a picture of ESXI networkcard configuration from vsphere client (sry it is german but should be easy to understand for you guys).

 

Here is the configuration of our switches (after reading a lot of best practises in case of esxi server):

 

Running configuration:

; hpStack_WB Configuration Editor; Created on release #WB.15.13.0008
; Ver #05:18.e3.ff.35.0d:39

stacking
   member 1 type "J9728A" mac-address d4c9ef-ada3c0
   member 2 type "J9728A" mac-address a01d48-797140
   member 2 priority 120
   member 3 type "J9728A" mac-address d4c9ef-c54900
   member 3 priority 120
   member 4 type "J9728A" mac-address c4346b-9503c0
   member 4 priority 120
   exit
hostname "TBKIESW01"
trunk 4/47-4/48 trk1 trunk
trunk 3/47-3/48 trk2 trunk
trunk 2/47-2/48 trk3 trunk
ip default-gateway 10.2.1.1
ip routing
interface 1/1
   flow-control
   exit
interface 1/2
   flow-control
   exit
interface 1/3
   flow-control
   exit
interface 1/4
   flow-control
   exit
interface 1/5
   flow-control
   exit
interface 1/6
   flow-control
   exit
interface 1/7
   flow-control
   exit
interface 1/8
   flow-control
   exit
interface 1/9
   flow-control
   exit
interface 1/10
   flow-control
   exit
interface 1/11
   flow-control
   exit
interface 1/12
   flow-control
   exit
interface 1/13
   flow-control
   exit
interface 1/14
   flow-control
   exit
interface 1/15
   flow-control
   exit
interface 1/16
   flow-control
   exit
interface 1/17
   flow-control
   exit
interface 1/18
   flow-control
   exit
interface 1/19
   flow-control
   exit
interface 1/20
   flow-control
   exit
interface 1/21
   flow-control
   exit
interface 1/22
   flow-control
   exit
interface 1/23
   flow-control
   exit
interface 1/24
   flow-control
   exit
interface 1/25
   flow-control
   exit
interface 1/26
   flow-control
   exit
interface 1/27
   flow-control
   exit
interface 1/28
   flow-control
   exit
interface 1/29
   flow-control
   exit
interface 1/30
   flow-control
   exit
interface 1/31
   flow-control
   exit
interface 1/32
   flow-control
   exit
interface 1/33
   flow-control
   exit
interface 1/34
   flow-control
   exit
interface 1/35
   flow-control
   exit
interface 1/36
   flow-control
   exit
interface 1/37
   flow-control
   exit
interface 1/38
   flow-control
   exit
interface 1/39
   flow-control
   exit
interface 1/40
   flow-control
   exit
interface 1/41
   flow-control
   exit
interface 1/42
   flow-control
   exit
interface 1/43
   flow-control
   exit
interface 1/44
   flow-control
   exit
interface 1/45
   flow-control
   exit
interface 1/46
   flow-control
   exit
interface 1/47
   flow-control
   exit
interface 1/48
   flow-control
   exit
interface 2/1
   flow-control
   exit
interface 2/2
   flow-control
   exit
interface 2/3
   flow-control
   exit
interface 2/4
   flow-control
   exit
interface 2/5
   flow-control
   exit
interface 2/6
   flow-control
   exit
interface 2/7
   flow-control
   exit
interface 2/8
   flow-control
   exit
interface 2/9
   flow-control
   exit
interface 2/10
   flow-control
   exit
interface 2/11
   flow-control
   exit
interface 2/12
   flow-control
   exit
interface 2/13
   flow-control
   exit
interface 2/14
   flow-control
   exit
interface 2/15
   flow-control
   exit
interface 2/16
   flow-control
   exit
interface 2/17
   flow-control
   exit
interface 2/18
   flow-control
   exit
interface 2/19
   flow-control
   exit
interface 2/20
   flow-control
   exit
interface 2/21
   flow-control
   exit
interface 2/22
   flow-control
   exit
interface 2/23
   flow-control
   exit
interface 2/24
   flow-control
   exit
interface 2/25
   flow-control
   exit
interface 2/26
   flow-control
   exit
interface 2/27
   flow-control
   exit
interface 2/28
   flow-control
   exit
interface 2/29
   flow-control
   exit
interface 2/30
   flow-control
   exit
interface 2/31
   flow-control
   exit
interface 2/32
   flow-control
   exit
interface 2/33
   flow-control
   exit
interface 2/34
   flow-control
   exit
interface 2/35
   flow-control
   exit
interface 2/36
   flow-control
   exit
interface 2/37
   flow-control
   exit
interface 2/38
   flow-control
   exit
interface 2/39
   flow-control
   exit
interface 2/40
   flow-control
   exit
interface 2/41
   flow-control
   exit
interface 2/42
   flow-control
   exit
interface 2/43
   flow-control
   exit
interface 2/44
   flow-control
   exit
interface 2/45
   flow-control
   exit
interface 2/46
   flow-control
   exit
interface 2/48
   flow-control
   exit
snmp-server community "public" unrestricted
snmp-server contact "TB Kiel HV"
oobm
   ip address dhcp-bootp
   member 1
      ip address dhcp-bootp
      exit
   member 2
      ip address dhcp-bootp
      exit
   member 3
      ip address dhcp-bootp
      exit
   member 4
      ip address dhcp-bootp
      exit
   exit
vlan 1
   name "DEFAULT_VLAN"
   no untagged 1/3-1/18,2/3-2/18
   untagged 1/1-1/2,1/19-1/48,1/A1-1/A2,1/B1-1/B2,2/1-2/2,2/19-2/46,2/A1-2/A2,2/B1-2/B2,3/1-3/46,3/A1-3/A2,3/B1-3/B2,4/1-4/46,4/A1-4/A2,4/B1-4/B2,Trk1-Trk3
   ip address 10.2.1.15 255.255.254.0
   exit
vlan 5
   name "ISCSI"
   untagged 1/3-1/18,2/3-2/18
   tagged 1/19-1/22,2/19-2/22
   no ip address
   jumbo
   exit
spanning-tree
spanning-tree 1/3 admin-edge-port
spanning-tree 1/3 bpdu-filter
spanning-tree 1/4 admin-edge-port
spanning-tree 1/4 bpdu-filter
spanning-tree 1/5 admin-edge-port
spanning-tree 1/5 bpdu-filter
spanning-tree 1/6 admin-edge-port
spanning-tree 1/6 bpdu-filter
spanning-tree 1/7 admin-edge-port
spanning-tree 1/7 bpdu-filter
spanning-tree 1/8 admin-edge-port
spanning-tree 1/8 bpdu-filter
spanning-tree 1/9 admin-edge-port
spanning-tree 1/9 bpdu-filter
spanning-tree 1/10 admin-edge-port
spanning-tree 1/10 bpdu-filter
spanning-tree 1/11 admin-edge-port
spanning-tree 1/11 bpdu-filter
spanning-tree 1/12 admin-edge-port
spanning-tree 1/12 bpdu-filter
spanning-tree 1/13 admin-edge-port
spanning-tree 1/13 bpdu-filter
spanning-tree 1/14 admin-edge-port
spanning-tree 1/14 bpdu-filter
spanning-tree 1/15 admin-edge-port
spanning-tree 1/15 bpdu-filter
spanning-tree 1/16 admin-edge-port
spanning-tree 1/16 bpdu-filter
spanning-tree 1/17 admin-edge-port
spanning-tree 1/17 bpdu-filter
spanning-tree 1/18 admin-edge-port
spanning-tree 1/18 bpdu-filter
spanning-tree 2/3 admin-edge-port
spanning-tree 2/3 bpdu-filter
spanning-tree 2/4 admin-edge-port
spanning-tree 2/4 bpdu-filter
spanning-tree 2/5 admin-edge-port
spanning-tree 2/5 bpdu-filter
spanning-tree 2/6 admin-edge-port
spanning-tree 2/6 bpdu-filter
spanning-tree 2/7 admin-edge-port
spanning-tree 2/7 bpdu-filter
spanning-tree 2/8 admin-edge-port
spanning-tree 2/8 bpdu-filter
spanning-tree 2/9 admin-edge-port
spanning-tree 2/9 bpdu-filter
spanning-tree 2/10 admin-edge-port
spanning-tree 2/10 bpdu-filter
spanning-tree 2/11 admin-edge-port
spanning-tree 2/11 bpdu-filter
spanning-tree 2/12 admin-edge-port
spanning-tree 2/12 bpdu-filter
spanning-tree 2/13 admin-edge-port
spanning-tree 2/13 bpdu-filter
spanning-tree 2/14 admin-edge-port
spanning-tree 2/14 bpdu-filter
spanning-tree 2/15 admin-edge-port
spanning-tree 2/15 bpdu-filter
spanning-tree 2/16 admin-edge-port
spanning-tree 2/16 bpdu-filter
spanning-tree 2/17 admin-edge-port
spanning-tree 2/17 bpdu-filter
spanning-tree 2/18 admin-edge-port
spanning-tree 2/18 bpdu-filter
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
spanning-tree config-name "ISCSI_SERVER"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1
spanning-tree mode rapid-pvst
spanning-tree force-version rstp-operation
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager
password operator

 

Have anyone a solution/idea how I will get this vlan trunking way from cisco on a same way on this HP switches?

 

Thanks for every reply!

11 REPLIES
Vince-Whirlwind
Honored Contributor

Re: For VMWare VLAN trunking solution on HP switch on a similar Cisco way

With Cisco, you configure a port with sw mode trunk and 802.1q format and it automatically adds all VLANs to that port (as tagged VLANs). (You then filter out the VLANs you don't want using "allow vlan").

 

With HP, there is no "vlan trunk" config and you just add each VLAN you need as "tagged" to each port where you need it.

TBITGuys
Occasional Advisor

Re: For VMWare VLAN trunking solution on HP switch on a similar Cisco way

Hi,

 

thanks for your reply.

 

I understand you that there is now way?

Because I add the VLAN as tagged ports to the ESXI management ports. So I understand it from other vlan tagging describing sites. But it doesn't work. I could not reach over a virtual machine with tagged vlan 5 network card the iscsi system when I add a network card adapter to this virtual machine called "manage".

 

What is wrong with my config on this behaviour?

I am a little bit counfused now, sry.

Vince-Whirlwind
Honored Contributor

Re: For VMWare VLAN trunking solution on HP switch on a similar Cisco way

So, if you have configured this:

vlan 5
   name "ISCSI"
   untagged 1/3-1/18,2/3-2/18
   tagged 1/19-1/22,2/19-2/22

 

 

The if you patch HP switchport 1/19 into a Cisco switch, the Cisco switchport would be:

interface 1/0/19

   sw mo trunk

   sw tr encap dot1q

   sw tr nat vlan 1

   sw tr vlan allow 1,5

 

That's the same as having HP configured with VLAN1 untagged, VLAN 5 tagged.

Vince-Whirlwind
Honored Contributor

Re: For VMWare VLAN trunking solution on HP switch on a similar Cisco way

Have you tagged the uplink switchports that go to your "Core" switch into VLAN5?

 

 

Vince-Whirlwind
Honored Contributor

Re: For VMWare VLAN trunking solution on HP switch on a similar Cisco way

I suspect you have forgotten to add trk1, trk2, or trk3 to VLAN5 as "tagged" ports.

TBITGuys
Occasional Advisor

Re: For VMWare VLAN trunking solution on HP switch on a similar Cisco way

Thanks again. :)

 

Well, behind this trk ports are only client switches, they need no access to vlan5. All esxi relevant traffic are on the first two of four stacked (real stacked) switches from hp.  The only behaviour should be that a virtual machine over the manage network card on the management port have access by setting the virtual machines second network card to vlan5.

 

So it should work now, but it didn't somewhere I read that a HP switch needs a reboot to handle tagged ports, could that be the solution?

Vince-Whirlwind
Honored Contributor

Re: For VMWare VLAN trunking solution on HP switch on a similar Cisco way

Are you saying a host patched to 1/0/19 has no layer2 connectivity to a host patched to 2/0/19?

 

 

TBITGuys
Occasional Advisor

Re: For VMWare VLAN trunking solution on HP switch on a similar Cisco way

We try to reach through Port 1/19 or 2/19 by setting a virtual machine with a network card connected to esxi manage switchcard with vlan5 to the ISCSI system which are on the untagged vlan 5 ports from 1/3 to 1/18 and similar 2/3 -to 2/18.  The virtual machine network card is on the same IP Level like the ISCSI system:

 

virtual host ip adress:  172.16.0.200 adapted to vlan5 on tagged vlan5 port 1/19 (also untagged as vlan1 to reach the server for management from default network and vcenter from parent company)

ISCSI system system ip adress 172.16.0.100 on untagged vlan5 ports 1/3

 

 

Vince-Whirlwind
Honored Contributor

Re: For VMWare VLAN trunking solution on HP switch on a similar Cisco way

If you do a show mac-address table, VLAN5, can you see any entries in the switch from any of the hosts in the VMware environment?
On the face of it, the switch config is very simple, so of it's not working, it seems likely you haven't trunked it through the virtual switch properly.
Often it's tagged VLAN being mismatched with an interface where it is untagged. Or a switch that doesn't have the VLAN actually created or enabled. Narrow it down by trying different virtual hosts try using VLAN5 between each other.
TBITGuys
Occasional Advisor

Re: For VMWare VLAN trunking solution on HP switch on a similar Cisco way

Okay that is an idea. I will try some tests and check the mac adress table on switch, thanks.

TBITGuys
Occasional Advisor
Solution

Re: For VMWare VLAN trunking solution on HP switch on a similar Cisco way

I changed the Manage Physical Networkcard Switch on ESXI to VLAN (all) and configured again a network card on this interface with vlan5. Looked on the mac adress table:

TBKIESW01# sh mac-address vlan 5

Status and Counters - Address Table - VLAN 5

MAC Address Port
------------- ---------
00098a-027b47 1/7
00098a-027b48 2/6
00098a-027b49 2/5
00098a-027baa 2/8
00098a-027bab 1/9
00098a-027bac 1/10
001132-2827c9 2/4
001132-2827ca 1/3
001132-2827cb 2/3
001132-2827cc 1/4
005056-6476ec 1/12
005056-6758e0 2/12
005056-688bee 2/13
005056-694b1d 1/11
005056-69d318 1/13
005056-6b0c36 2/11
005056-6b4e9e 1/14
005056-6d859a 2/14
005056-9127ed 1/20
005056-916916 1/20

 

(The esxi server is managed over ports 1/20 as well)

 

Try to ping each system and voila it works, perfectly. 

I am really glad that you help us :)

Thanks a lot.