LAN Routing
Showing results for 
Search instead for 
Did you mean: 

HP 2530-48-PoEP Switch "high collision or drop rate" & "Excessive CRC/alignment errors."


HP 2530-48-PoEP Switch "high collision or drop rate" & "Excessive CRC/alignment errors."

Hi Guys,

Good day. I got some issues on my HP 2530-48-PoEP Switch.

1. "high collision or drop rate" (almost 20 ports affected) and those 20 ports are connected to user PCs.

- i know that high collision is caused by Half Duplex Hub or HD Devices.

- I decide to hard code the Speed-Duplex from "Auto" to "100-Full"

- Once i have configured, the "Excessive CRC/alignment errors." occured.

"Excessive CRC/alignment errors." is caused by Physical & Datalink problem, bad cables, ports, NICs, duplex mismatch.

- Did you guys have any solution ?



Honored Contributor

Re: HP 2530-48-PoEP Switch "high collision or drop rate" & "Excessive CRC/alignme

There isn't a solution for a misconfiguration (and/or for an Hardware related - passive cabling side & host side- issues), so reset to Auto the Speed Negotiation setting on all [*] relevant port (check that your Hosts have that setting to on each of their NICs <-- you should check also that those NICs have proper and updated software device driver installed on relevant OS used)...then...reset Duplex Mode to Full-Duplex.

Test by connecting a known working Host (NIC Network Interface Card should be OK on its side) directly using a new certified Cat. 5E Patch Cable 3 meters (or so) long (it's enough to ensure proper Fast Ethernet - 100 Mbps - connections between your Switch and your Hosts) and verify, with these test conditions, if problem still occurs (or suddenly appears) on used Switch port with that test Host.

Generally, if the Switch is not at fault (Hardware level) and if it is updated, those issues happens on bad passive cabling (not certified nor tested to pass Cat. 5E and/or Cat. 6 certifications) testing using a simple Patch Cable should reveal the culprit (Cabling? NICs? Hosts? Switch?) is almost immediately.

[*] sometimes Printers' 100Mbps NIC port (on old printers) is not enough smart to manage the port Speed Auto-Negotiation correctly (to cope with the same setting on the Switch port), in that case, you should observe if there is an issue and manage it properly (case by case) by testing other settings (as example by setting 100Mbps and Full-Duplex instead of Auto and Full-Duplex on both side).

I'm not an HPE Employee
Kudos and Accepted Solution banner