LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 2920 inter vlan routing

bubai70
Occasional Contributor

HP 2920 inter vlan routing

the HP 2920 switch connected my core switch (extreme black diamond 8810) but while any traffic goes from HP 2920 to the core switch other switch (connected to that particular core switch) stop talking with the core switch. In this scenario if I power off HP 2920 then the traffic goes normal between core switch & other switch (which is connected with the core).
I don't understand what's going on.

Attached switch config below......

sh config

Startup configuration: 113

; J9727A Configuration Editor; Created on release #WB.15.11.0007
; Ver #03:12.15.0d:09

hostname "CLAB1 02"
module 1 type j9727a
ip access-list extended "test1"
10 permit ip 192.168.0.0 0.0.0.255 192.168.5.0 0.0.0.255
20 permit ip 192.168.5.0 0.0.0.255 192.168.0.0 0.0.0.255
30 permit ip 192.168.5.0 0.0.0.255 192.168.1.0 0.0.0.255
40 permit ip 192.168.5.0 0.0.0.255 192.168.5.0 0.0.0.255
50 permit ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
60 permit ip 192.168.0.0 0.0.0.255 192.168.0.0 0.0.0.255
70 permit ip 192.168.1.0 0.0.0.255 192.168.0.0 0.0.0.255
80 permit ip 192.168.1.0 0.0.0.255 192.168.1.0 0.0.0.255
90 permit ip 192.168.1.0 0.0.0.255 192.168.5.0 0.0.0.255
exit
ip default-gateway 192.168.0.1
ip routing
snmp-server community "public" unrestricted
oobm
ip address dhcp-bootp
exit
vlan 1
name "DEFAULT_VLAN"
no untagged 1-22
untagged A1-A2,B1-B2
tagged 23-24
ip access-group "test1" vlan
ip address 192.168.0.17 255.255.255.0
exit
vlan 2
name "wireless1"
ip address 192.168.2.1 255.255.255.0
exit
vlan 3
name "printers"
ip address 192.168.3.1 255.255.255.0
exit
vlan 4
name "ccct-admin"
ip address 192.168.4.1 255.255.255.0
exit
vlan 5
name "computers-lab-1"
untagged 1-22
tagged 23-24
ip access-group "test1" vlan
ip address 192.168.5.1 255.255.255.0
exit
vlan 6
name "computers-lab-2"
ip address 192.168.6.1 255.255.255.0
exit
vlan 7
name "computers-lab-3"
ip address 192.168.7.1 255.255.255.0
exit
vlan 8
name "staff "
ip address 192.168.8.1 255.255.255.0
exit
vlan 9
name "library"
ip address 192.168.9.1 255.255.255.0
exit
vlan 10
name "others lab"
ip address 192.168.10.1 255.255.255.0
exit
vlan 11
name "hostels"
ip address 192.168.11.1 255.255.255.0
exit
vlan 12
name "staff-quarters"
ip address 192.168.12.1 255.255.255.0
exit
vlan 1001
name "serverfarm"
tagged 23-24
ip access-group "test1" vlan
ip address 192.168.1.1 255.255.255.0
exit

CLAB1 02(config)#

5 REPLIES
bubai70
Occasional Contributor

Re: HP 2920 inter vlan routing

As per my network diagram configuration is ok but I don't understand the logic behind it .... please help me
bubai70
Occasional Contributor

Re: HP 2920 inter vlan routing

I just wanted to configure inter vlan routing and I did it successfully only this challenge I am facing.
bubai70
Occasional Contributor

Re: HP 2920 inter vlan routing

The funny thing is that once the HP 2920 back to online after restarting it stops talking to the core switch
Vince-Whirlwind
Honored Contributor

Re: HP 2920 inter vlan routing

Need more details:

 

 - what is the config of the "other switch"? 

What VLANs, what IP addresses, and what ports are patched to the core (and any other switch), detail all its switch neighbours.

 - same info required for the "core".

 

What traffic fails, exactly? (Source IP , destination IP).

 

If the 2920 is not your "core", then why is it configured for routing?

 

Apparently, the only VLANs trunked to the core are VLANs 1, 5 and 1001.

The switch's default GW is on VLAN1, presumably the "core" VLAN1 address is .1.

 

(Personally, I am very superstitious of VLAN ID 1001, and never use it. Not all vendors allow it.).

Kent Breeding
Occasional Visitor

Re: HP 2920 inter vlan routing

Let's just look at what you have that does "something".
What actually matters here is only related to these three VLANs 1, 5, 1001.
Question: Which port(s) link to the BD8810?
If only port 23 OR port 24 I see no problem.
If both port 23 & port 24 link to the 8810 at the same time then you make a loop.
If you do not have spanning tree enabled then you are creating a packet storm.
If your intention is for link aggregation then you need a LAG i.e. trunk configured on both ends of the link.
I sort of suspect you may intend to have the uplink with port aggregation but do not know.
If the 802.1q tagging of the VLANs on both ends of the uplink interface match then those will pass.
The only clients are obviously in VLAN 5 on ports 1-22.
If you want the local VLANs to route through VLAN 1 via next hop 192.168.0.1 then you need the default route configured.
ip route 0.0.0.0 0.0.0.0 192.168.0.1 (add the default route with routing enabled)
If clients in VLAN 5 have 192.168.5.1 as their gateway then with the default route added they will also route out.

ip default-gateway 192.168.0.1 <- This applies to the switch without routing enabled. i.e. Layer 2
ip routing

vlan 1
name "DEFAULT_VLAN"
no untagged 1-22
untagged A1-A2,B1-B2
tagged 23-24 <- On the 8810 Vlan 1 is tagged as well? Confirm tagged or untagged on the 8810.

 

The statement that traffic from the "other switch" stops to the 8810 makes me firmly believe that both ports 23 & 24 were uplinked to the 8810 making a loop that would explain the service disruption IF spanning tree is not enabled on the 8810 core. The statement is not clear enough as to how extensive the disruption is for the active VLANs. If we are only seeing a disruption to one VLAN segment then the duplication of the gateway address for clients on the other switch would present a problem at layer 3. I would expect intermittent behavior at least then as a possible symptom.

 

The additional LLDP neighbor information would clarify exactly how things were linked. I still suspect a loop and that the CPUs ramp up and things begin to fail very quickly. The removal of the 2920 in this situation would resolve the introduction of an unwanted loop.