LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 5130-24 G | configuration help

 
josejesuratnam
Regular Visitor

HP 5130-24 G | configuration help

Dear Team,

Please help me to configure the 5130-24g switch.

Requirements:

24th is the Gigabit port and i need Vlan 3

SFP port 25 i need vlan 1  and ip 192.168.0.2 /24 

SFP port 26 i need vlan 3 and ip 192.168.1.1 /24

How to save and how to create a .cfg file.

-------------------------------------------------------

i have done the configuration little but not fully done. i will share here the configurations which i did. I need all the nessessary configuration commands it would be great helpful to me. waiting for the quick responce.

hp 5130-24g flex network switch


Press Ctrl+B to access EXTENDED BOOT MENU...0
Loading the main image files...
Loading file flash:/5130ei-cmw710-system-r3111p02.bin...........................
...................................Done.
Loading file flash:/5130ei-cmw710-boot-r3111p02.bin...........Done.

Image file flash:/5130ei-cmw710-boot-r3111p02.bin is self-decompressing.........
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
......................................................................Done.
System is starting...
Cryptographic algorithms tests passed.

Startup configuration file does not exist.
Started automatic configuration, press CTRL_C or CTRL_D to break.

Automatic configuration attempt: 1.
Not ready for automatic configuration: no interface available.
Waiting for the next...
Automatic configuration is running, press CTRL_C or CTRL_D to break.
Automatic configuration is aborted.
Line aux0 is available.


Press ENTER to get started.

<HPE>
<HPE>%Jan 1 00:01:08:330 2013 HPE SHELL/5/SHELL_LOGIN: TTY logged in from aux0.

<HPE>
<HPE>display current configuration
#
sysname HPE
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 1
#
lldp global enable
#
password-recovery enable
#
vlan 1
#
stp global enable
#
scheduler logfile size 16
#
line class aux
user-role network-admin
#
line class vty
user-role network-operator
#
line aux 0
user-role network-admin
#
line vty 0 63
user-role network-operator
#
radius scheme system
user-name-format without-domain
#
domain system
#
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role
#
role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
user-group system
#
return
<HPE>

<HPE>?
User view commands:
archive Archive configuration
backup Backup the startup configuration file to a TFTP server
boot-loader Software image file management
bootrom Update/read/backup/restore bootrom
cd Change current directory
cfd Connectivity Fault Detection (CFD) module
clock Specify the system clock
copy Copy a file
debugging Enable system debugging functions
delete Delete a file
diagnostic-logfile Diagnostic log file configuration
dir Display files and directories on the storage media
display Display current system information
exception Exception information configuration
fdisk Partition a storage medium
fixdisk Check and repair a storage medium
format Format a storage medium
free Release a connection
ftp Open an FTP connection
gunzip Decompress file
gzip Compress file
install Perform package management operation
ip Specify IP configuration
lock Lock the current line
logfile Log file configuration
md5sum Compute the hash digest of a file using the MD5 algorithm
mkdir Create a new directory
monitor System monitor
more Display the contents of a file
move Move a file
oam OAM module
ping Ping function
process Process management
pwd Display current working directory
python Source using python script
quit Exit from current command view
reboot Reboot operation
rename Rename a file or directory
reset Reset operation
restore Restore next startup-configuration file from TFTP server
rmdir Remove an existing directory
save Save current configuration
scheduler Scheduler configuration
scp Establish an SCP connection to an SCP server
screen-length Multiple-screen output function
security-logfile Security log file configuration
send Send information to other lines
sftp Establish an SFTP connection to an SFTP server
sha256sum Compute the hash digest of a file using the SHA256
algorithm
ssh2 Establish an Stelnet connection to an Stelnet server
startup Specify system startup parameters
super Switch to a user role
system-view Enter the System View
tar Archive management
tclquit Exit from TCL shell
tclsh Enter the TCL shell
telnet Establish a telnet connection
terminal Set the terminal line characteristics
tftp Open a TFTP connection
tracert Tracert function
undelete Recover a deleted file
undo Cancel current setting
web Web configuration
xml Enter XML view

<HPE>
<HPE>
<HPE>ip ?
forwarding-table IP forwarding table

<HPE>display ip routing-table
ROUTE4 is not configured.

<HPE>terminal ?
debugging Enable to display debugging logs on the current terminal
logging Display logs on the current terminal
monitor Enable to display logs on the current terminal

<HPE>terminal monitor
The current terminal is enabled to display logs.
<HPE>save
The current configuration will be written to the device. Are you sure? [Y/N]:y
Please input the file name(*.cfg)[flash:/startup.cfg]
(To leave the existing filename unchanged, press the enter key):
Validating file. Please wait...
Saved the current configuration to mainboard device successfully.
<HPE>system view
^
% Too many parameters found at '^' position.
<HPE>system-view
System View: return to User View with Ctrl+Z.
[HPE]
[HPE]
[HPE]
[HPE]interface vlan-interface 1
[HPE-Vlan-interface1]%Jan 1 00:15:59:982 2013 HPE OPTMOD/4/MODULE_IN: Ten-GigabitEthernet1/0/25: The transceiver is 1000_BASE_LX_SFP.
%Jan 1 00:16:01:535 2013 HPE IFNET/3/PHY_UPDOWN: Ten-GigabitEthernet1/0/25 link status is up.
%Jan 1 00:16:01:551 2013 HPE IFNET/5/LINK_UPDOWN: Line protocol on the interface Ten-GigabitEthernet1/0/25 is up.
%Jan 1 00:16:01:554 2013 HPE IFNET/3/PHY_UPDOWN: Vlan-interface1 link status is up.
%Jan 1 00:16:01:566 2013 HPE IFNET/5/LINK_UPDOWN: Line protocol on the interface Vlan-interface1 is up.
%Jan 1 00:16:01:728 2013 HPE STP/6/STP_DETECTED_TC: Instance 0's port Ten-GigabitEthernet1/0/25 detected a topology change.
%Jan 1 00:16:01:787 2013 HPE LLDP/6/LLDP_CREATE_NEIGHBOR: Nearest bridge agent new neighbor created on Port Ten-GigabitEthernet1/0/25 (IfIndex 25), Chassis ID is 40b9-3c6b-5ce4, Port ID is GigabitEthernet1/0/25.

%Jan 1 00:16:01:818 2013 HPE STP/6/STP_NOTIFIED_TC: Instance 0's port Ten-GigabitEthernet1/0/25 was notified a topology change.
%Jan 1 00:16:02:728 2013 HPE STP/6/STP_NOTIFIED_TC: Instance 0's port Ten-GigabitEthernet1/0/25 was notified a topology change.

[HPE-Vlan-interface1]
[HPE-Vlan-interface1]q
[HPE]ip http enable
[HPE]ip https enable
The system might take several minutes to enable the HTTPS service. Please wait...
[HPE]ip http port 80
[HPE]web idle-timeout 5
[HPE]aaa session-limit http 5
[HPE]local-user Administrator
New local user added.
[HPE-luser-manage-Administrator]save
The current configuration will be written to the device. Are you sure? [Y/N]:y
Please input the file name(*.cfg)[flash:/startup.cfg]
(To leave the existing filename unchanged, press the enter key):
flash:/startup.cfg exists, overwrite? [Y/N]:y
Validating file. Please wait...
Saved the current configuration to mainboard device successfully.


[HPE-luser-manage-Administrator]q
[HPE]

[HPE]interface vlan-interface 1
[HPE-Vlan-interface1]ip address 192.168.0.2 255.255.255.0
[HPE-Vlan-interface1]
[HPE-Vlan-interface1]#
[HPE-Vlan-interface1] sysname HPE
[HPE]#
[HPE] irf mac-address persistent timer
[HPE] irf auto-update enable
[HPE] undo irf link-delay
[HPE] irf member 1 priority 1
[HPE]#
[HPE] lldp global enable
[HPE]#
[HPE] password-recovery enable
[HPE]#
[HPE]vlan 1
[HPE-vlan1]#
[HPE-vlan1] stp global enable
[HPE]#
[HPE] scheduler logfile size 16
[HPE]#
[HPE]line class aux
[HPE-line-class-aux] user-role network-admin
[HPE-line-class-aux]#
[HPE-line-class-aux]line class vty
[HPE-line-class-vty] user-role network-operator
[HPE-line-class-vty]#
[HPE-line-class-vty]line aux 0
[HPE-line-aux0] user-role network-admin
[HPE-line-aux0]#
[HPE-line-aux0]line vty 0 63
[HPE-line-vty0-63] user-role network-operator
[HPE-line-vty0-63]#
[HPE-line-vty0-63]radius scheme system
[HPE-radius-system] user-name-format without-domain
[HPE-radius-system]#
[HPE-radius-system]domain system
[HPE-isp-system]#
[HPE-isp-system] domain default enable system
[HPE]#
[HPE]role name level-0
[HPE-role-level-0] description Predefined level-0 role
[HPE-role-level-0]#
[HPE-role-level-0]role name level-1
[HPE-role-level-1] description Predefined level-1 role
[HPE-role-level-1]#
[HPE-role-level-1]role name level-2
[HPE-role-level-2] description Predefined level-2 role
[HPE-role-level-2]#
[HPE-role-level-2]role name level-3
[HPE-role-level-3] description Predefined level-3 role
[HPE-role-level-3]#
[HPE-role-level-3]role name level-4
[HPE-role-level-4] description Predefined level-4 role
[HPE-role-level-4]#
[HPE-role-level-4]role name level-5
[HPE-role-level-5] description Predefined level-5 role
[HPE-role-level-5]#
[HPE-role-level-5]role name level-6
[HPE-role-level-6] description Predefined level-6 role
[HPE-role-level-6]#
[HPE-role-level-6]role name level-7
[HPE-role-level-7] description Predefined level-7 role
[HPE-role-level-7]#
[HPE-role-level-7]role name level-8
[HPE-role-level-8] description Predefined level-8 role
[HPE-role-level-8]#
[HPE-role-level-8]role name level-9
[HPE-role-level-9] description Predefined level-9 role
[HPE-role-level-9]#
[HPE-role-level-9]role name level-10
[HPE-role-level-10] description Predefined level-10 role
[HPE-role-level-10]#
[HPE-role-level-10]role name level-11
[HPE-role-level-11] description Predefined level-11 role
[HPE-role-level-11]#
[HPE-role-level-11]role name level-12
[HPE-role-level-12] description Predefined level-12 role
[HPE-role-level-12]#
[HPE-role-level-12]role name level-13
[HPE-role-level-13] description Predefined level-13 role
[HPE-role-level-13]#
[HPE-role-level-13]role name level-14
[HPE-role-level-14] description Predefined level-14 role
[HPE-role-level-14]#
[HPE-role-level-14]user-group system
[HPE-ugroup-system]#
[HPE-ugroup-system]return

telnet server
-------------------------------
[HPE]telnet server enable

[HPE]telnet server enable
[HPE]interface vlan-interface 2
[HPE-Vlan-interface2]ip address 192.168.0.2 24
This subnet overlaps with another interface!
[HPE-Vlan-interface2]ip address 192.168.1.1 24
[HPE-Vlan-interface2]q

[CORE SW #TTK]interface Ten-GigabitEthernet1/0/25
port up


[CORE HP #TTK]sysname CORE SW # TTK


[TTK-CORE-HP#]vlan 2
[TTK-CORE-HP#-vlan2]port ten-gigabitethernet1/0/25
[TTK-CORE-HP#]vlan 2
[TTK-CORE-HP#-vlan2]port ten-gigabitethernet1/0/26

 

[TTK-CORE-HP#]%Jan 1 06:12:21:292 2013 TTK-CORE-HP# STP/6/STP_DETECTED_TC: Instance 0's port GigabitEthernet1/0/2 detected a topology change.

[TTK-CORE-HP#]
[TTK-CORE-HP#]
[TTK-CORE-HP#]display current-configuration
#
version 7.1.045, Release 3111P02
#
sysname TTK-CORE-HP#
#
telnet server enable
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 1
#
lldp global enable
#
password-recovery enable
#
vlan 1
#
vlan 2
#
stp global enable
#
interface NULL0
#
interface Vlan-interface1
ip address 192.168.0.2 255.255.255.0
#
interface Vlan-interface2
ip address 192.168.1.1 255.255.255.0
#
interface GigabitEthernet1/0/1
#
interface GigabitEthernet1/0/2
#
interface GigabitEthernet1/0/3
#
interface GigabitEthernet1/0/4
#
interface GigabitEthernet1/0/5
#
interface GigabitEthernet1/0/6
#
interface GigabitEthernet1/0/7
#
interface GigabitEthernet1/0/8
#
interface GigabitEthernet1/0/9
#
interface GigabitEthernet1/0/10
#
interface GigabitEthernet1/0/11
#
interface GigabitEthernet1/0/12
#
interface GigabitEthernet1/0/13
#
interface GigabitEthernet1/0/14
#
interface GigabitEthernet1/0/15
#
interface GigabitEthernet1/0/16
#
interface GigabitEthernet1/0/17
#
interface GigabitEthernet1/0/18
#
interface GigabitEthernet1/0/19
#
interface GigabitEthernet1/0/20
#
interface GigabitEthernet1/0/21
#
interface GigabitEthernet1/0/22
#
interface GigabitEthernet1/0/23
#
interface GigabitEthernet1/0/24
#
interface Ten-GigabitEthernet1/0/25
port access vlan 2
port up-mode
#
interface Ten-GigabitEthernet1/0/26
port access vlan 2
port up-mode
#
interface Ten-GigabitEthernet1/0/27
#
interface Ten-GigabitEthernet1/0/28
#
scheduler logfile size 16
#
line class aux
user-role network-admin
#
line class vty
user-role network-operator
#
line aux 0
user-role network-admin
#
line vty 0 63
user-role network-operator
#
radius scheme system
user-name-format without-domain
#
domain system
#
aaa session-limit http 5
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role
#
role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
user-group system
#
local-user Administrator class manage
password hash $h$6$dhuOS/vS7DWcjHc0$rkKQEzIo2V4BPXHAkTZbrLYl+a03Jd5I+0Qu1yIb3h52EVrqq8N8ZGWGIzOTAQj3ym7M1v73+0WIhWKM9vaXFQ==
service-type http
authorization-attribute user-role network
authorization-attribute user-role network-operator
#
ip http enable
ip https enable
web idle-timeout 5
#
return