LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 8212 and Cisco 3560 Config Question

Phil Liva
Occasional Visitor

HP 8212 and Cisco 3560 Config Question

We have two schools, one with an HP 8212 and one with a Cisco 3560.  Soon the Cisco is being replaced with an HP5412.  

Currently, there is a vlan 10 on the 8212 which has 10.2.0.1 as its IP address and it uses port 48 on the Cisco with an assigned IP of 10.2.0.2.  (VLAN 10 is not defined on the Cisco) but our WAN link uses the B19 interface (untagged for vlan 10) on the HP8212.  All other VLANS on the 8212 have corresponding VLANS with different IP's and subnets on the Cisco.  My question is, how do I send traffic to the new HP5412 when I cannot assign a specific IP to any HP interfaces other than VLAN interfaces?  Thanks for any recommendations!

Cisco 

interface FastEthernet0/48
description WAN link to Upper School
no switchport
ip address 10.2.0.2 255.255.255.252

router eigrp 1
network 10.0.0.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.2.0.1

HP 8212

ip route 0.0.0.0 0.0.0.0 10.0.0.2
ip route 10.6.0.0 255.255.0.0 10.2.0.2
ip route 10.7.0.0 255.255.0.0 10.2.0.2
ip route 10.8.0.0 255.255.0.0 10.2.0.2
ip route 10.9.0.0 255.255.0.0 10.2.0.2
ip route 10.12.0.0 255.255.0.0 10.2.0.2
ip route 172.20.0.0 255.255.0.0 10.2.0.2
ip route 172.21.0.0 255.255.0.0 10.2.0.2
ip route 172.22.0.0 255.255.0.0 10.2.0.2
ip route 192.168.0.0 255.255.128.0 10.0.0.2
ip routing
ip multicast-routing

vlan 10
name "UpperSchool"
untagged B19
tagged D23-D24,E1-E8,F1-F8
ip address 10.2.0.1 255.255.255.252

 

3 REPLIES
HP-Browniee
Respected Contributor

Re: HP 8212 and Cisco 3560 Config Question

Hello

You just need to untag a port  in vlan 10,  in your case B19, and that port will be your routing port on the HP switch.

So if you connect port 0/48 on the Cisco with port B19 on the HP switch, you should be able to ping each other in the subnet 10.2.0.0/30

Kind regards

 

Phil Liva
Occasional Visitor

Re: HP 8212 and Cisco 3560 Config Question

Thanks for your recommendation, but what you describe is what we currently have running now between HP & Cisco switches.  My question is about how to configure two HP switches after we eliminate the Cisco.  We want to maintain the same vlans at each location, but they use different subnets at each location.  For instance: Faculty Vlan is 10.3.0.0/16 on our HP 8212, but Faculty Vlan is 10.7.0.0/16 on the other switch, which will be an HP 5412.   If you have any further input, I'm interested to read it.  Phil

HP-Browniee
Respected Contributor

Re: HP 8212 and Cisco 3560 Config Question

Hello

Then you should configure both hp switches as described above.

  • configure a vlan (for routing)
  • create a new subnet to connect the 2 switches and assign .1 on one side and .2 on the other side.
  • assign an untag port in that vlan on both switches.
  • configure a routing protocol, in your case you used static routes.
  • and after that you can connect them with each other and you shoud be good to go.

Kind regards