LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

HP A5500-24G-SFP EI + LACP + STP

 
Highlighted
Occasional Visitor

HP A5500-24G-SFP EI + LACP + STP

Hello,
I have an IRF stack of two HP A5500-24G-SFP EI - connected over 10Gbit. The rings (RSTP) are connected to this stack so that the end is always in another physical switch (see https://pasteboard.co/I6zfS7q.png). I have a linux server connected to the IRF stack with etherchannel lacp with layer 2 + 3 hash algorithm. When I connect a server with one switch in IRF stack (port 1/0/31 and 1/0/32) everything works. When I connect the server by plugging each network card into another switch in IRF (port 1/0/32 and 2/0/32) after a certain (random) time it starts to lag. There are plenty of spanning tree topology changes in the log.

Log message: https://pastebin.com/G0ZXGWcN

Configuration (shortened):

#
 version 5.20.99, Release 2222P08
#
 sysname MasterStack
#
 irf mac-address persistent timer
 irf auto-update enable
 undo irf link-delay
 irf member 1 priority 30
 irf member 2 priority 28
#
 domain default enable system 
#
 undo lldp enable
#
 loopback-detection enable
#
 undo ip http enable 
#
 password-recovery enable
#
vlan 1
#
vlan 199
#
vlan 200
#
vlan 201
#
vlan 202
#
vlan 203
#
vlan 204
#
vlan 205
#
vlan 206
#
vlan 207
#
vlan 221
#
domain system 
 access-limit disable 
 state active 
 idle-cut disable 
 self-service-url disable 
#
user-group system
 group-attribute allow-guest
#
local-user admin
 authorization-attribute level 3
 service-type ssh terminal
#
 stp mode rstp
 stp instance 0 priority 4096
 stp enable
#
cwmp
 undo cwmp enable
#
interface Bridge-Aggregation1
 port link-type hybrid
 port hybrid vlan 204 tagged
 port hybrid vlan 1 untagged
 stp disable
#
interface Bridge-Aggregation2
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 220 263
 stp disable
#
interface Bridge-Aggregation3
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 199
 link-aggregation mode dynamic
 stp disable
#
interface Bridge-Aggregation4
 port link-type trunk
 port trunk permit vlan 1 to 198 200 to 4093
 link-aggregation mode dynamic
 stp disable
 dhcp-snooping trust
#
interface NULL0
#
interface Vlan-interface1
#
interface Vlan-interface221
 ip address 192.168.217.2 255.255.255.248
#
interface GigabitEthernet1/0/1
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 202 tagged
 port hybrid vlan 1 untagged
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 5000 500
 stp point-to-point force-true
 stp root-protection
#
interface GigabitEthernet1/0/2
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 200 266 tagged
 port hybrid vlan 1 untagged
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 15000 5000
 stp point-to-point force-true
 stp root-protection
#
interface GigabitEthernet1/0/3
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 201 262 265 tagged
 port hybrid vlan 1 untagged
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 5000 500
 stp point-to-point force-true
 stp root-protection
#
interface GigabitEthernet1/0/4
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 205 265 293 295 tagged
 port hybrid vlan 1 untagged
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 5000 500
 stp point-to-point force-true
 stp root-protection
#
interface GigabitEthernet1/0/5
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 203 291 600 tagged
 port hybrid vlan 1 untagged
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 5000 500
 stp point-to-point force-true
 stp root-protection
#
interface GigabitEthernet1/0/6
 port link-mode bridge
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 220 263 to 264 268 to 287
 loopback-detection enable
 storm-constrain unicast kbps 5000 500
 stp disable
 port link-aggregation group 2
#
interface GigabitEthernet1/0/17
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 206 to 208 221 265 290 292 294 tagged
 port hybrid vlan 1 untagged
 loopback-detection enable
 loopback-detection control enable
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 500 500
 stp disable
#
interface GigabitEthernet1/0/18
 port link-mode bridge
 port access vlan 267
 loopback-detection enable
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 500 500
 stp disable
#
interface GigabitEthernet1/0/31
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan 1 to 198 200 to 4093
 stp disable
 undo lldp enable
 lacp period short
 port link-aggregation group 4
 dhcp-snooping trust
#
interface GigabitEthernet1/0/32
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan 1 to 198 200 to 4093
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 15000 5000
 stp disable
 undo lldp enable
 lacp period short
 port link-aggregation group 4
 dhcp-snooping trust
#
interface GigabitEthernet2/0/1
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 202 tagged
 port hybrid vlan 1 untagged
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 5000 500
 stp point-to-point force-true
 stp root-protection
#
interface GigabitEthernet2/0/2
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 200 266 tagged
 port hybrid vlan 1 untagged
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 15000 5000
 stp point-to-point force-true
 stp root-protection
#
interface GigabitEthernet2/0/3
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 201 262 265 tagged
 port hybrid vlan 1 untagged
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 5000 500
 stp point-to-point force-true
 stp root-protection
#
interface GigabitEthernet2/0/4
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 205 265 293 295 tagged
 port hybrid vlan 1 untagged
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 5000 500
 stp point-to-point force-true
 stp root-protection
#
interface GigabitEthernet2/0/5
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 203 291 tagged
 port hybrid vlan 1 untagged
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 5000 500
 stp point-to-point force-true
 stp root-protection
#
interface GigabitEthernet2/0/6
 port link-mode bridge
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 220 263 to 264 268 to 287
 loopback-detection enable
 storm-constrain unicast kbps 5000 500
 stp disable
 port link-aggregation group 2
#
interface GigabitEthernet2/0/7
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 204 tagged
 port hybrid vlan 1 untagged
 loopback-detection enable
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 5000 500
 stp disable
 port link-aggregation group 1
#
interface GigabitEthernet2/0/22
 port link-mode bridge
 port link-type hybrid
 undo port hybrid vlan 1
 port hybrid vlan 199 untagged
 port hybrid pvid vlan 199
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 500 500
 stp disable
#
interface GigabitEthernet2/0/23
 port link-mode bridge
 shutdown
 stp disable
#
interface GigabitEthernet2/0/24
 port link-mode bridge
 shutdown
 stp disable
#
interface GigabitEthernet2/0/25
 port link-mode bridge
 port link-type hybrid
 port hybrid vlan 300 tagged
 port hybrid vlan 1 untagged
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 500 500
 stp disable
#
interface GigabitEthernet2/0/30
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan all
 shutdown
 stp disable
 dhcp-snooping trust
#
interface GigabitEthernet2/0/31
 port link-mode bridge
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 199
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 15000 5000
 stp disable
 stp port bpdu-protection enable
 stp root-protection
 undo lldp enable
 lacp period short
 port link-aggregation group 3
#
interface GigabitEthernet2/0/32
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan 1 to 198 200 to 4093
 storm-constrain broadcast kbps 500 500
 storm-constrain multicast kbps 500 500
 storm-constrain unicast kbps 15000 5000
 stp disable
 undo lldp enable
 lacp period short
 port link-aggregation group 4
 dhcp-snooping trust
#
interface Ten-GigabitEthernet1/1/2
 port link-mode bridge
 stp disable
#
interface Ten-GigabitEthernet2/1/1
 port link-mode bridge
 stp disable
#
interface Ten-GigabitEthernet1/1/1
#
interface Ten-GigabitEthernet2/1/2
#
 ip route-static 0.0.0.0 0.0.0.0 192.168.217.1
#
#
 snmp-agent
 snmp-agent local-engineid 800063A2034431920BAF69
 snmp-agent community write pRIVATeGroup
 snmp-agent community read pUBLIcGroup
 snmp-agent sys-info version v2c
#
#
 ssh server enable
#
 load xml-configuration 
#
 load tr069-configuration
#
user-interface aux 0
 authentication-mode scheme
 command authorization
 command accounting
 terminal type vt100
user-interface aux 1
user-interface vty 0 4
 authentication-mode scheme
 history-command max-size 256
 protocol inbound ssh
user-interface vty 5 15
 history-command max-size 256
#
irf-port 1/1
 port group interface Ten-GigabitEthernet1/1/1 mode normal
#
irf-port 2/2
 port group interface Ten-GigabitEthernet2/1/2 mode normal
#
return

 

2 REPLIES 2
Highlighted
Honored Contributor

Re: HP A5500-24G-SFP EI + LACP + STP

Why there are so many stp disable?

Highlighted
Occasional Visitor

Re: HP A5500-24G-SFP EI + LACP + STP

Because I don't need on those the port.  I try everything.  First I had STP enabled on all ports. Where is set stp disable, was set edge mode.