LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

IPv6 Multicast Listener Discovery (MLD) does not work on department switch HP5120

 
Juergen Bachsteffel
Occasional Advisor

IPv6 Multicast Listener Discovery (MLD) does not work on department switch HP5120

Hello!

I have two switches. A central switch, where I do the static routing and
a department switch. Both are connected via a 'tagged uplink'.

I have two switches. A central switch, where I do the static routing and
a department switch. Both are connected via a 'tagged uplink'.

My Problem: MLD ist not working on the department switch.

The only thing I had to do in the central switch, was to
enable MLD at VLAN 1.

Maybe someone can  give me  hints (tutorials etc.).
I don't need a exact solution. Where can I find more knowledge?

All config examples in the doumentation are COMWARE to COMWARE. They don't help me so much.These examples show how to configure multicast-VLAN's and so on. I don't no, if I need that.

Thank you very much!

Regards,
      Juergen

Central switch (router) 5406:

# show ipv6 mld

MLD Service Protocol Info

  Total vlans with MLD enabled                : 2
  Current count of multicast groups joined    : 17

  VLAN ID : 1      NAME : DEFAULT_VLAN
  MLD Version : 2

  MLD Interface State : Querier
  Querier Address     : fe80::219:bbff:fe0e:c600 [this switch]
          Version     : 2
          Uptime      : 2d 19h 43m
          Expires     : 0m 17s
  Ports with multicast routers :

  Active Group Addresses                   Tracking Vers Mode Uptime   Expires
  ---------------------------------------- -------- ---- ---- -------- --------
  ff02::1:ff12:9d51                        Standard 1    EXC  1h 35m   2m 35s
  ff02::1:ff12:a407                        Standard 1    EXC  26m 48s  2m 35s
....

Department switch 5120:

Department switch 5120:

# display mld-snooping statistics

 Received MLD general queries:0.
  Received MLDv1 specific queries:0.
  Received MLDv1 reports:0.
  Received MLD dones:0.
  Sent     MLDv1 specific queries:0.
  Received MLDv2 reports:0.
  Received MLDv2 reports with right and wrong records:0.
  Received MLDv2 specific queries:0.
  Received MLDv2 specific sg queries:0.
  Sent     MLDv2 specific queries:0.
  Sent     MLDv2 specific sg queries:0.
  Received error MLD messages:0.

 

Relevant parts of the config files:

; J8697A Configuration Editor; Created on release #K.15.06.0017
; Ver #02:10.0d:1f

hostname "SW5406-1"
time timezone 1
time daylight-time-rule Middle-Europe-and-Portugal
module 1 type J8702A
...
module 6 type J9309A
interface F3
   speed-duplex 10-full
exit
ip routing
ovlan 1
   name "DEFAULT_VLAN"
   untagged A1-A24,B5-B12,B15-B20,C1-C24,D1-D24,E1-E4,F1-F4
   ip address 192.168.100.1 255.255.255.0
   ipv6 address fda0:65da:e55a:1::feed:1/64
   ipv6 enable
   no untagged B1-B4,B13-B14,B21-B24
   ip igmp
   exit
vlan 10
...

dhcp-relay option 82 keep
powr-over-ethernet pre-std-detect
no telnet-server
ip timep manual 192.168.100.6
ip route 0.0.0.0 0.0.0.0 192.168.10.2
ipv6 unicast-routing
snmp-server community "public"
snmp-server contact "JB"
vlan 1
   ipv6 mld enable
   ipv6 nd ra reachable-time 1800000
   ipv6 nd ra other-config-flag
   ipv6 nd ra max-interval 20
   ipv6 nd ra min-interval 5
   exit
#
 version 5.20.99, Release 2222P01
#
 sysname SW5120-1
#
 clock timezone Amsterdam add 01:00:00
#
 irf mac-address persistent timer
 irf auto-update enable
 undo irf link-delay
#
 domain default enable system
#
 ipv6
#
 password-recovery enable
#
igmp-snooping
#
mld-snooping
#
vlan 1
 igmp-snooping enable
 mld-snooping enable
#
vlan 10
#
#
interface Vlan-interface1
 ipv6 address FDA0:65DA:E55A:1::FEED:2/64
 ipv6 address auto link-local
 ip address 192.168.100.5 255.255.255.0
#
 ip route-static 0.0.0.0 0.0.0.0 Vlan-interface1 192.168.100.1
#
 ipv6 route-static :: 0 Vlan-interface1 FE80::219:BBFF:FE0E:C600
#
return