LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

InterVLAN between two VLAN

 
Highlighted
Occasional Visitor

InterVLAN between two VLAN

Good Day all

 

I've been looking some way on how to make two VLAN able to communicate

 

Running configuration:

; J9850A Configuration Editor; Created on release #KB.16.02.0013
; Ver #0e:01.b3.ff.7c.5f.fc.7b.ff.ff.fc.ff.ff.3f.ef:cb
hostname "HP-5406Rzl2"
module A type one-06
module B type one-06
module C type j9534a
module E type j9537a
ip routing
snmp-server community "public" unrestricted
oobm
   ip address 192.168.168.1 255.255.255.0
   exit
vlan 1
   name "DEFAULT_VLAN"
   no untagged A1i-A2i,B1i-B2i,C1-C24,E1-E24
   untagged A3i,B3i
   no ip address
   exit
vlan 10
   name "VLAN10"
   untagged A1i,B1i,C7-C8,C13-C24,E1-E24
   ip address 172.16.10.1 255.255.254.0
   dhcp-server
   exit
vlan 11
   name "Vlan Teaming Controller"
   untagged A2i,B2i
   no ip address
   exit
vlan 134
   name "VLAN Guest"
   untagged C1-C2
   tagged A1i,B1i,C7-C24,E1-E24
   no ip address
   exit

vlan 300
   name "VLAN Admin"
   untagged C11-C12
   ip address 10.200.10.202 255.255.255.252
   exit

So VLAN134 is the vlan for guest network,  how can i able to communicate a device that is connected to vlan134, to be to ping vlan 300 with ip 10.200.10.202

i enabled the #ip routing already, but when trying to ping 10.200.10.202 i will get RTO

3 REPLIES 3
Highlighted
Honored Contributor

Re: InterVLAN between two VLAN

Since VLAN 134 hasn't an IP Address (I suspect you want it to have an IP Address of your Guests' subnet...not specified here) the IP Routing - even if it is enabled - isn't happening between that VLAN and the VLAN 300...so to let your Aruba 5406R zl2 to route between VLAN 134 and VLAN 300 you need to assign first an IP Address to VLAN 134. That's essential.

Highlighted
Occasional Visitor

Re: InterVLAN between two VLAN

yes, because VLAN134 is used only as a passthrough for the guest network, which is managed by another router.

So anything that is connected to the unttaged port in that VLAN (in this case, it's C1, and C2)  will receive ip address in this range 10.154.0.0/18 .

The question is, is that possible to make client on vlan 134 to be able to communicate to that VLAN 300?

Highlighted
Honored Contributor

Re: InterVLAN between two VLAN

Yes, provided that you instruct the router that owns the IP routing duty (and responsability) of VLAN 134 and vice-versa...and, generally, this happen by means of setting one static route to desired destination (VLAN 300 Network) on your Router via your Switch and one static route back (to VLAN 134 Network) on your Switch via your Router...this approach legitimates a network topology related question: is it correct - by design - for your network to have two devices performing IP routing instead of having only one (your Router OR your Switch)? if the answer is Yes then...if the router is directly connected to your Switch that means it owns an Address on VLAN 300 Subnet...the VLAN 134 definition - considered as a "passthrough" - shouldn't be necessary at all on the Switch...that's because that VLAN exists on the Router and should be reached through it by the Switch exactly as VLAN 300 should be reached through the Switch by the Router...each device which is doing IP Routing on your network topology routes VLAN interfaces (networks) it directly owns and must be instructed about how to reach remote ones owned by other routing device(s).