LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

InterVLAN routing issue with 5406ZL

Rich R_1
Advisor

InterVLAN routing issue with 5406ZL

I "inherited" a network and the core switch is a HP 5406ZL.  I am more familiar with Cisco, but have been going over the switch command PDF for the similarities.  

 

My situation:

 

I enabled IP Routing on the 5406, and created two VLANS 30 & 40.  VLAN 1 was already there.  Problem is that I can ping between VLAN 30 & 40, but cannot ping a PC on VLAN 1.  Though the PC's on VLAN 1 have the DG that is the router.  I added the default route on the switch, but still cannot ping any pc with that default gateway.  The switch itself can ping all pcs no matter which VLAN they are on.  I also setup static routes on the router and now the router can talk to pcs on VLANs 30&40.  

 

When I try to ping any pc on VLAN 1 (DG of router) from VLANs 30&40, I cannot do so, such as VLAN 40 (10.40.40.10 DG- 10.40.40.1) cannot ping pc (10.10.7.96 DG-10.10.7.10).

 

Setup:

; J8697A Configuration Editor; Created on release #K.12.57

hostname "5406zl Core-1" 
module 1 type J8702A 
module 2 type J8702A 
module 3 type J8706A 
module 4 type J8702A 
module 5 type J8702A 
interface A7 
   lacp Passive 
exit
interface A8 
   lacp Passive 
exit
interface B7 
   speed-duplex 100-full 
exit
interface B23 
   speed-duplex 100-full 
exit
trunk A9-A10 Trk1 LACP 
trunk A11-A12 Trk2 LACP 
interface D6 
   speed-duplex 100-full 
exit
ip routing 
snmp-server community "public" Unrestricted 
vlan 1 
   name "DEFAULT_VLAN" 
   untagged A1-A4,A6-A8,A13,A15-A24,B1-B24,C1-C24,D1-D24,E1-E24,Trk1-Trk2 
   ip address 10.10.8.1 255.255.240.0 
   no untagged A5,A14 
   exit 
vlan 30 
   name "DELL_DRAC_VLAN30" 
   untagged A14 
   ip address 10.11.11.1 255.255.255.0 
   exit 
vlan 40 
   name "VLAN40" 
   untagged A5 
   ip address 10.40.40.1 255.255.255.0 
   exit 
ip route 0.0.0.0 0.0.0.0 10.10.7.10
2 REPLIES
TMI
Occasional Contributor

Re: InterVLAN routing issue with 5406ZL

I'm in a similar boat as you, trying to get 17 VLANs talking to eachother.  The 5412 will ping any device plugged into it, devices can ping eachother if they're on the same VLAN, but you cannot ping cross VLAN.  Also, on the switch if you use "ping source 90 4.2.2.2" it won't work.

 

Hopefully someone knows a stupid easy fix that will help both of us.

AAPP Toledo
Frequent Advisor

Re: InterVLAN routing issue with 5406ZL

Hi,

 

What happend if In your VLAN1 change the "no untagged a5,a14" to "tagged a5,a14" ?

 

Greetings...

 

 no untagged A5,A14