LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Layer 3 switches and Vlans

byteflip
Occasional Visitor

Layer 3 switches and Vlans

Gents,

 

I’m currently setting up my first real lab with HP 1910-8 Layer 3 switches.  This will be a private system and completely off the internet.  With this said each switch will need to be able to send traffic between each switch.   Total of three switches.  I have attached my network diagram to help see what I am trying to accomplish.  Will this setup work if I use the STACK option?  Mind you I’m very new business class hardware.

Here is what my current config looks like on my Master switch.

 

#
 version 5.20.99, Release 1116
#
 sysname HPE
#
 domain default enable system 
#
 ipv6
#
 cluster enable 
 stack stack-port 1 port GigabitEthernet1/0/9
 stack stack-port 1 port GigabitEthernet1/0/10
#
 ssl version ssl3.0 disable
#
 password-recovery enable
#
vlan 1
 description Management
#
vlan 10
 description Master Site
#
vlan 20
 description Peer 1 Site
 #
vlan 30
 description Peer 2 Site
#
domain system 
 access-limit disable 
 state active 
 idle-cut disable 
 self-service-url disable 
#
user-group system
 group-attribute allow-guest
#
local-user admin
 authorization-attribute level 3
 service-type ssh telnet terminal
 service-type web
#
 stp mode rstp
 stp enable
#
interface NULL0
#
interface Vlan-interface1
 ip address dhcp-alloc
#
interface Vlan-interface10
 ip address 192.168.1.1 255.255.255.0 
#
interface Vlan-interface20
 ip address 192.168.2.1 255.255.255.0 
#
interface Vlan-interface30
 ip address 192.168.3.1 255.255.255.0 
#
interface Ethernet1/0/1
 port link-type hybrid
 port hybrid vlan 10 20 30 tagged
 port hybrid vlan 1 untagged
 port auto-power-down
 stp edged-port enable
 undo ntdp enable 
#
interface Ethernet1/0/2
 port link-type hybrid
 port hybrid vlan 10 20 30 tagged
 port hybrid vlan 1 untagged
 port auto-power-down
 stp edged-port enable
 undo ntdp enable 
#
interface Ethernet1/0/3
 port link-type hybrid
 port hybrid vlan 10 20 30 tagged
 port hybrid vlan 1 untagged
 port auto-power-down
 stp edged-port enable
 undo ntdp enable 
#
interface Ethernet1/0/4
 port link-type hybrid
 port hybrid vlan 10 20 30 tagged
 port hybrid vlan 1 untagged
 port auto-power-down
 stp edged-port enable
 undo ntdp enable 
#
interface Ethernet1/0/5
 port link-type hybrid
 port hybrid vlan 10 20 30 tagged
 port hybrid vlan 1 untagged
 port auto-power-down
 stp edged-port enable
 undo ntdp enable 
#
interface Ethernet1/0/6
 port link-type hybrid
 port hybrid vlan 10 20 30 tagged
 port hybrid vlan 1 untagged
 port auto-power-down
 stp edged-port enable
 undo ntdp enable 
#
interface Ethernet1/0/7
 port link-type hybrid
 port hybrid vlan 10 20 30 tagged
 port hybrid vlan 1 untagged
 port auto-power-down
 stp edged-port enable
 undo ntdp enable 
#
interface Ethernet1/0/8
 port link-type hybrid
 port hybrid vlan 10 20 30 tagged
 port hybrid vlan 1 untagged
 port auto-power-down
 stp edged-port enable
 undo ntdp enable 
#
interface GigabitEthernet1/0/9
 port link-type hybrid
 port hybrid vlan 10 20 30 tagged
 port hybrid vlan 1 untagged
 combo enable copper
 port auto-power-down
 stp edged-port enable
#
interface GigabitEthernet1/0/10
 port link-type hybrid
 port hybrid vlan 10 20 30 tagged
 port hybrid vlan 1 untagged
 combo enable copper
 port auto-power-down
 stp edged-port enable
#
 ip route-static 0.0.0.0 0.0.0.0 169.254.44.254 preference 10
#
 undo info-center logfile enable
#
 load xml-configuration 
#
user-interface aux 0
 authentication-mode scheme
user-interface vty 0 15
 authentication-mode scheme
#
return

 

1 REPLY
Vince-Whirlwind
Honored Contributor

Re: Layer 3 switches and Vlans

No, that doesn't really work.

To communicate with each other, each switch will need an IP address in the same subnet as the switch it connects to.

Do you really want all 3 switches doing routing? I wouldn't, I'd just pick one and put all the VLAN interfaces on it.
(Also, I never use 192.168. subnets. They look amateur. I use 10. subnets instead)

But assuming you do, you need 5 network segments:
1/ VLAN101 = 192.168.1.0/24 - Master Subnet
2/ VLAN102 = 192.168.120/24 - Peer1 Subnet
3/ VLAN103 = 192.168.1.0/24 - Peer2 Subnet
4/ VLAN92 = 192.168.92.0/24 - Master<---->Peer1 subnets link
5/ VLAN93 = 192.168.93.0/24 - Master<---->Peer2 subnets link

Master switch needs:
VLAN101, 192.168.1.11
VLAN92, 192.168.92.1 - Assign VLAN92 as a tagged port on port 9 and patch it to port 9 on Peer1 switch
VLAN93, 192.168.93.1 - Assign VLAN93 as a tagged port on port10 and patch it to port 10 on Peer2 switch

Peer1 switch needs:
VLAN102, 192.168.2.11
VLAN92, 192.168.92.2 - Assign VLAN92 as a tagged port on port 9

Peer2 switch needs:
VLAN103, 192.168.3.11
VLAN93, 192.168.93.2 -  Assign VLAN93 as a tagged port on port10