LAN Routing

MSR router no DHCP server

 
XATRIX
Occasional Visitor

MSR router no DHCP server

Hi, i'd like to ask you. I have a router, HP A-MSR20-20, and it has 2 ethernet ports (no other extension modules included). Actually i need to setup DHCP server on it. For the ethernet0/0 port. It's web interface configurator tries to setup a vlan1 and assign it a DHCP server. But it doesn't work. I mean, my clients doesn't aquire the IP addr.

I tried another way, i removed vlan1, and assigned my IPs, directly to eth0/0, and setup DHCP on this interface - still the same result.

This is my current config:

#
 version 5.20, Release 2207P41, Standard
#
 sysname HP
#
 domain default enable system 
#
 dns proxy enable 
#
 dar p2p signature-file cfa0:/p2p_default.mtd
#
 port-security enable 
#
 system-failure maintain
#
vlan 1
#
domain system 
 access-limit disable 
 state active 
 idle-cut disable 
 self-service-url disable 
#
dhcp server ip-pool vlan1 extended
 network ip range 192.168.137.20 192.168.137.232
 network mask 255.255.255.0
 gateway-list 192.168.137.1 
 dns-list 192.168.10.251 8.8.8.8 
#
user-group system
 group-attribute allow-guest
#
local-user admin
 password cipher xxxxxxxxxxxxxxxxx
 authorization-attribute level 3
 service-type telnet
 service-type web
#
cwmp
 undo cwmp enable
#
interface Aux0
 async mode flow
 link-protocol ppp
#
interface Cellular0/0
 async mode protocol
 link-protocol ppp
#
interface Ethernet0/0
 port link-mode route
 ip address 192.168.10.1 255.255.255.0 
 ip address 192.168.137.1 255.255.255.0 sub
 ip address 10.10.10.1 255.255.255.0 sub
 ip address 192.168.1.1 255.255.255.0 sub
 dhcp server apply ip-pool vlan1
#
interface Ethernet0/1
 port link-mode route
 nat outbound
 ip address xxx.xxx.xxx.xxx 255.255.255.252 
#
interface NULL0
#
interface Vlan-interface1
#
 ip route-static 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx permanent description ===WAN GW===
#
 dhcp enable 
#
 load xml-configuration 
#
 load tr069-configuration
#
user-interface con 0
user-interface tty 13
user-interface aux 0
user-interface vty 0 4
 authentication-mode scheme
#
return

I attached a photo of my router interfaces below

2 REPLIES 2
vbogatov
Occasional Visitor

Re: MSR router no DHCP server

Make sure you have enabled dhcp service by:

[Router] dhcp enable 

 

 

 

lorn10
Valued Contributor

Re: MSR router no DHCP server

I know this thread is old but I had the same issue. Here follows a solution which worked in my case perfectly.

 

The reason why the DHCP server was not active is because the DHCP server pool was not applied to the corresponding interface (or sub-interface). This can be done with the dhcp server apply ip-pool command.

 

In my case, it looked like this:

 

 

interface GigabitEthernet2/0
dhcp server apply ip-pool vlan1

 

 

The dhcp vlan1 server pool started working right after the execution of these two commands. Really absolutely trivial....