LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Multicast Routing on a 5406zl

adamf83
Occasional Visitor

Multicast Routing on a 5406zl

I'm trying to get multicast routing working on our core switch (a HP 5406zl) an struggling big time. We have a premium license for the switch and I think I have configured it all correctly but when I attempt to image machines using SCCM (which is all setup for multicast), I cannot image anything of a different VLAN to the server using multicast. If I connect a client to the same VLAN as the server I have no problems.

This is the config output from the switch:

; J8697A Configuration Editor; Created on release #K.15.03.0007

hostname "Core Switch"
module 1 type J8706A
module 2 type J8702A
module 3 type J8702A
module 4 type J9537A
interface A1
name "Server Trunk"
speed-duplex 1000-full
exit
interface A2
name "Server Trunk"
speed-duplex 1000-full
exit
interface A3
name "Server Trunk"
speed-duplex 1000-full
exit
interface A4
name "Orion (Grd)"
speed-duplex 1000-full
lacp Passive
exit
interface A5
speed-duplex 1000-full
exit
interface A6
name "Pho/Peg"
speed-duplex 1000-full
exit
interface A7
speed-duplex 1000-full
exit
interface A8
name "Science"
speed-duplex 1000-full
lacp Passive
exit
interface A9
speed-duplex 1000-full
lacp Passive
exit
interface A10
speed-duplex 1000-full
exit
interface A11
speed-duplex 1000-full
exit
interface A12
name "Aquila (Mez)"
speed-duplex 1000-full
exit
interface A13
name "IV Trunk"
speed-duplex 1000-full
exit
interface A14
name "IV Trunk"
speed-duplex 1000-full
lacp Passive
exit
interface A15
name "Mackay"
speed-duplex 1000-full
exit
interface A16
name "6th Form (Old)"
exit
interface A17
speed-duplex 1000-full
exit
interface A19
speed-duplex 1000-full
exit
interface A20
speed-duplex 1000-full
exit
interface A21
speed-duplex 1000-full
exit
interface A22
speed-duplex 1000-full
exit
interface B21
speed-duplex 100-full
exit
interface B23
speed-duplex 100-full
exit
interface C1
no power-over-ethernet
exit
interface C7
speed-duplex auto-1000
exit
interface D1
speed-duplex 1000-full
exit
interface D2
speed-duplex 1000-full
exit
interface D3
speed-duplex 1000-full
exit
interface D4
speed-duplex 1000-full
exit
interface D5
speed-duplex 1000-full
exit
interface D6
speed-duplex 1000-full
exit
trunk A1-A3 Trk1 Trunk
trunk A13 Trk3 Trunk
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged A24,C10,C22
ip helper-address 10.59.100.9
ip helper-address 10.59.100.10
no untagged A4-A12,A14-A23,B1-B24,C1-C9,C11-C21,C23-C24,D1-D24,Trk1,Trk3
no ip address
ip igmp
exit
vlan 10
name "SERVERS"
untagged B6,B8-B9,B11,B21,B23,C11-C12
ip helper-address 10.59.100.9
ip helper-address 10.59.100.10
ip address 10.59.100.6 255.255.255.192
tagged Trk1
ip proxy-arp
ip igmp
exit
vlan 20
name "COLLEGE VI"
untagged Trk3
ip helper-address 10.59.100.9
ip helper-address 10.59.100.10
ip address 10.59.101.1 255.255.255.0
ip proxy-arp
ip igmp
exit
vlan 60
name "LIB/MEZ/COLLEGE VI WIRELESS"
untagged A14,B15,C5
ip helper-address 10.59.100.9
ip helper-address 10.59.100.10
ip address 10.59.99.1 255.255.255.128
tagged A12,A16,A18
ip proxy-arp
ip igmp
exit
vlan 70
name "CPA(DT)"
untagged A19-A20
ip helper-address 10.59.100.9
ip helper-address 10.59.100.10
ip address 10.59.99.129 255.255.255.128
ip proxy-arp
ip igmp
exit
vlan 80
name "SCIENCE/MKAY"
untagged A8,A15
ip helper-address 10.59.100.9
ip helper-address 10.59.100.10
ip address 10.59.103.1 255.255.255.0
ip proxy-arp
ip igmp
exit
vlan 90
name "ORION"
untagged A4-A5,A22,B19,B22,C3,C6
ip helper-address 10.59.100.9
ip helper-address 10.59.100.10
ip address 10.59.102.1 255.255.255.0
tagged A16
ip proxy-arp
ip igmp
exit
vlan 100
name "AQUILA"
untagged A10,B1-B2,C7,C21
ip helper-address 10.59.100.9
ip helper-address 10.59.100.10
ip address 10.59.97.1 255.255.255.0
tagged A11-A12,A18
ip proxy-arp
ip igmp
exit
vlan 110
name "PHO/PEG"
untagged A6-A7,A9
ip helper-address 10.59.100.9
ip helper-address 10.59.100.10
ip address 10.59.98.1 255.255.255.128
ip proxy-arp
ip igmp
exit
vlan 130
name "PHO/PEG(2)"
untagged A17
ip helper-address 10.59.100.9
ip helper-address 10.59.100.10
ip address 10.59.98.129 255.255.255.128
ip proxy-arp
ip igmp
exit
vlan 200
name "ADMIN"
no ip address
ip proxy-arp
exit
vlan 140
name "CENTRAL"
untagged A21,A23,B3-B5,B7,B10,B12-B14,B16-B17,B20,B24,C2,C8-C9,C13-C16,C23-C24
ip helper-address 10.59.100.9
ip helper-address 10.59.100.10
ip address 10.59.96.1 255.255.255.0
tagged Trk1
ip proxy-arp
ip igmp
exit
vlan 500
name "CCTV"
forbid A8
untagged B18,C1,C4,C17-C20,D1-D24
ip address 172.16.1.1 255.255.255.0
tagged A11,A16
exit
no fault-finder bad-driver
no fault-finder bad-transceiver
no fault-finder bad-cable
no fault-finder too-long-cable
no fault-finder over-bandwidth
no fault-finder broadcast-storm
no fault-finder loss-of-link
no fault-finder duplex-mismatch-hdx
no fault-finder duplex-mismatch-fdx
no fault-finder link-flap
power-over-ethernet pre-std-detect
sntp server priority 1 10.59.100.7
no ip ssh
ip timep manual 10.59.100.7
ip route 0.0.0.0 0.0.0.0 10.59.100.1
ip route 10.62.0.0 255.255.255.0 10.62.0.1
ip multicast-routing
router rip
redistribute connected
exit
router pim
exit
interface C1
rate-limit all in percent 10
rate-limit all out percent 10
exit
snmp-server community "public" unrestricted
snmp-server community "spiceworks" operator
snmp-server host 10.59.100.51 community "public"
snmp-server host 10.59.100.23 community "public"
snmp-server host 10.59.100.47 community "spiceworks"
snmp-server host 10.59.100.28 community "public"
snmp-server contact "Adam Ed Jerry Reece" location "Comms Room"
spanning-tree Trk1 priority 4
spanning-tree Trk3 priority 4
vlan 10
ip rip 10.59.100.6
ip pim-dense
ip-addr any
exit
exit
vlan 20
ip rip 10.59.101.1
ip pim-dense
ip-addr any
exit
exit
vlan 60
ip rip 10.59.99.1
ip pim-dense
ip-addr any
exit
exit
vlan 70
ip rip 10.59.99.129
ip pim-dense
ip-addr any
exit
exit
vlan 80
ip rip 10.59.103.1
ip pim-dense
ip-addr any
exit
exit
vlan 90
ip rip 10.59.102.1
ip pim-dense
ip-addr any
exit
exit
vlan 100
ip rip 10.59.97.1
ip pim-dense
ip-addr any
exit
exit
vlan 110
ip rip 10.59.98.1
ip pim-dense
ip-addr any
exit
exit
vlan 130
ip rip 10.59.98.129
ip pim-dense
ip-addr any
exit
exit
vlan 140
ip rip 10.59.96.1
ip pim-dense
ip-addr any
exit
exit
password manager

The sevrer is joined to the servers VLAN and i've been trying to image clients in the AQUILA VLAN.

Can anybody see what might be wrong?

2 REPLIES
paulgear
Esteemed Contributor

Re: Multicast Routing on a 5406zl

Hi Adam,

 

It looks like no one has answered your query, so i thought i would find out how you're going.  I'm not a multicast expert, and i use multicast routing on my A5500, not my E5400, so my config will not be the same as yours.  But it looks like you've covered most things in your config.

 

What does the output of 'show ip igmp' show on your switch?  You also should have a 'show ip pim' and a 'show ip mroute' (at least that is how the show up on my 3400cl.  What do they report?

 

Regards,

Paul

 

Regards,
Paul
cenk sasmaztin
Honored Contributor

Re: Multicast Routing on a 5406zl

There are several problems with your settings

fristly

if you don't use rip routing unnecessary ip rip command in pim configuration

I have never seen switch config don't use ,do you use static routing and routing between vlan

 

secondly

you enable all on vlan pim configuration,unnecessary you must have only multicast vlan enable multicast routing.

 

my example configuration for pim (multicast routing)

Review and adapt on your system

 

ip routing
ip multicast-routing
exit
router pim
exit
vlan 13
ip pim-dense
ip-addr 10.10.13.254
exit
exit
vlan 14
ip pim-dense
ip-addr 10.10.14.254
exit
exit
vlan 15
ip pim-dense
ip-addr 10.10.15.254
exit
exit

 

good luck...

 

 

 

 

cenk