LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Multicast Routing

thobil
Occasional Visitor

Multicast Routing

Hi Guys

 

I have a 3800 Series as Layer 3 Router and a 2530 as Layer2 Accesswitch.

 

VLANS: 

501 IP TV Satellit Streamer Triax

532 IP TVs Samsung

 

The Triax Streamer just sends a UDP/RTP Stream. For each channel a multicast address e.g. bbc -> 224.0.0.2.

So unfortunately the layer 3 switch has no igmp groups created. The TV sends for each channel change a igmp leave and a igmp report for the new multicast IP.

 

Layer3 Switch config

ip routing
ip multicast-routing

router pim
    state-refresh 45
exit

vlan 501
    name "IP TV SRV Net"
    untagged 1,11-13,15
    tagged 23
    ip address 10.5.1.2 255.255.255.0
    ip igmp
    ip igmp blocked 14
    ip igmp forward 11
    ip pim-dense
        ip-addr any

        exit

    exit

vlan 532
    name "IP TV 3OG"
    untagged 9
    tagged 23
    ip address 10.5.32.1 255.255.255.0
    ip helper-address 10.5.11.17
    ip igmp
    ip pim-dense  
        ip-addr any
        exit
exit

 

Layer 2 Switch Konfig

vlan 532
name "IP TV 3OG"
untagged 1-34
tagged 47-52
no ip address
ip igmp
exit

 

Why is there no igmp group?

 

thba-sw02# show ip igmp vlan 501

IGMP Service Protocol Info

Total VLANs with IGMP enabled : 4
Current count of multicast groups joined : 6

IGMP Filter Unknown Multicast: Disabled
IGMP Filter Unknown Multicast Status: Disabled

VLAN ID : 501
VLAN Name : VLAN501
IGMP version : 2
Querier Address : 10.5.1.2
Querier Port : 48
Querier UpTime : 5h 10m 7s
Querier Expiration Time : 0h 2m 49s

Active Group Addresses Type Expires Ports Reports Queries
---------------------- ---------- --------------- ---------- ------- -------

 

 

Regards

Thomas

2 REPLIES
jerinst
Regular Visitor

Re: Multicast Routing

Hi,

You may need to reboot the layer 3 router once you enable router PIM,for the igmp groups to be shown.

Michael Patmon
Trusted Contributor

Re: Multicast Routing

224.0.0.2 (all routers on this subnet) is a reserved multicast address and will not be learned.  Try something like 239.1.1.1 and up.