LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem performing routing between VLAN

 
fabiommx
Occasional Advisor

Problem performing routing between VLAN

Hi, i need to perform interVLAN routing in order to allow devices in different VLAN to see each other.
Right now i've setup a RIP Router and use IP RIP V1-only in the VLAN than has to communicate but unfortunately the VLAN still won't communicate at all.

UPDATE: Configuration file is attached.


Devices on VLAN 1,3 and 11 needs to see each other and communicate, but right now i cannot ping/traceroute any of them from one VLAN to the other. 

8 REPLIES
16again
Respected Contributor

Re: Problem performing routing between VLAN

Devices on VLANs should just set their default gateway to L3 switchIP address in their subnet.
The switch has routes to all direct attached networks, so you won't need a routing protocol.

Never ever use RIP-v1.  It's classful only, so you can't advertise subnet masks.
172.16.x.x is ClassB address , having /16 mask so all your subnets fall are in the same in the same RIP advertisement.

fabiommx
Occasional Advisor

Re: Problem performing routing between VLAN

Changing subnet doesn't solve the problem unfortunately

In any case i can ping the gateway for each VLAN and still i cannot direct my traffic from one VLAN to another.

16again
Respected Contributor

Re: Problem performing routing between VLAN

There's no need to change the subnets. Just make sure that:
All clients in 172.16.1..0/24 network have set their gateway to 172.16.1.1
All clients in 172.16.3..0/24 network have set their  gateway to 172.16.3.1
All clients in 172.16.1.1.0/24 network have set their  gateway to 172.16.11.1

fabiommx
Occasional Advisor

Re: Problem performing routing between VLAN

The client gateway configuration is correct and I can ping the gateway without problem. I still cannot ping and access devices from one vlan to another.
16again
Respected Contributor

Re: Problem performing routing between VLAN

On the switch, what is the output of following commands?
show arp
show ip route
show ip

fabiommx
Occasional Advisor

Re: Problem performing routing between VLAN

I performed the command see attachments.

Thanks :)

16again
Respected Contributor

Re: Problem performing routing between VLAN

output shows:
IP routing is enabled, route table contains all connected networks.
As only 3 stations made it to the ARP table , I doubt stations use correct IP subnet or wrong gateway.

Try pinging/traceroute among those 3 stations, and make sure their firewall is turned off.

16again
Respected Contributor

Re: Problem performing routing between VLAN

Did you look at this topic:  Similar switch that needed firmware update to enable IP routing
http://community.hpe.com/t5/forums/replypage/board-id/lan-routing-forum/message-id/1508