LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

QOS Config question

 
SOLVED
Go to solution
Rich R_1
Advisor

QOS Config question

Setup:

  • HP E5412zl w/ K.15.08.0013
  • IP Routing Enabled
  • OSPF Enabled and working
  • Interface A1 is trunked
  • Connected to a layer 2 ENS network via Comcast

 

Since Comcast doesn't provide an IP like other MPLS networks, this creates a true layer 2 network for which I have to trunk port A1 if I wanted to allow tagged VLANS to come across from other sites.  My question should be if I wanted to enable VLAN QOS, should I use the IP Prescedence or Diff-Serv QOS?  I was thinking Diff-Serv, though when monitoring sflow with SolarWinds netflow analyzer, I'm not seeing traffic outbound on a different class base.  Such as I enabled video conferencing to use EF41 and a public wireless to use CS1 for low priority.  Though when monitoring this traffic, it is still being listed as CS0.  

 

Config:

hostname 
module 1 type j9534a
module 2 type j9536a
module 3 type j9534a
module 4 type j9534a
module 5 type j9547a
dhcp-snooping authorized-server
no dhcp-snooping option 82
dhcp-snooping vlan 50
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-hdx sensitivity high
fault-finder duplex-mismatch-fdx sensitivity high
fault-finder link-flap sensitivity high
trunk A1 trk1 trunk
banner motd "*****AUTHORIZED USE ONLY! THIS SESSION IS BEING MONITORED*****"
power-over-ethernet pre-std-detect
qos type-of-service diff-services
sflow 2 destination
sflow 2 polling Trk1 30
sflow 2 sampling Trk1 128
sflow 3 destination
sflow 3 polling A2-A24,B1-B22,C1-C24,D1-D24,E1-E24,Trk1 20
sflow 3 sampling A2-A24,B1-B22,C1-C24,D1-D24,E1-E24,Trk1 120
timesync sntp
sntp unicast
sntp 30
sntp server priority 1
sntp server priority 2
no telnet-server
time daylight-time-rule continental-us-and-canada
time timezone -300
no web-management
web-management ssl
ip dns server-address priority 1
ip dns server-address priority 2
ip route 0.0.0.0 0.0.0.0
ip router-id 13.13.13.13
ip routing
interface A1
name "Trunk 1 Uplink for Comcast ENS"
speed-duplex 100-full
exit

interface Trk1
dhcp-snooping trust
exit
spanning-tree Trk1 priority 4
vlan 1
name "DO NOT USE"
no untagged A2-A24,B1-B22,C1-C24,D1-D24,E1-E24,Trk1
no ip address
exit
vlan 6
name "OSPF"
tagged Trk1
ip address 10.10.100.13 255.255.255.0
ip igmp
ip ospf 10.10.100.13 area backbone
exit
vlan 30
name
untagged C16,C22,D17,D19
ip address 10.15.1.1 255.255.255.224
ip helper-address 10.10.34.37
ip igmp
ip ospf 10.15.1.1 passive
ip ospf 10.15.1.1 area 0.0.0.13
qos dscp 101110
exit
vlan 50
name
untagged A3-A24,B1-B22,C1-C15,C17-C21,C23-C24,D1-D2,D4-D8,D15-D16,D23-D24,E1-E24
ip address 10.10.17.1 255.255.255.0
ip helper-address 10.10.34.37
ip igmp
ip ospf 10.10.17.1 passive
ip ospf 10.10.17.1 area 0.0.0.13
qos dscp 100000
exit
vlan 51
name
untagged D9-D14,D18,D20-D22
ip address 10.15.1.129 255.255.255.224
ip ospf 10.15.1.129 area 0.0.0.13
qos dscp 000000
exit
vlan 120
name
untagged A2,D3
tagged Trk1
no ip address
ip igmp
qos dscp 001000
exit
fastboot
loop-protect trap loop-detected
loop-protect mode vlan
loop-protect vlan 30,50
no autorun
no dhcp config-file-update
no dhcp image-file-update
trunk-load-balance L4-based
password manager
password operator

 

2 REPLIES
Matcol
Frequent Advisor
Solution

Re: QOS Config question

When I had to do QoS through a provider's network, I found that:

a) DSCP worked, not IP Precedence

b) The provider had to be hounded to even *preserve* DSCP tags, let alone honour them.

Rich R_1
Advisor

Re: QOS Config question

Got the answer from Comcast.  Since we only have the "Basic" service we have to mark all packets as 0-1 via 802.1p.... We would have to go to a higher level of service to allow dscp tags to be kept.

 

1.4 CoS Identification and Marking. Customers must mark all packets using 802.1p CoS values as specified in Figure 3 to ensure the service will provide the intended CoS performance objectives specified in Figure 2.