LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

SAN Storage to SAN Storage - One Inter vlan layer 3 switch

Lucas00
Occasional Visitor

SAN Storage to SAN Storage - One Inter vlan layer 3 switch

Hello,

I am having issues doing inter VLANing between my two SAN devices through a single, Layer 3 HP switch. I am not too
familiar with HP my background is in Cisco, so I was hoping someone could tell me what I am missing. Here is the current
configuration in my Switch:

hostname "ProCurve 2910al-48G Switch"

ip routing
vlan 1
name "DEFAULT_VLAN"
untagged 1-4,15-24,26-30,36,43-48
ip address dhcp-bootp
no untagged 5-14,25,31-35,37-42
exit
vlan 200
name "SANA"
untagged 5-14,37-38
ip address 10.0.1.1 255.255.255.0
exit
vlan 400
name "VLAN400"
no ip address
exit
vlan 600
name "SANB"
untagged 25,31-35,39-42
ip address 10.1.1.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 10.0.0.1
ip route 0.0.0.0 0.0.0.0 10.1.0.1
snmp-server community "public" unrestricted
no autorun
password manager
password operator


SAN Set up

 

SANA                                                                                                             SANB
Mgmt1:10.0.0.40 /24 GW:10.0.0.1 <--Port 26 VLAN 1             Mgmt1:10.1.0.40 /24 GW:10.1.0.1 <--Port 28 VLAN1
Mgmt1:10.0.0.41 /24 GW:10.0.0.1 <--Port 27 VLAN 1             Mgmt1:10.1.0.41 /24 GW:10.1.0.1 <--Port 29 VLAN1

iSCSI A1: 10.0.1.10                                                                                  iSCSI A1: 10.1.1.10
iSCSI A1: 10.0.1.11                                                                                  iSCSI A1: 10.1.1.11
iSCSI A1: 10.0.1.12                                                                                  iSCSI A1: 10.1.1.12
iSCSI A1: 10.0.1.13                                                                                  iSCSI A1: 10.1.1.13
iSCSI A1: 10.0.1.14                                                                                  iSCSI A1: 10.1.1.14
iSCSI A1: 10.0.1.15                                                                                  iSCSI A1: 10.1.1.15
iSCSI A1: 10.0.1.16                                                                                  iSCSI A1: 10.1.1.16
iSCSI A1: 10.0.1.17                                                                                  iSCSI A1: 10.1.1.17


I am able to ping all the iSCSI interfaces from the switch, I am able to ping and login to SANA management, but I am not
able to ping or logon to the SANB management interface.

Thanks,

1 REPLY
Ian Vaughan
Honored Contributor

Re: SAN Storage to SAN Storage - One Inter vlan layer 3 switch

Howdy,

If your SANB Management interfaces are not in the correct IP address range for the address configured on the VLAN1 L3 interface. That's why you cannot ping them?

 

The switch IP in VLAN1 (currently determined by DHCP?) needs to be consistent with both sets of iP addresses on the SAN management interfaces if they are all to live hapily in the same VLAN (1). I would use a static address on that switch management IP. Preferably not on VLAN1.

 

I tend to stick to simple numbering if at all possible:

Stay off VLAN 1.

10.0.10.0/24 - SAN A - VLAN10

10.0.20.0/24 - SAN B - VLAN 20

10.0.99.0/24 - Management - VLAN 99

Or something like that

 

I would imagine that clients will be in yet another VLAN and will use MPIO to see all paths and do some form of load-balancing/ HA.

 

Do you have a second physical switch? I would be mindful of running everything through a SPOF.

 

HTH

Ian

Hope that helps - please click "Thumbs up" for Kudos if it does
## ---------------------------------------------------------------------------##
Which is the only cheese that is made backwards?
Edam!
Tweets: @2techie4me