LAN Routing
1748054 Members
4978 Online
108758 Solutions
New Discussion юеВ

Switch L3 HP 5120 - How commad for 1 port can access all VLAN

 
Anton09
Occasional Visitor

Switch L3 HP 5120 - How commad for 1 port can access all VLAN

I have 3 VLAN interface > 20, 30, 40.

I want to port 23 can access to all vlan interface. could you suggest me?

Below my current config:

#
version 5.20, Release 1513P62
#
sysname IJWP-L3
#
clock timezone Bangkok add 07:00:00
#
super password level 3 cipher $c$3$N+/AMwFnf7bj58RGdrqYHTwul1N3j00CJrcIBQY=
#
dhcp relay server-group 1 ip 192.168.30.1
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
#
domain default enable system
#
telnet server enable
#
password-recovery enable
#
acl number 3001 name ACL-GUEST
rule 0 permit ip destination 192.168.40.14 0
rule 5 permit ip destination 192.168.40.15 0
rule 10 permit ip destination 192.168.40.19 0
rule 15 deny ip destination 192.168.20.0 0.0.0.255
rule 20 deny ip destination 192.168.30.0 0.0.0.255
rule 25 deny ip destination 192.168.40.0 0.0.0.255
rule 30 permit ip
#
vlan 1
#
vlan 10
name TO-FIREWALL
#
vlan 20
name USER-LAN
#
vlan 30
name SERVER-LAN
#
vlan 40
name CCTV
#
vlan 50
name WAN-ACCESS
#
vlan 60
name VLAN-GUEST
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
dhcp server ip-pool cctv
network 192.168.40.0 mask 255.255.255.0
gateway-list 192.168.40.254
#
user-group system
#
local-user admin
password cipher $c$3$8ZwWMBv1UaDdzq9/6+WfiQ0F+Sb56uGd3Ufpg2c=
authorization-attribute level 3
service-type telnet terminal
service-type web
local-user ijwpadmin
password cipher $c$3$LKo0pQMaGiuhAoXw7AdWCO8gTPhhRQstDl1XKOs=
authorization-attribute level 3
service-type telnet
service-type web
#
cwmp
undo cwmp enable
#
interface NULL0
#
interface Vlan-interface10
ip address 192.168.100.4 255.255.255.0
#
interface Vlan-interface20
ip address 192.168.20.254 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface30
ip address 192.168.30.254 255.255.255.0
#
interface Vlan-interface40
ip address 192.168.40.254 255.255.255.0
#
interface Vlan-interface60
ip address 192.168.60.254 255.255.255.0
packet-filter 3001 inbound
#
interface GigabitEthernet1/0/1
description *FW1 to LAN*
port access vlan 10
#
interface GigabitEthernet1/0/2
description *FW2 to LAN*
port access vlan 10
#
interface GigabitEthernet1/0/3
description *Trunk to IJWP-L2-PoE-1*
port link-type trunk
port trunk permit vlan 1 10 20 30 40
#
interface GigabitEthernet1/0/4
description *Trunk to IJWP-L2-PoE-2*
port link-type trunk
port trunk permit vlan 1 10 20 30 40
#
interface GigabitEthernet1/0/5
description *NVR CCTV*
port access vlan 40
#
interface GigabitEthernet1/0/6
description *WAN ISP*
port access vlan 50
#
interface GigabitEthernet1/0/7
description *WAN to FW1*
port access vlan 50
#
interface GigabitEthernet1/0/8
description *WAN to FW2*
port access vlan 50
#
interface GigabitEthernet1/0/9
description *to IJWP-SVR1-port1*
port access vlan 30
#
interface GigabitEthernet1/0/10
description *to IJWP-SVR1port2*
port access vlan 30
#
interface GigabitEthernet1/0/11
port access vlan 20
#
interface GigabitEthernet1/0/12
port access vlan 20
#
interface GigabitEthernet1/0/13
port access vlan 20
#
interface GigabitEthernet1/0/14
port access vlan 20
#
interface GigabitEthernet1/0/15
port access vlan 20
#
interface GigabitEthernet1/0/16
port access vlan 20
#
interface GigabitEthernet1/0/17
port access vlan 20
#
interface GigabitEthernet1/0/18
port access vlan 20
#
interface GigabitEthernet1/0/19
port access vlan 20
#
interface GigabitEthernet1/0/20
port access vlan 20
#
interface GigabitEthernet1/0/21
port access vlan 20
#
interface GigabitEthernet1/0/22
port access vlan 20
#
interface GigabitEthernet1/0/23
port access vlan 20
#
interface GigabitEthernet1/0/24
port access vlan 20
#
interface GigabitEthernet1/0/25
port access vlan 20
#
interface GigabitEthernet1/0/26
port access vlan 20
#
interface GigabitEthernet1/0/27
port access vlan 20
#
interface GigabitEthernet1/0/28
port access vlan 20
#
interface GigabitEthernet1/0/29
port access vlan 20
#
interface GigabitEthernet1/0/30
port access vlan 20
#
interface GigabitEthernet1/0/31
port access vlan 20
#
interface GigabitEthernet1/0/32
description ***FO-to-AP-FACTORY-2***
port access vlan 20
#
interface GigabitEthernet1/0/33
description ***Production Server***
port access vlan 30
#
interface GigabitEthernet1/0/34
description ***Production Server#2***
port access vlan 30
#
interface GigabitEthernet1/0/35
description ***FO-to-AP-FACTORY1***
port access vlan 20
#
interface GigabitEthernet1/0/36
description ***FO-to-AP-FACTORY3***
port access vlan 20
#
interface GigabitEthernet1/0/37
description *Trunk to IJWP-L3-PoE-3*
port link-type trunk
port trunk permit vlan 1 10 20 30 40
#
interface GigabitEthernet1/0/38
description *Guest for BeaCukai*
port access vlan 20
#
interface GigabitEthernet1/0/39
port access vlan 20
#
interface GigabitEthernet1/0/40
port access vlan 20
#
interface GigabitEthernet1/0/41
#
interface GigabitEthernet1/0/42
#
interface GigabitEthernet1/0/43
#
interface GigabitEthernet1/0/44
#
interface GigabitEthernet1/0/45
#
interface GigabitEthernet1/0/46
#
interface GigabitEthernet1/0/47
#
interface GigabitEthernet1/0/48
#
interface GigabitEthernet1/0/49
#
interface GigabitEthernet1/0/50
#
interface GigabitEthernet1/0/51
#
interface GigabitEthernet1/0/52
#
ip route-static 0.0.0.0 0.0.0.0 192.168.100.2 description to internet temporary
#
dhcp enable
#
ntp-service unicast-server 203.34.118.4
ntp-service unicast-server 180.211.88.50
#
load tr069-configuration
#
user-interface aux 0
user-interface vty 0
set authentication password cipher $c$3$6Js6dX/CDeIKKy2QgGgQndh9WZQwEom7tq66w+U=
user-interface vty 1 15
#
return

4 REPLIES 4
HP-Browniee
Respected Contributor

Re: Switch L3 HP 5120 - How commad for 1 port can access all VLAN

Hello

You can take the same config as your port 1/0/4, so for port 23 it should be:

interface GigabitEthernet1/0/23
port link-type trunk
port trunk permit vlan 20 30 40

kind regards

Anton09
Occasional Visitor

Re: Switch L3 HP 5120 - How commad for 1 port can access all VLAN

Thank you HP-Brwniee,

I already tried changed to type trunk and permit vlan 20,30,40

But all connection is loss.

In under L3 switch is switch hub unmanage. below rute ;

L3 port 23--> unmanage switch HUB --> client (VLAN20), cctv (vlan40)

current config only access to VLAN20. I want to in this port can acces client and cctv.

Please your helps,

Regards,

Anton

 

 

HP-Browniee
Respected Contributor

Re: Switch L3 HP 5120 - How commad for 1 port can access all VLAN

Hello

Try to change the pvid of port 23 to vlan 20.

interface GigabitEthernet1/0/23
port link-type trunk
port trunk permit vlan 20 30 40
port trunk pvid vlan 20

Kind regards

Rob_Korn
Advisor

Re: Switch L3 HP 5120 - How commad for 1 port can access all VLAN

I don't believe a "hub" as described by the OP would ever understand a "trunk" port.

Hubs do not know how to process a Vlan Tag.

You will have to find another way to connect, if there is a "switch" instead of the "hub", and if you have devices that are "VLAN aware", then you would be setup.

Client (vlan aware, tagged vlan 20)  ---------------------|

CCTV (vlan aware, tagged vlan 30(or whatever))  -----| SWITCH (not hub) - PORT 23 AS described.

The issue is that no manner of Vlan config on the HP switch will be understood by a simple old HUB.  (people still use a HUB?)

Good luck.