LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Trunking HPE 1920s to Cisco 2960 S

 
SOLVED
Go to solution
Highlighted
Frequent Advisor

Trunking HPE 1920s to Cisco 2960 S

Hello,

I'd like to make two ports trunk between a HPE 1920S and a Cisco 2960s.

What should I configure on both switches? I've just created a trunk in 1920s for ports 39 and 40, and in the cisco I've created an inteface port channel with mode access:

interface Port-channel3
switchport trunk allowed vlan 1
switchport mode trunk
!

and ports 23 and 24 are configured as follows:

interface GigabitEthernet0/23
switchport trunk allowed vlan 1
channel-group 3 mode active
!
interface GigabitEthernet0/24
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 3 mode active
!

The cisco is configured with vlan 1 and 2. I only need to allow traffic from vlan 1 between bot switches. The HP has only vlan 1, the default.

Is it correct?

Regards,

Senior Systems Administrator
8 REPLIES 8
Highlighted
Honored Contributor

Re: Trunking 1920s to Cisco 2960 S

Hi,

The Cisco side looks good to me (considering that the switchporttrunk native vlan 1 statement shouldn't be necessary as it is already valid as default):

interface Port-channel 3
switchport trunk native vlan 1
switchport trunk allowed vlan 1
switchport mode trunk
interface GigabitEthernet 0/23
switchport trunk allowed vlan 1
channel-group 3 mode active
interface GigabitEthernet 0/24
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 3 mode active

 How the HPE OfficeConnect 1920S is configured with regard to necessary LAG (Links Aggregation Group = Trunk in Web GUI)? is the LACP enabled on the links aggregation (Static disabled)?

Highlighted
Frequent Advisor

Re: Trunking 1920s to Cisco 2960 S

1920s_Trunk.jpg

Senior Systems Administrator
Highlighted
Honored Contributor

Re: Trunking 1920s to Cisco 2960 S

That Static Mode Enabled looks the culprit (it should be Static Mode = Disabled = use LACP IEEE 802.3ad)...then you should check that Load Balancing algorithm uses Source/Destination IP Addresses (Layer 3) to calculate hash for egress traffic balancing across aggregated pots...

Highlighted
Frequent Advisor

Re: Trunking 1920s to Cisco 2960 S

Hello,

Sorry to disturb you, but I've realised that on Cisco, there is a little difference among ports 23 and 24. Port 24 has switchport mode trunk enabled, but port 23 not:

interface GigabitEthernet0/23
switchport trunk allowed vlan 1
channel-group 3 mode active
!
interface GigabitEthernet0/24
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 3 mode active
!

After setting "static disabled" on HP trunk, I've connected both cables, but only 1 is active:

2910_Active.jpg

 

 

Senior Systems Administrator
Highlighted
Honored Contributor

Re: Trunking 1920s to Cisco 2960 S

Hi, I think that "Port 24 has switchport mode trunk enabled, but port 23 not" should be fixed: both involved ports must have the very same configuration...that's a golden rule valid on both peers (HPE/Aruba and Cisco).

Highlighted
Frequent Advisor

Re: Trunking 1920s to Cisco 2960 S

Hi,

¿and what would be the best, "switchport mode trunk"  enable or not, like in port 23?

Regards,

Senior Systems Administrator
Highlighted
Honored Contributor
Solution

Re: Trunking 1920s to Cisco 2960 S

Wait...with regard to Port-Channel 3 and ports 23 and 24 do a reconfiguration on the Cisco side from scratch (default): first physical ports, then the logical (Port Channel) one...setting on Port Channel should propagate down to its member ports (23 and 24)...the order used to configure is important.

Before touching Cisco configuration check cabling: is the actual physical connection made this way?

HPE 1920S port 39 <---cable---> Port 23 Cisco 2960

HPE 1920S port 40 <---cable---> Port 24 Cisco 2960

or that way?

HPE 1920S port 39 <---cable---> Port 24 Cisco 2960

HPE 1920S port 40 <---cable---> Port 23 Cisco 2960

Given that HPE 1920S port 39 is the only one actually "Up" of the LAG to the Cisco 2960...if the former connection schema is the one you really used it means that port 23's configuration on Cisco is OK (so 24 is incorrect -> fix it to cope with port 23's configuration), if the latter connection schema is the one you actually used it means that port 24's configuration on Cisco is OK (so 23 is incorrect -> fix it to cope with port 24's configuration).

Highlighted
Frequent Advisor

Re: Trunking 1920s to Cisco 2960 S

Hello parnassus,

Solved, you've been, as always, very hepfull.

Regards,

Senior Systems Administrator