LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Using Procurve 2848 as a router also...

Svavaroe
Occasional Contributor

Using Procurve 2848 as a router also...

Hello.

I have a spare 2848 Procurve switch that I need to configure into my network.
The question is that I need also to replace my old-pc running linux and Zebra(Quagga) wich
is acting as a router to my fiber connection to my ISP.

I have limited knowledge on routing configurations in procurve, but can I replace my PC machine
and configure the Procurve to act as a router too ?

I have plotted a diagram of my current network setup hera as a attachment.
Hopefully someone understands me :)

Any help would be much appriaciated.

Best regards,

Svavar - Reykjavik - Iceland


Here's my current configuration in Quagga(Zebra daemon).

interface Ethernet0
# Interface connected to Fiber-Ethernet Transciver (ISP)
ip address 213.2xx.xxx.58 255.255.255.252
no ip mroute-cache
full-duplex
no cdp enable
!
interface FastEthernet0
# Interface connected to our public network.
ip address 62.1xx.xxx.97 255.255.255.224
ip verify unicast reverse-path
no ip mroute-cache
speed 100
full-duplex
no cdp enable
!
ip default-gateway 213.2xx.xxx.57
ip classless
ip route 0.0.0.0 0.0.0.0 213.2xx.xxx.57
no ip http server
ip pim bidir-enable

2 REPLIES
RK_br
Advisor

Re: Using Procurve 2848 as a router also...

Hello Svavar,

 

Yes, you should be able to configure IP routing without a problem on a 2848. Please note that as far as I know, it only supports static routing and is not an ideal router for complex situations, but if your network is simple it will do the trick.

 

You would have to configure separate VLANs and give those IP addresses (don't use VLAN 1 as that is the default for all ports)

 

ex.

vlan 10

ip address 213.2xx.xxx.58 255.255.255.252

untagged Y (where Y is your port to the ISP)

 

vlan 20

ip address 62.1xx.xxx.97 255.255.255.224

untagged Z (where z is your public network port)

 

ip routing

ip route 0.0.0.0 0.0.0.0 213.2xx.xxx.57 (this sets your default gateway)

 

Now, all you other ports are in VLAN 1 by default. If you want those to be routed, you have to give VLAN 1 an IP address and make sure you have static routes to other networks you might have out there, specially since you are using short masks.

 

ex. if network 50.x.x.x is on your public port

ip route 50.x.x.x 255.0.0.0 62.1xx.xxx.98

 

best of luck,

RK

Svavaroe
Occasional Contributor

Re: Using Procurve 2848 as a router also...

Thanks so much. Will try. :)