cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN ISSUES

liech
Occasional Visitor

VLAN ISSUES

Hi All,

I'm having some issues with inteervlan communication, any assistance will be welcome;

hostname "SWT-CORE"
module 1 type j9726a
ip default-gateway 172.168.1.210
ip route 0.0.0.0 0.0.0.0 172.168.1.210
ip route 192.168.100.0 255.255.255.0 vlan 30
ip routing
interface 23
flow-control
name "RouterConnection"
exit
snmp-server community "public" unrestricted
oobm
ip address dhcp-bootp
exit
vlan 1
name "DEFAULT_VLAN"
no untagged 1-19,23

ip address 192.168.200.1 255.255.255.0
exit
vlan 10
name "Data"
untagged 1-9,23
ip address 172.168.1.254 255.255.255.0
exit
vlan 30
name "Voice"
untagged 10-19
ip address 192.168.100.254 255.255.255.0
ip helper-address 172.168.1.1
exit
vlan 90
name "Common Services"
ip address 172.16.1.254 255.255.255.0
exit
spanning-tree
spanning-tree mode rapid-pvst
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager

 

sh ip route

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
0.0.0.0/0 172.168.1.210 10 static 1 1
127.0.0.0/8 reject static 0 0
127.0.0.1/32 lo0 connected 1 0
172.168.1.0/24 10 connected 1 0

1 REPLY
16again
Respected Contributor

Re: VLAN ISSUES

What's the issue?
For direct attached networks, you won't need routes like this one:
ip route 192.168.100.0 255.255.255.0 vlan 30

Is the  "sh ip route output" complete? It misses some local attached networks.  Are associated VLAN interfaces up?