LAN Routing
1752301 Members
4910 Online
108786 Solutions
New Discussion

Re: VLAN Routing Issue 5412zl

 
SOLVED
Go to solution
TMI
Occasional Contributor

VLAN Routing Issue 5412zl

I've read that I should be able to assign IPs to VLANs, enable ip routing set up a 0.0.0.0/0 route, and the switch should automagically route for devices that use the switch as the default gateway.

 

Configuration below:

 

Running configuration:

; J8698A Configuration Editor; Created on release #K.15.05.0002
; Ver #01:01:00

hostname "TMI-SW1"

module 1 type J9534A
module 2 type J9535A
module 3 type J9534A
module 4 type J9535A
module 5 type J9534A
trunk B19-B20 Trk1 LACP
ip routing
ip directed-broadcast
vlan 1
   name "Network_VLAN"
   untagged A1,A8,A19-A24,B1-B18,B21-B24,C1-C24,D1-D24
   qos priority 7
   ip address 10.16.0.1 255.255.255.0
   tagged Trk1
   no untagged A2-A7,A9-A18,E1-E24
   jumbo
   exit
vlan 20
   name "Server_VLAN"
   untagged A2
   qos priority 6
   ip address 10.20.0.1 255.255.255.0
   tagged Trk1
   jumbo
   exit
vlan 30
   name "Storage_VLAN"
   untagged A3
   qos priority 6
   ip address 10.20.8.1 255.255.255.0
   tagged Trk1
   jumbo
   exit
vlan 40
   name "Printers_VLAN"
   untagged A4
   qos priority 1
   ip address 10.20.12.1 255.255.255.0
   tagged A1-A3,A5-A24,B1-B18,B21-B24,C1-C24,D1-D24,E1-E24,Trk1
   exit
vlan 50
   name "Tech_VLAN"
   untagged A5
   qos priority 6
   ip address 10.20.16.1 255.255.255.0
   tagged Trk1
   exit
vlan 70
   name "Facilities_VLAN"
   untagged A6
   qos priority 5
   ip address 10.20.32.1 255.255.255.0
   tagged Trk1
   exit
vlan 80
   name "Security_VLAN"
   untagged A7
   qos priority 5
   ip address 10.20.48.1 255.255.255.0
   tagged Trk1
   exit
vlan 90
   name "Phone_VLAN"
   qos priority 7
   ip helper-address 172.20.0.18
   ip address 10.20.192.1 255.255.255.0
   tagged A1-A24,B1-B18,B21-B24,C1-C24,D1-D24,E1-E24,Trk1
   voice
   exit
vlan 200
   name "BO_VLAN"
   untagged A9
   qos priority 3
   ip address 10.21.8.1 255.255.255.0
   tagged Trk1
   exit
vlan 250
   name "Employee_VLAN"
   untagged A10
   qos priority 2
   ip address 10.21.16.1 255.255.255.0
   tagged Trk1
   exit
vlan 300
   name "Student_VLAN"
   untagged A11
   qos priority 1
   ip address 10.21.24.1 255.255.255.0
   tagged Trk1
   exit
vlan 400
   name "WLAN_Emp_VLAN"
   untagged A12
   qos priority 2
   ip address 10.24.8.1 255.255.255.0
   tagged Trk1
   exit
vlan 450
   name "WLAN_Stud_VLAN"
   untagged A13
   qos priority 1
   ip address 10.24.16.1 255.255.255.0
   tagged Trk1
   exit
vlan 500
   name "WLAN_Guest_VLAN"
   untagged A14
   qos priority 1
   ip address 10.30.128.1 255.255.255.0
   tagged Trk1
   exit
vlan 800
   name "WAN1_VLAN"
   untagged A15
   qos priority 4
   tagged Trk1
   no ip address
   exit
vlan 810
   name "WAN2_VLAN"
   untagged A16
   qos priority 4
   tagged Trk1
   no ip address
   exit
vlan 900
   name "Unknown_VLAN"
   untagged A17
   qos priority 1
   tagged Trk1
   no ip address
   exit
vlan 999
   name "Legacy_VLAN"
   untagged A18,E1-E24
   qos priority 5
   ip address 172.20.96.30 255.255.255.0
   tagged Trk1
   exit

qos type-of-service diff-services
no telnet-server

ip route 0.0.0.0 0.0.0.0 172.20.96.1

ip multicast-routing
router rip
   redistribute connected
   enable
   exit
no core-dump interfaces
snmp-server community "[REDACTED]" unrestricted
snmp-server community "[REDACTED]" operator unrestricted
snmp-server contact "[REDACTED]" location "MDF"
spanning-tree
spanning-tree Trk1 priority 4

primary-vlan 999
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager
password operator

 

3 REPLIES 3
TMI
Occasional Contributor

Re: VLAN Routing Issue 5412zl

I forgot to mention, right now I just want to be able to communicated between VLANs, and once I get that hurdle down, I will worry about ACLs and all that.

TMI
Occasional Contributor
Solution

Re: VLAN Routing Issue 5412zl

Disregard this post. I'm an idiot.

My solution, in the hopes that it helps other people:

I forgot to add the switch as a gateway to the new IP range and since I forgot to do that, the switch would send data out and then it would get lost in the aether.

Always double check your routing tables on all routers/switches to make sure your new ranges are accounted for.
switchstacking
Occasional Contributor

Re: VLAN Routing Issue 5412zl

Hi ,

 i have seen your post and i think you have some good idea about this vlan setup. I am pretty new to this concept so please  forgive my mistakes.  My issue is with DHCP . that the devices connected to my switch cannot get ip from the dhcp.  i can ping the dhcp from the switch.  there is 2 switches . configuration is pasted below have a look at this and help me with some advices please .

 

 

 

SWITCH1(rip)# show run

Running configuration:

; J9147A Configuration Editor; Created on release #W.14.38

hostname "SWITCH1"
time daylight-time-rule Western-Europe
module 1 type J9147A
module 3 type J9165A
stack commander "01"
stack auto-grab
stack member 1 mac-address 68B5991F1D40
stack member 2 mac-address C09134CDE580
ip routing
vlan 1
   name "DEFAULT_VLAN"
   untagged 3-32,34-46,B1
   ip address dhcp-bootp
   no untagged 1-2,33,47-48
   exit
vlan 2
   name "CAR1F-a"
   untagged 1
   ip helper-address 192.168.14.2
   ip address 10.4.2.1 255.255.255.0
   exit
vlan 4
   name "CAR1F-b"
   untagged 2,33
   ip helper-address 192.168.14.2
   ip address 10.4.4.1 255.255.255.0
   exit
vlan 8
   name "CAR1F-c"
   ip helper-address 192.168.14.2
   ip address 10.4.8.1 255.255.255.0
   exit
vlan 16
   name "CAR1F-d"
   ip helper-address 192.168.14.2
   ip address 10.4.16.1 255.255.255.0
   exit
vlan 20
   name "CAR1F-e"
   ip helper-address 192.168.14.2
   ip address 10.4.20.1 255.255.255.0
   exit
vlan 22
   name "CR1F-f"
   ip helper-address 192.168.14.2
   ip address 10.4.22.1 255.255.255.0
   exit
vlan 23
   name "CAR1F-g"
   ip helper-address 192.168.14.2
   ip address 10.4.23.1 255.255.255.0
   exit
vlan 25
   name "CAR1F-h"
   ip helper-address 192.168.14.2
   ip address 10.4.25.1 255.255.255.0
   exit
vlan 31
   name "CARGF-i"
   ip helper-address 192.168.14.2
   ip address 10.4.34.1 255.255.255.0
   exit
vlan 99
   name "VLAN99"
   untagged 48
   ip address 192.168.14.199 255.255.255.0
   exit
vlan 6
   name "VLAN6"
   ip helper-address 192.168.14.2
   no ip address
   exit
vlan 100
   name "VLAN100"
   untagged 47
   ip address 10.4.100.2 255.255.255.0
   exit
banner motd "AUTHORISED PERSONAL ONLY "
router rip
   exit
snmp-server community "public" unrestricted
snmp-server location "London"
spanning-tree
vlan 100
   ip rip 10.4.100.2
   exit

 

thanks.