LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN routing v2920 Level 3 switch

 
JBrkan
Collector

VLAN routing v2920 Level 3 switch

I am having a problem with the following network setup;

  • One Level 3 switch (V290-SPF):

           -IP (Default VLAN 1) 192.168.1.2
           -VLAN 2 (interface 2), IP 192.168.2.2 Physically connected on port 3 with L2 switch)
            -Routing:

Destination IP address       Mask                             Protocol     Preference      NextHop             Interface

127.0.0.0                              255.0.0.0                        Direct               0                   127.0.0.1            InLoopback0

127.0.0.1                              255.255.255.255          Direct               0                   127.0.0.1            InLoopback0
192.168.1.0                         255.255.255.0               Direct               0                   192.168.1.2       VlanInterface1
192.168.1.2                         255.255.255.255          Direct               0                   127.0.0.1            InLoopback0

192.168.2.0                         255.255.255.0               Static             60                 192.168.2.3         VlanInterface2

 

The last line was manually added, it does not show up in the routing table but only under the create tab in the IPv4 menu (webbased)


  • One Level 2 switch (HP procurve 1810G):

       -IP 192.168.2.3 gateway 192.168.2.2 (physically connected on port 3 with L3 switch)

 

  • Computer 1

        -IP: 192.168.1.30 mask 255.255.255.0  gateway 192.168.1.2
          physically connected to L3 switch on port 1

 

  • Computer 2

       -IP: 192.168.2.60  mask 255.255.255.0 gateway 192.168.2.3

       physically connected to L2 switch on port 1

 

The weird thing is that when i change the ip of computer 1 to 192.168.2.30 and the gateway to 192.168.2.3, I am able to ping the L2 switch and even login to it. This is not possible visa versa with computer 2 (IP 192.168.1.60 and gateway 192.168.1.2)

What I am trying to accomplish is that both computers are located in different VLANs in a different subnet (192.168.1.0 and 192.168.2.0) where they are able to ping one another as so the switches.
I do not have a lot of experience with these devices/routing. If some one could help me with this issue I would greatly appreciate it.

Thank you in advance