HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

VSF 2930F Problem

 
SOLVED
Go to solution
Laamouri
Occasional Contributor

VSF 2930F Problem

I want to build a stack of 4 switch 2930F.
I configured the 4 switches as follows:
Switch 1:
vsf
    enable domain 10
    member 1
       type "JL261A" mac-address b05ada-964d40
       priority 255
       link 1 1/25
       link 1 name "I-Link1_1"
       link 2 1/26
       link 2 name "I-Link1_2"
       exit
    port-speed 10g

Switch 2 :

vsf
    enable domain 10
    member 2
       type "JL261A" mac-address b05ada-966f20
       priority 200
       link 1 2/25
       link 1 name "I-Link2_1"
       link 2 2/26
       link 2 name "I-Link2_2"
       exit
    port-speed 10g
    exit

the port doesn't working they are always in error.

Aruba-VSF-2930F# sh vsf link detail

VSF Member: 1 Link: 1

Port State
-------- ------------
1/25 Error: Selftest failure


VSF Member: 1 Link: 2

Port State
-------- ------------
1/26 Error: Selftest failure

Does anyone also encounterd this problem and knows how to fix this ?

 

4 REPLIES
parnassus
Honored Contributor
Solution

Re: VSF 2930F Problem

Since you didn't provide a full view of your scenario (sanitized config file and VSF topology) here I'm guessing what you're trying to achieve. So few questions to clarify better what's going on:

Can you show us the details about interfaces 25 and 26, respectively on both mentioned VSF Member 1 and Member 2 switches (output of show interfaces 25-26 command)?

Are you using genuine and supported HP SFP Transceivers to deploy VSF using 1G links [*]?

If so...can you please provide us SFP Transceivers info (via show tech transceivers command and/or via show interfaces transceiver 1/25 plus show interfaces transceiver 1/26 about Member 1 and repeating the same command with 2/25 and 2/26 about Member 2)?

Are you trying to manually setup a VSF Ring Topology (I see that VSF Link 1 and Link 2 are used to create a ring/loop between all four members [**] but only VSF Member 1 and 2 seem to have SFP Transceivers related issues)?

So...what show vsf topology and show vsf link detail commands report (all four members)?

[*] Interfaces 25 and 26 should be both SFP slots on JL261A Switch model.

[**] You know that is not mandatory to respect the Link 1 (on Member 1) to Link 1 (on Member 2) matching...you can manually deploy VSF links also by doing Link 1 (on Member 1) to Link 2 (on Member 2) and so on...closing the loop of your Ring Topology with Link 1 (on Member 4) to Link 2 (on Member 1)...in other words...Link 1 to 2 (between any two neighbour VSF Member) instead of Link 1 to Link 1 (and Link 2 to Link 2)...this alternative way of physically interlinking VSF links recalls what is usually done on IRF deployments.

Laamouri
Occasional Contributor

Re: VSF 2930F Problem

thank you for your feedback

it's works now.
the 2930F switch doesn't support link sfp +
I built the stack using the 1g copper ports.
is there any cable SFP stack 1gig ?

Best Regards

parnassus
Honored Contributor

Re: VSF 2930F Problem

Laamouri wrote: the 2930F switch doesn't support link sfp +

That's not exactly correct...your model (JL261A) doesn't support SFP+ ports, other models do.

To be correct: JL259A, JL260A, JL261A and JL262A don't support SFP+ ports (they all have 4 SFP ports instead), all the other models do support SFP+ ports (from JL253A to JL258A)....and also note that SFP+ ports generally are able to support also SFP Transceivers (1G) other than SFP+ ones (10G)...clearly the contrary is not valid and SFP ports support only SFP Transceivers, not SFP+.


Laamouri wrote: I built the stack using the 1g copper ports.

That's good if the way you deployed your VSF fits your needs in terms of VSF throughput between VSF members.


Laamouri wrote: is there any cable SFP stack 1gig ?

What? I'm not sure I follow you...can you reformulate that question?

osdtech
Occasional Visitor

Re: VSF 2930F Problem

I am having trouble stacking two 2930F switches using the SPF+ ports, I am not using 10G tranceivers though, I am using 1G tranceivers, part number J4858C. I can stack them using copper easily but for some reason fiber is just not working.

I have never worked on Aruba switches before and I am learning as I go using the manuals. I followed the same instructions I used for the copper ports.

Here's what I did:

//On commander switch:

vsf member 1 priority 200

vsf member 1 link 1 49

vsf enable domain 39

//reboot

vsf member 2 type JL256A mac-address ecebb8-cb4e40

vsf member 2 priority 150

vsf member 2 link 1 2/49

I do get a message saying that the stacking port will not be activated because it's a 10G port. I configured vsf port speed to be 1G and i'm not getting that message anymore but the stack is still not forming. Both ports on the commander and the member are solid green when LED is in global mode. In USR mode port 1 blinks green. For good measure I am also adjusting port speed-duplex on member 2 to be 1 G full duplex, to make sure the port is operating at 1G speed, still not working.

I also would like to know if I need to reboot both the commander and the member for the stack to form or can I just connect the member and boot it up.

I've been struggling with this for two weeks now, I would greately appreciate any help, thank you!