LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

cross vlan traffic (vlan 2 to vlan 1) not working

durango099
Occasional Visitor

cross vlan traffic (vlan 2 to vlan 1) not working

Hello experts

 

I have an issue with a scack of 6 total 2910al-48 switches.

 

Devices on vlan 2 can't seem to communicate with vlan 1 - the issue is that the ip helper-address is on vlan 1 as well as the Mitel vMCD. Here is the main switch config:

 

; J9148A Configuration Editor; Created on release #W.15.08.0012
; Ver #02:11.05:16
hostname "SEA-1"
module 1 type j9148a
module 2 type j9008a
qos type-of-service diff-services
stack commander "main"
stack auto-grab
stack member 1 mac-address 6c3be5-f92500
stack member 2 mac-address 6c3be5-fc14c0
stack member 3 mac-address 6c3be5-fc4300
stack member 4 mac-address 6c3be5-fcf240
stack member 5 mac-address a0b3cc-b3a880
time timezone -8
ip default-gateway 10.1.1.1
ip routing
interface 44
   name "Public SIP"
   exit
interface 45
   name "Trunk to QMOE"
   speed-duplex 100-full
   exit
interface 46
   name "Private Prot/Vlan 316"
   exit
interface 47
   name "Public Port/Vlan 315"
   exit
spanning-tree
vlan 1
   name "DEFAULT_VLAN"
   no untagged 44,46
   untagged 1-43,45,48,A1-A2
   tagged 47
   ip address 10.1.1.26 255.255.255.0
   exit
vlan 2
   name "VoIP"
   tagged 1-43,A1-A2
   ip address 10.1.2.1 255.255.255.0
   ip helper-address 10.1.1.28
   qos priority 7
   voice
   exit
vlan 315
   name "Public Vlan"
   untagged 44,47
   tagged 45
   ip address 208.xxx.xxx.xxx 255.255.255.240
   exit
vlan 316
   name "Private Vlan"
   untagged 46
   tagged 45
   no ip address
   exit
password manager
password operator

and except for the address changes the stack members all look the same:

; J9148A Configuration Editor; Created on release #W.15.08.0012
; Ver #02:11.05:16
hostname "SEA-2"
module 1 type j9148a
module 2 type j9008a
power-over-ethernet pre-std-detect
stack join 6c3be5-fcbb00
time timezone -8
snmp-server community "public" unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-48,A1-A2
   ip address 10.1.1.27 255.255.255.0
   exit
vlan 2
   name "VoIP"
   tagged 1-48,A1-A2
   ip address 10.1.2.2 255.255.255.0
   qos priority 7
   voice
   exit
password manager
password operator

Help! I know I am missing something - there is no cross vlan traffic

Mark
2 REPLIES
durango099
Occasional Visitor

Re: cross vlan traffic (vlan 2 to vlan 1) not working

BTW: The Mitel 5330e IP Phones are sitting at DHCP: Discovery and then DHCP: time out ... and so on and so on.
Peter_Debruyne
Honored Contributor

Re: cross vlan traffic (vlan 2 to vlan 1) not working

is ip routing enabled on all stack members ?