11i lvcreate

 
SOLVED
Go to solution
Hubert Feller
Advisor

11i lvcreate

I've just upgraded a server from 11.00 to 11i. Now I recognized that the option -m for the command lvcreate doesn't work anymore. In the man pages it's mentioned but not if you just enter the command. Is this a bug? Or do I miss a patch (I installed the Dec. 02 Base package).
Thanks for your help.
5 REPLIES 5
Ian Dennison_1
Honored Contributor
Solution

Re: 11i lvcreate

-m is for mirror copies - when you upgraded to 11i, did you get codewords for MirrorDiskUX 11i?

What does a swlist tell you?

B2491BA B.11.11 MirrorDisk/UX

Share and Enjoy! Ian
Building a dumber user
melvyn burnard
Honored Contributor

Re: 11i lvcreate

sounds like you did not upgrade your MirrorDisk/UX
during hte upgrade.
check with swlist, and if necessary install hte software.
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
Jeff Schussele
Honored Contributor

Re: 11i lvcreate

Hi Peter,

Since I normally do an initial lvcreate & then come back with an lvextend -m 1, I haven't run across this yet.
Are you specifying TWO separate PVs that are *already* in the VG when you issue the lvcreate command?
What message - if any - do you get?
Does vgdisplay -v show *both* PVs?
Does lvdisplay show mirror copies=1 ?
As far as I know -m in lvcreate should still work if the command is constructed correctly.

Rgds,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
Hubert Feller
Advisor

Re: 11i lvcreate

Thanks for your quick help.
Indeed the mirroring software was missed during the upgrade!
Marlene Smith
Advisor

Re: 11i lvcreate

You'll need to get that reinstalled. Some others that I've noticed that don't "come across" in the upgrade are MC/SG - glance - Online JFS. These items will need to be re-installed. HTH. .