Re: Alternate Link Problem

 
Apollo2000
New Member

Alternate Link Problem

Not sure if I missed a step.
I had 2 disks in vg00
/dev/dsk/c0t8d0s2(boot) and /dev/dsk/c0t10d0.
they are both in PVG0

I tried to mirror them with two other disk in vg00
/dev/dsk/c0t12d0s2 (boot)and /dev/dsk/c0t14d0.

Since I want them seperated I edited the LVMPVG file and put the 3rd and 4th disk under PVG1

However when I do #vgdisplay -v /dev/vg00
I noticed that below had ALTERNATE LINK:

----------------------------------------------
--- Physical volumes ---
PV Name /dev/dsk/c0t8d0s2
PV Status available
Total PE 4228
Free PE 0
Autoswitch On
Proactive Polling On

PV Name /dev/dsk/c0t10d0
PV Name /dev/dsk/c0t14d0 Alternate Link
PV Status available
Total PE 4238
Free PE 3055
Autoswitch On
Proactive Polling On

PV Name /dev/dsk/c0t12d0s2
PV Status available
Total PE 4228
Free PE 942
Autoswitch On
Proactive Polling On

----------

When I vgreduce the /dev/dsk/c0t14d0 the disk information for /dev/dsk/c0t10d0 is displayed again.
Hoever when I extend vg00 with /dev/dsk/c0t14d0 it seems it does something to the /dev/dsk/c0t10d0 , because as you can see above the c0t10d0 info is not displayed and I get this Altrnate link.

Any idea what is going on and how I can fix it.

FYI, this two volumes were used by someone else before as other logival volumes. I did an DD to over write over them and created new device files.
2 REPLIES 2
Torsten.
Acclaimed Contributor

Re: Alternate Link Problem

Hard or impossible to suggest something without knowing the hardware/configuration details. Do you have some more information regarding the disks, connection, etc. ... ?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Apollo2000
New Member

Re: Alternate Link Problem

Not sure what information you needed. Anyway, I was able to fix the issue.

I reduced the 4th (c0t14d0)disk and again did a DD of information from a different disk source, then I deleted all the related device files and used idisk, insf and pvcreate command.

I then did vgextend again and this time it worked with no alternate link issues.

Not sure which step fixed it, but I thought there was something linking:
PV Name /dev/dsk/c0t10d0
PV Name /dev/dsk/c0t14d0 Alternate Link

so started the last disk from scratch it worked.Not sure what was wrong though.

Sorry to have wasted your time.