Re: Full fsck problem

 
SOLVED
Go to solution
Wilder Mellotto
Frequent Advisor

Full fsck problem

Hello

We had an electrical problem on our enviroment and after the rp4440 connected to DS2120 storage the "vg01" shows an error message during mounting a filesystem.

I tried to check with fsck but without success, and I would like to know if there anything that I can do to mount, without formating and restore data back.

#fsck -F vxfs -o full -y /dev/vg01/rlvol1
log replay in progress
vxfs fsck: fsck read failure bno = 3838776, off = 0, len = 8192
full file system check required, exiting ...

Please let me know if you know anything to help me.

 

Thanks

3 REPLIES 3
Bill Hassell
Honored Contributor

Re: Full fsck problem

The read failure indicates a disk problem. You should also see errors in the output from the command: dmesg
You will should also see errors logged in the file /var/adm/syslog/syslog.log

If the lvols in vg01 are mirrored (vgdisplay -v vg01). you can replace the bad disk (identified in syslog.log). Otherwise, you'll have to replace the bad disk and rebuild vg01 and restore the lvol(s) from your backups.

One other possibility: did someone use the lvreduce command?
The read error may be caused by trying to read beyond the end of the lvol.



Bill Hassell, sysadmin
parnassus
Honored Contributor

Re: Full fsck problem

Routine question: was the filesystem check done against a mounted filesystem (probably the rlvol1 was moutned read-only)?

A filesystem check should always be performed against an unmounted filesystem...so try first to unmount (umount) the filesystem which is experiencing the issue and repeat that exact fsck command against it once you're sure it is cleanly unmounted.


I'm not an HPE Employee
Kudos and Accepted Solution banner
Wilder Mellotto
Frequent Advisor
Solution

Re: Full fsck problem

I had no luck with cleaning the filesystem.

After the server and storage went down because a power outage, the fsck failed even when I tried to boot in low maintenance mode, always returing the same message "vxfs fsck: fsck read failure bno = 3838776, off = 0, len = 8192"

I have created a new VG with a new lvol and I did a restore data from a tape drive.

Sadly I lost about 6 hours in this restore procedure, but thanks to all for your answers, because I tried your sugestions before anything else.

Thanks.