I/O errors on a LUN with LVM

 
Etienne Roseau
Frequent Advisor

I/O errors on a LUN with LVM

Hi Gurus !
me again...
i am working on a futur 2nd node for a futur cluster.
the system recognizes well the H/W paths for the LUN but i am unable to recreate the LVM as in the 1st machine.
I firstly took the ignite tape from the first machine, but it's seem to have corrupted the lvmtab ! therefor i removed all the informations about LVM (rm /dev/vgxx, cp lvmtab, rm /dev/(r)dsk/...) reboot, insf...etc...checked the WWN of the FC on the SAN with the array administrator.... but still doesn't work !!!
please have a look attached !
thx in advance for your help !
E.
6 REPLIES 6
Ganesan R
Honored Contributor

Re: I/O errors on a LUN with LVM

Hi,

Are you getting I/O errors only for that particular LUN?

If it is for all LUNs then it should be some issue with storage part.
Best wishes,

Ganesh.
Etienne Roseau
Frequent Advisor

Re: I/O errors on a LUN with LVM

hi !
only for this LUN from this server....
on the first machine it 's working fine !
Torsten.
Acclaimed Contributor

Re: I/O errors on a LUN with LVM

I don't know about the array model and the specific settings, but you should double check them.

Caution: pvcreate will make the data on this device unaccessible!

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Etienne Roseau
Frequent Advisor

Re: I/O errors on a LUN with LVM

i forget the issue of a pvcreate....give me you server & array...just trust me :-)
the array is a EMC², but i don't know the model...
so maybe a vgimport from the 1st server will work, as it should become the 2nd node of a cluster ?
i just know that the admin before me did create (lot of) alternate pathes to the array from the 1st node because he had troubles as well !
Etienne Roseau
Frequent Advisor

Re: I/O errors on a LUN with LVM

i will close this thread....
i'm just a dumb !
have you ever seen the same volume of an array seen by two machines in the same time ?
thanks for your help.
E.
Etienne Roseau
Frequent Advisor

Re: I/O errors on a LUN with LVM

closing thread !
thx everybody