Incorrect filesystem size

 
SOLVED
Go to solution
Vipin Singhal
Super Advisor

Incorrect filesystem size

I have create a new Volume group- VG72 and some file systems, One of filesystems is /PMOR/db/ORPMORP/data/dat02.
These are the details:
/dev/vg72/pmor_data_dat02
18432000 20990 17260329 0% /PMOR/db/ORPMORP/data/dat02
It is of 18GB.

But I am facing some problems when creating tablespace.

I.e. when I try to create tablespace with 400k it is working, if I try the same with 4000m (4GB) is not working.

Please suggest.
Vipin
10 REPLIES 10
James R. Ferguson
Acclaimed Contributor

Re: Incorrect filesystem size

Hi Vipin:

Did you create the filesystem with 'largefiles' enabled? Check this with:

# fstyp -v dev/vg72/pmor_data_dat02

Look for the 'f_flag' value. If it is '16' then you have large file support enabled, otherwise not.

Regards!

...JRF...
HGN
Honored Contributor

Re: Incorrect filesystem size

Hi

You can enable the largefiles options on line with
#fsadm -F vxfs -o largefiles /PMOR/db/ORPMORP/data/dat02

Also you need to update the fstab file also for largefiles.

Rgds

HGN
Vipin Singhal
Super Advisor

Re: Incorrect filesystem size

hi
f_flag value is 0(zero):f_flag: 0,
how i will change it?

this is the /etc/fstab file output -
/dev/vg72/pmor_data_dat02 /PMOR/db/ORPMORP/data/dat02 vxfs rw,suid,delaylog,largefiles 0 2

Please suggest how will i change the f-flag value?
James R. Ferguson
Acclaimed Contributor

Re: Incorrect filesystem size

Hi Vipin:

To enable 'largefiles' (assuming a JFS (vxfs)) filesystem type simply do:

# /usr/sbin/fsadm -F vxfs -o largefiles /dev/vg72/rpmor_data_dat02

Note the use of the RAW (device) file.

If you do not have OnlineJFS, unmount first.

Regards!

...JRF...

Vipin Singhal
Super Advisor

Re: Incorrect filesystem size

# /usr/sbin/fsadm -F vxfs -o largefiles /dev/vg72/rpmor_data_dat02

Should I run only this command or anything i need to do?

this is the output of swlist:
# swlist -l product | grep -i jfs
JFS B.11.23 The Base VxFS File System
OnlineJFS B.11.23.05 Online features of the VxFS File System


this means - does i have "online jfs"?
James R. Ferguson
Acclaimed Contributor
Solution

Re: Incorrect filesystem size

Hi (again) Vipin:

Yes, you have OnlineJFS and do not need to unmount. Run the command as indicated.'

Regards!

...JRF...
Vipin Singhal
Super Advisor

Re: Incorrect filesystem size

Hi James & Everybody,
I have done this:
# /usr/sbin/fsadm -F vxfs -o largefiles /dev/vg72/rpmor_data_dat02


I am not able to create still; I am facing the same problem here.

Please suggest
Vipin Singhal
Super Advisor

Re: Incorrect filesystem size

f_flag: 0
is still zero.
Vipin Singhal
Super Advisor

Re: Incorrect filesystem size

Please update