cancel
Showing results for 
Search instead for 
Did you mean: 

Missing links in LVM

 
Frode Vold
Occasional Advisor

Missing links in LVM

Output from vgdisplay: Couldn't query physical volume "/dev/dsk/c2t1d1". The specified path does not correspond to physical volume attached to this volume group.


The alternate link to this disk have become primary link and the system is online.
Any ideas ?
5 REPLIES 5
Patrick Wessel
Honored Contributor

Re: Missing links in LVM

What kind of disk is connected to the device file "/dev/dsk/c2t1d1"? I guess it's a diskarray, isn't it? In this case, died the array controller or the host bus adapter.

Anyway, it sounds like a Hardware problem to me.

- are you able to perform a "diskinfo /dev/rdsk/c2t1d1"?
- is the disk still visible in ioscan -fn?

There is no good troubleshooting with bad data
Steve White_1
Occasional Advisor

Re: Missing links in LVM

It sounds to me like you have a problem with the SCSI controller.

Jason Luginbuhl
Frequent Advisor

Re: Missing links in LVM

This type of error typically either indicates the HW problems that the previous gentlement have mentioned or in some cases it can be indicative of a "phantom" disk in the vg. If the disk was not properly removed from the vg, it may still be included in some of the LVM tables. In this case, performing a "vgreduce -f vgname" will normally remove the associations to the phantom disks.

However, in this case since you seem to indicate that the device in question is merely an alternate path to an active disk that is not having any problems. If this is the case, then I would have to agree with previous response that it appears to be a problem with the Interface card (SCSI or otherwise) or the cable.
"Unfortunately you can't out-program stupidity"
Frode Vold
Occasional Advisor

Re: Missing links in LVM

The disk is part of an EMC array.
Output from ioscan -fn seems to be OK.
The command diskinfo gives an normal output.

In addition there are other devices connected to the same SCSI-controller that are working properly.
Highlighted
Shyam Kishore
Frequent Advisor

Re: Missing links in LVM

Hi,

The error indicates that one of the controllers in your EMC box is not working.

AS each EMC BOX will have tow controllers, one will be primary and onother is secondary. These two are redundent, if primary fails secondary will take the charge. As each disk in side the box will be monitored by both controllers, each device will have two paths (device files) to your machine.

Now it looks that the primary path to the disk is faild and secondary is become active, so you are not experiencing any problem is using the disk.

You have to replace the primary controller if all the disks are giving same message which are in side the box.

-Shyam
Kids learn from masters, masters from mistakes.