LVM and VxVM

Modifying /etc/fstab after LV creation

 
dictum9
Super Advisor

Modifying /etc/fstab after LV creation


I created a LV, manually mounted it, all is well. But when I modified /etc/fstab, unmounted the LV then tried to do "mount -a", it said:

umount: cannot find /audbu in /etc/mnttab
cannot unmount /audbu

vxfs mount: mount option(s) incompatible with file system /dev/vg10/lvol

Is it because the /etc/mnttab file is not updated with latest /etc/fstab?


manually mounting the LV works....
6 REPLIES 6
A. Clay Stephenson
Acclaimed Contributor

Re: Modifying /etc/fstab after LV creation

I suspect it's because you have largefiles specified as a mount option in /etc/fstab on a filesystem that has not been enabled for largefiles
If it ain't broke, I can fix that.
James R. Ferguson
Acclaimed Contributor

Re: Modifying /etc/fstab after LV creation

Hi:

It sounds as if you have added VxFS (Journaled File System (JFS)) options that are *not* supported unless you have Online JFS.

The options that require Online JFS include '-o mincache=direct' and '-o convosync=direct'.

Regards!

...JRF...
Victor Fridyev
Honored Contributor

Re: Modifying /etc/fstab after LV creation

Hi,

Could you please show /etc/fstan with the change ?
Entities are not to be multiplied beyond necessity - RTFM
Jeff_Traigle
Honored Contributor

Re: Modifying /etc/fstab after LV creation

It would help if we knew what command line you used to mount it successfully and what the /etc/fstab entry is that's not working.
--
Jeff Traigle
Patrick Wallek
Honored Contributor

Re: Modifying /etc/fstab after LV creation

The key is this:

vxfs mount: mount option(s) incompatible with file system /dev/vg10/lvol

What is the line you added to the /etc/fstab?

Did you specify "largefiles" there? If so, is the filesystem set up for largefiles? Remount the filesystem manually and then verify with "fsadm /mountpoint" (where /mountpoint is the path you mounted to).

If the filesystem is not set for largefiles and you specify largefiles in /etc/fstab then you will run into this issue.

The /etc/fstab options and file system creation options must be consistent.
melvyn burnard
Honored Contributor

Re: Modifying /etc/fstab after LV creation

One way I like to use to make sure iot goes into fstab ok is to manually mount the file system, then do:
mount -p |tail -1 >> /etc/fstab

Assuming the manually mounted file system is the last to show up when doing a mount -p

Then manually umount it, then try mount -a
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!