Online JFS

 
Michael Denney
Valued Contributor

Online JFS

OnlineJFS does not appear to be working. Getting the following output from doing a "# fsadm /opt":

fsadm: /etc/defaults/fs is used for determining the file system type
fsam: unrecognized vxfs version number

(all the file systems say the same thing)

OS is hpux11.11 with Gold bundles from 12/06. So, patching is current.

Swlist|grep -i jfs shows:

B3929CA B.11.11 HP OnLineJFS
PHKL_34805 1.0 JFS3.3 patch; mmap

"vxenable -a" is in inittab. Running manually does not help either.


Please help!
16 REPLIES 16
Marco A.
Esteemed Contributor

Re: Online JFS

Hello,

Have you tranferred files to /opt from another server, a 10.20 for example?

Rgds,

Marco
Just unplug and plug in again ....
Michael Denney
Valued Contributor

Re: Online JFS

The system was orginally a 11.00 system. Online_JFS was installed after the upgrade to 11.11.

The problem is not just with /opt, but all file systems..So it must be onlinejfs, not a file system issue. I even created a new lvol/file system to test with.


Here is the output of /opt file system info.

fstyp -v /dev/vg00/lvol4
vxfs
version: 4
f_bsize: 8192
f_frsize: 1024
f_blocks: 3788800
f_bfree: 498399
f_bavail: 467506
f_files: 206900
f_ffree: 124596
f_favail: 124596
f_fsid: 1073741828
f_basetype: vxfs
f_namemax: 254
f_magic: a501fcf5
f_featurebits: 0
f_flag: 0
f_fsindex: 7
f_size: 3788800
Marco A.
Esteemed Contributor

Re: Online JFS

That issue could be generated due to old binaries (11.00) in your new system.

Best rgds,

Marco
Just unplug and plug in again ....
Steven E. Protter
Exalted Contributor

Re: Online JFS

Shalom,

http://seer.support.veritas.com/docs/260954.htm

It would appear the license file is corrupt.

You may need to reinstall OnlineJFS. It may not be designed to survive upgrade-ux.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Michael Denney
Valued Contributor

Re: Online JFS

Installed OnlineJFS after the upgrade to 11.11.
Marco A.
Esteemed Contributor

Re: Online JFS

What is the current version (veritas) ? and what was the previous version? because the 3.4 version doesn't understand the 3.5 format.

Regards,

Marc0
Just unplug and plug in again ....
Geoff Wild
Honored Contributor

Re: Online JFS

Is OnlineJFS installed?
# swlist -l product OnlineJFS

Should see:
OnlineJFS B.11.11 Online features of the VxFS File System


Are we licensed for OnlineJFS?
# vxlicense -p

Should see:
vrts:vxlicense: INFO: Feature name: HP_OnlineJFS [50]
vrts:vxlicense: INFO: Number of licenses: 1 (non-floating)
vrts:vxlicense: INFO: Expiration date: Sun Jun 24 02:00:00 2007 (1065.8 days from now)
vrts:vxlicense: INFO: Release Level: 22
vrts:vxlicense: INFO: Machine Class: All
vrts:vxlicense: INFO: Site ID: 0


Check to see if vxportal in kernel:

# kmsystem -q vxportal

Should see:

Module Configured Loadable
=================================================
vxportal Y -


Check device:
# lsdev | grep 97

Should see:
97 97 vxportal unknown


Is /dev/vxportal corrupt?
# ll /dev/vxportal

Should be like:
crw-r--r-- 1 root sys 97 0x000000 Nov 15 2000 /dev/vxportal

If missing or incorrect permissions:
# rm /dev/vxportal
# mknod /dev/vxportal c 97 0
# chmod 644 /dev/vxportal


If vxportal was not "Configured" in the kernel (from kmsystem command), then rebuild kernel:

# cd /stand/build
# /usr/lbin/sysadm/system_prep -v -s system
This extracts a current copy of your system file into /stand/build/system

Use kmsystem(1M) to modify the system file and system description files.

# kmsystem -c y -S ./system vxportal
NOTE: Redo that same command for each and every driver from the list of drivers above

Build the kernel:
# mk_kernel -s system
The mk_kernel command creates /stand/build/vmunix_test, a kernel ready for testing.

Move the old system file and kernel so if anything goes wrong, you still have a bootable kernel:
# mv /stand/system /stand/system.prev
# mv /stand/vmunix /stand/vmunix.prev
# mv /stand/dlkm /stand/dlkm.vmunix.prev

Move the new system file and new kernel into place, ready to be used when you reboot the system:
# mv /stand/build/system /stand/system
# kmupdate /stand/build/vmunix_test

kmupdate(1M) initiates the automatic move of the specified kernel file, together with its associated directory containing related files, to /stand/vmunix and /stand/dlkm/, respectively, during shutdown.
It also automatically saves the old kernel and its associated directory to /stand/vmunix.prev and /stand/dlkm.vmunix.prev/, respectively.

Reboot the system using the shutdown -r (1M) command (not reboot(1M)).


If none of that applied, and vxlicense -p was okay, try re-enabling the license:

/sbin/fs/vxfs/vxenablef -e online



Try the last step first...

Rgds...Geoff
Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
Michael Denney
Valued Contributor

Re: Online JFS

Geoff,

Every thing checked out you recommended. Still no go.
NMory
Respected Contributor

Re: Online JFS

Michael,

1)What exactly are you trying to do with OnlineJFS?
2) What happends if you try to extend a filesystem? Does it give the same error?

3)Have you check the state of OnlineJFS

#swlist -a state | -i OnlineJFS

4) Have you checked all Disk Layout versions in all the lvols? check if they are all the same.

Regards,

Luis Nassar